Got an issue with playonlinux, their forums are no help

If none of the more specific forums is the right place to ask

Got an issue with playonlinux, their forums are no help

Postby Liamza2314 » 2018-10-17 09:41

Hi everyone, my name is liam and I have an issue with playonlinux
I posted on their forums, my issue has gone unresolved for quite a few days so I'm hoping the debian forums can help
I'm running Debian 9, nvidia proprietary drivers installed with apt-get install nvidia-legacy-304xx-driver as my card is old
I've installed playonlinux, and since I'm running x64 I added the i386 architecture and installed wine-32
Anything that isn't a 3d/dx9 application runs fine, but when I try launch anything heavier, in this case CS:GO, it refuses to launch and spits out:

Code: Select all
err:wgl:has_opengl Failed to load libGL: libGL.so.1: cannot open shared object file: No such file or directory
err:wgl:has_opengl OpenGL support is disabled.


I tried to locate the library with ldconfig -p | grep libGl.so.1 and it points me to /usr/lib86_64 or something like that
I've googled this but the only related guides are for Ubuntu and Arch Linux, which seem to have separate directories for x64 and x32 libs as opposed to debian which seems to toss them all in that lib86_64 directory and this is why wine wont detect it
Native openGL apps work just fine

I'd really appreciate any help, at my wits end lol
Liamza2314
 
Posts: 7
Joined: 2018-10-17 09:18

Re: Got an issue with playonlinux, their forums are no help

Postby arzgi » 2018-10-17 10:07

Code: Select all
apt-file search libGL.so.1
libgl1-glvnd-nvidia-glx: /usr/lib/i386-linux-gnu/nvidia/current/libGL.so.1
libgl1-glvnd-nvidia-glx: /usr/lib/i386-linux-gnu/nvidia/current/libGL.so.1.7.0
libgl1-mesa-glx: /usr/lib/i386-linux-gnu/libGL.so.1
libgl1-mesa-glx: /usr/lib/i386-linux-gnu/libGL.so.1.2.0
libgl1-nvidia-glx: /usr/lib/i386-linux-gnu/nvidia/current/libGL.so.1
libgl1-nvidia-legacy-304xx-glx: /usr/lib/i386-linux-gnu/nvidia/legacy-304xx/libGL.so.1
libgl1-nvidia-legacy-340xx-glx: /usr/lib/i386-linux-gnu/nvidia/legacy-340xx/libGL.so.1
primus-libs: /usr/lib/i386-linux-gnu/primus/libGL.so.1


Hi! I did above apt-file search for file, which caused your error.
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: Got an issue with playonlinux, their forums are no help

Postby Liamza2314 » 2018-10-18 08:10

Will try installing some of these packages when I get the chance, sadly my pc is away from internet so it might be a bit
Liamza2314
 
Posts: 7
Joined: 2018-10-17 09:18


Return to General Questions

Who is online

Users browsing this forum: zerubbabel and 9 guests

fashionable