Installing git-all purges almost everything

If none of the more specific forums is the right place to ask

Installing git-all purges almost everything

Postby nadebula1984 » 2018-11-08 16:43

I used this week's Debian Installer (updated on Nov. 5th) to setup a Debian testing installation with MATE desktop environment.
When I tried to install git-all (git and its all sub-packages), I got the appended information.
If I proceeded, nearly the entire system would be purged. Most importantly, the installation attempted to purge systemd and install init.
When I forced a reboot (the system was largely unusable after purging certain packages such as systemd), I saw init was used rather than systemd, and then the system crashed.
This is reproducible and I believe that this is caused by dependency problem. Certain package(s) depend(s) on init so the package manager attempts to install init, resulting in such chain reaction.

rl@debian:~$ sudo apt install git-all
[sudo] password for rl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
accountsservice albatross-gtk-theme ant ant-contrib ant-optional
blackbird-gtk-theme bluebird-gtk-theme ca-certificates-java caja-common
coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5
coinor-libcoinutils3v5 coinor-libosi1v5 cracklib-runtime default-jre
default-jre-headless dns-root-data dnsmasq-base docbook-xml engrampa
engrampa-common eom eom-common espeak-ng-data exfat-fuse exfat-utils
ffmpegthumbnailer firebird3.0-common firebird3.0-common-doc
firebird3.0-server-core firebird3.0-utils fonts-cantarell
fonts-crosextra-caladea fonts-crosextra-carlito fonts-dejavu
fonts-dejavu-extra fonts-liberation2 fonts-linuxlibertine fonts-noto-hinted
fonts-noto-mono fonts-opensymbol fonts-sil-gentium fonts-sil-gentium-basic
gdisk gimp gimp-data gir1.2-atspi-2.0 gir1.2-gst-plugins-base-1.0
gir1.2-gstreamer-1.0 gir1.2-gtksource-3.0 gir1.2-mate-panel
gir1.2-matepanelapplet-4.0 gir1.2-peas-1.0 gir1.2-pluma-1.0 gir1.2-wnck-3.0
gnome-accessibility-themes gnome-keyring gnome-keyring-pkcs11
gnome-themes-extra gnome-themes-extra-data greybird-gtk-theme gtk2-engines
gtk2-engines-murrine gtk2-engines-pixbuf gvfs-common gvfs-libs hyphen-en-us
java-common javascript-common libabw-0.1-1 libaccountsservice0
libactivation-java libamd2 libao-common libao4 libapache-poi-java
libapache-pom-java libatasmart4 libatk-adaptor libatk-wrapper-java
libatk-wrapper-java-jni libatkmm-1.6-1v5 libaudio2
libayatana-appindicator3-1 libayatana-ido3-0.4-0 libayatana-indicator3-7
libbabl-0.1-0 libbase-java libbcmail-java libbcpkix-java libbcprov-java
libblas3 libblockdev-crypto2 libblockdev-fs2 libblockdev-loop2
libblockdev-part-err2 libblockdev-part2 libblockdev-swap2 libblockdev-utils2
libblockdev2 libbluetooth3 libboost-chrono1.62.0 libboost-date-time1.62.0
libboost-filesystem1.62.0 libboost-iostreams1.62.0 libboost-locale1.62.0
libboost-system1.62.0 libboost-thread1.62.0 libbrlapi0.6 libbsh-java
libcairo-perl libcairomm-1.0-1v5 libcamd2 libccolamd2 libcdio-cdda2
libcdio-paranoia2 libcdio18 libcdr-0.1-1 libcholmod3 libclucene-contribs1v5
libclucene-core1v5 libcmis-0.5-5v5 libcolamd2 libcommons-codec-java
libcommons-collections3-java libcommons-logging-java libcommons-parent-java
libcpufreq0 libcrack2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdom4j-java
libdotconf0 libe-book-0.1-1 libehcache-java libeot0 libept1.5.0
libepubgen-0.1-1 libespeak-ng1 libetonyek-0.1-1 libexempi3 libexif12
libexiv2-14 libexttextcat-2.0-0 libexttextcat-data libfbclient2
libffmpegthumbnailer4v5 libflute-java libfonts-java libformula-java
libfreehand-0.1-1 libgdata-common libgdata22 libgegl-0.4-0 libgegl-common
libgexiv2-2 libgfortran5 libgimp2.0 libglib-perl libglibmm-2.4-1v5
libgoa-1.0-0b libgoa-1.0-common libgpgme11 libgpgmepp6 libgphoto2-6
libgphoto2-l10n libgphoto2-port12 libgtk2-perl libgtkmm-3.0-1v5
libgtksourceview-3.0-1 libgtksourceview-3.0-common libgucharmap-2-90-7
libheif1 libhsqldb1.8.0-java libib-util libicu4j-java libimobiledevice6
libindicator3-7 libintellij-annotations-java libitext-java libjaxen-java
libjcommon-java libjdom1-java libjetbrains-annotations-java libjim0.77
liblangtag-common liblangtag1 liblapack3 liblayout-java libldb1
liblightdm-gobject-1-0 libloader-java liblog4j1.2-java liblouis-data
liblouis16 libmail-java libmate-desktop-2-17 libmate-menu2
libmate-panel-applet-4-1 libmate-slab0 libmate-window-settings1 libmatedict6
libmatekbd-common libmatekbd4 libmatemixer-common libmatemixer0
libmateweather-common libmateweather1 libmbim-glib4 libmbim-proxy libmetis5
libmhash2 libmm-glib0 libmng1 libmspub-0.1-1 libmtp-common libmtp-runtime
libmtp9 libmwaw-0.3-3 libmypaint-1.3-0 libmypaint-common libmythes-1.2-0
libndp0 libneon27-gnutls libnfs11 libnma0 libntfs-3g88 libnumbertext-1.0-0
libnumbertext-data liboauth0 libodfgen-0.1-1 liborcus-0.13-0
libpagemaker-0.0-0 libpam-gnome-keyring libpango-perl libpangomm-1.4-1v5
libparted-fs-resize0 libpcaudio0 libpeas-1.0-0 libpeas-1.0-python2loader
libpeas-common libpentaho-reporting-flow-engine-java libpixie-java libplist3
libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpq5
libpulse-mainloop-glib0 libpwquality-common libpwquality1 libpython2.7
libpython3.6 libqmi-glib5 libqmi-proxy libquadmath0 libqxp-0.0-0
libraptor2-0 librarian0 librasqal3 libraw19 librdf0 libreoffice
libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
libreoffice-base-drivers libreoffice-calc libreoffice-common
libreoffice-core libreoffice-draw libreoffice-gtk3 libreoffice-help-common
libreoffice-help-en-us libreoffice-impress libreoffice-java-common
libreoffice-librelogo libreoffice-math libreoffice-nlpsolver
libreoffice-ogltrans libreoffice-report-builder
libreoffice-report-builder-bin libreoffice-script-provider-bsh
libreoffice-script-provider-js libreoffice-script-provider-python
libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb
libreoffice-sdbc-postgresql libreoffice-style-colibre
libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer
librepository-java librevenge-0.0-0 libsac-java libsaxonhe-java
libsdl1.2debian libserializer-java libservlet3.1-java libsigc++-2.0-0v5
libsmbclient libsonic0 libspeechd2 libstaroffice-0.0-0 libsuitesparseconfig5
libtalloc2 libteamdctl0 libtevent0 libtommath1 libudisks2-0 libumfpack5
libupower-glib3 libusbmuxd4 libvisio-0.1-1 libvolume-key1 libwbclient0
libwmf0.2-7 libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libxapian30
libxerces2-java libxklavier16 libxml-commons-external-java
libxml-commons-resolver1.1-java libxml-java libxmlbeans-java libxmlsec1
libxmlsec1-nss libxom-java libyajl2 libyelp0 libzmf-0.0-0
lightdm-gtk-greeter lp-solve mate-applets-common mate-backgrounds mate-calc
mate-calc-common mate-control-center-common mate-desktop mate-icon-theme
mate-icon-theme-faenza mate-media mate-media-common mate-menus
mate-panel-common mate-polkit-common mate-power-manager-common
mate-screensaver mate-screensaver-common mate-settings-daemon-common
mate-system-monitor mate-system-monitor-common mate-themes mate-user-guide
mate-utils mate-utils-common menu menu-xdg mobile-broadband-provider-info
modemmanager murrine-themes mythes-en-us node-normalize.css ntfs-3g
openjdk-11-jre openjdk-11-jre-headless orca p11-kit p11-kit-modules p7zip
p7zip-full pluma pluma-common python-mate-menu python-talloc python3-brlapi
python3-distro python3-gst-1.0 python3-louis python3-pyatspi python3-speechd
python3-uno python3-xdg rarian-compat samba-libs sgml-base sgml-data
sound-icons speech-dispatcher speech-dispatcher-audio-plugins
speech-dispatcher-espeak-ng uno-libs3 unzip upower ure usb-modeswitch
usb-modeswitch-data usbmuxd xbrlapi xml-core yelp yelp-xsl zip
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
apache2 apache2-bin apache2-data apache2-utils cvs cvsps elpa-async
elpa-dash elpa-ghub elpa-git-commit elpa-let-alist elpa-magit
elpa-magit-popup elpa-with-editor emacs emacs-bin-common emacs-common
emacs-el emacs-gtk git-cvs git-daemon-run git-doc git-el git-email git-gui
git-mediawiki git-svn gitk gitweb imagemagick-6-common initscripts insserv
install-info libalgorithm-c3-perl libapr1 libaprutil1
libaprutil1-dbd-sqlite3 libaprutil1-ldap libb-hooks-endofscope-perl
libb-hooks-op-check-perl libcgi-fast-perl libcgi-pm-perl libclass-c3-perl
libclass-c3-xs-perl libclass-data-inheritable-perl
libclass-factory-util-perl libclass-inspector-perl
libclass-method-modifiers-perl libclass-singleton-perl
libclass-xsaccessor-perl libcommon-sense-perl libcurl4 libdata-optlist-perl
libdatetime-format-builder-perl libdatetime-format-iso8601-perl
libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl
libdatetime-timezone-perl libdbd-sqlite3-perl libdbi-perl
libdevel-callchecker-perl libdevel-caller-perl libdevel-lexalias-perl
libdevel-stacktrace-perl libdigest-bubblebabble-perl libdigest-hmac-perl
libdynaloader-functions-perl libemail-valid-perl libeval-closure-perl
libexception-class-perl libfcgi-perl libfile-sharedir-perl libjson-perl
libjson-xs-perl liblockfile1 liblqr-1-0 liblua5.2-0 libm17n-0
libmagickcore-6.q16-6 libmagickwand-6.q16-6 libmediawiki-api-perl
libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
libnamespace-autoclean-perl libnamespace-clean-perl libnet-dns-perl
libnet-dns-sec-perl libnet-domain-tld-perl libnet-ip-perl libnet-libidn-perl
libotf0 libpackage-deprecationmanager-perl libpackage-stash-perl
libpackage-stash-xs-perl libpadwalker-perl libparams-classify-perl
libparams-util-perl libparams-validate-perl
libparams-validationcompiler-perl libreadonly-perl libref-util-perl
libref-util-xs-perl librole-tiny-perl libserf-1-1 libspecio-perl
libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl
libsub-install-perl libsub-name-perl libsub-quote-perl libsvn-perl libsvn1
libtcl8.6 libterm-readkey-perl libtk8.6 libtypes-serialiser-perl
libutf8proc2 libvariable-magic-perl libyaml-libyaml-perl libyaml-perl
m17n-db runit runit-helper runit-sysv ssl-cert startpar sysv-rc
sysvinit-core tcl tcl8.6 tk tk8.6
Suggested packages:
apache2-doc apache2-suexec-pristine | apache2-suexec-custom mksh rcs
emacs-common-non-dfsg mediawiki subversion bootchart2 libclone-perl
libmldbm-perl libnet-daemon-perl libsql-statement-perl m17n-docs
libmagickcore-6.q16-6-extra libscalar-number-perl libtest-fatal-perl
libyaml-shell-perl gawk openssl-blacklist bum bootlogd tcl-tclreadline
The following packages will be REMOVED:
caja dbus-user-session gnome-disk-utility gvfs gvfs-backends gvfs-daemons
libpam-systemd lightdm mate-applet-brisk-menu mate-applets
mate-control-center mate-desktop-environment mate-desktop-environment-core
mate-panel mate-polkit mate-power-manager mate-settings-daemon
network-manager network-manager-gnome policykit-1 rtkit synaptic
systemd-sysv task-mate-desktop udisks2
The following NEW packages will be installed:
apache2 apache2-bin apache2-data apache2-utils cvs cvsps elpa-async
elpa-dash elpa-ghub elpa-git-commit elpa-let-alist elpa-magit
elpa-magit-popup elpa-with-editor emacs emacs-bin-common emacs-common
emacs-el emacs-gtk git-all git-cvs git-daemon-run git-doc git-el git-email
git-gui git-mediawiki git-svn gitk gitweb imagemagick-6-common initscripts
insserv install-info libalgorithm-c3-perl libapr1 libaprutil1
libaprutil1-dbd-sqlite3 libaprutil1-ldap libb-hooks-endofscope-perl
libb-hooks-op-check-perl libcgi-fast-perl libcgi-pm-perl libclass-c3-perl
libclass-c3-xs-perl libclass-data-inheritable-perl
libclass-factory-util-perl libclass-inspector-perl
libclass-method-modifiers-perl libclass-singleton-perl
libclass-xsaccessor-perl libcommon-sense-perl libcurl4 libdata-optlist-perl
libdatetime-format-builder-perl libdatetime-format-iso8601-perl
libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl
libdatetime-timezone-perl libdbd-sqlite3-perl libdbi-perl
libdevel-callchecker-perl libdevel-caller-perl libdevel-lexalias-perl
libdevel-stacktrace-perl libdigest-bubblebabble-perl libdigest-hmac-perl
libdynaloader-functions-perl libemail-valid-perl libeval-closure-perl
libexception-class-perl libfcgi-perl libfile-sharedir-perl libjson-perl
libjson-xs-perl liblockfile1 liblqr-1-0 liblua5.2-0 libm17n-0
libmagickcore-6.q16-6 libmagickwand-6.q16-6 libmediawiki-api-perl
libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
libnamespace-autoclean-perl libnamespace-clean-perl libnet-dns-perl
libnet-dns-sec-perl libnet-domain-tld-perl libnet-ip-perl libnet-libidn-perl
libotf0 libpackage-deprecationmanager-perl libpackage-stash-perl
libpackage-stash-xs-perl libpadwalker-perl libparams-classify-perl
libparams-util-perl libparams-validate-perl
libparams-validationcompiler-perl libreadonly-perl libref-util-perl
libref-util-xs-perl librole-tiny-perl libserf-1-1 libspecio-perl
libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl
libsub-install-perl libsub-name-perl libsub-quote-perl libsvn-perl libsvn1
libtcl8.6 libterm-readkey-perl libtk8.6 libtypes-serialiser-perl
libutf8proc2 libvariable-magic-perl libyaml-libyaml-perl libyaml-perl
m17n-db runit runit-helper runit-sysv ssl-cert startpar sysv-rc
sysvinit-core tcl tcl8.6 tk tk8.6
0 upgraded, 136 newly installed, 25 to remove and 0 not upgraded.
Need to get 63.8 MB of archives.
After this operation, 162 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
nadebula1984
 
Posts: 4
Joined: 2018-06-03 11:46

Re: Installing git-all purges almost everything

Postby Segfault » 2018-11-08 18:06

Wow, good job. :roll: You do know what apt install git-all does, right?
Segfault
 
Posts: 816
Joined: 2005-09-24 12:24

Re: Installing git-all purges almost everything

Postby stevepusser » 2018-11-08 20:06

At times, Debian testing will suffer some dependency issues as new versions of packages are added. This is not unusual or unexpected, since it's not a release.

If the problem persists, you should file a bug against git-all.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53

Re: Installing git-all purges almost everything

Postby bentHnau » 2018-11-08 20:54

This happened with an attempted installation? I've only ever seen Debian ask me to autoremove huge numbers of packages after something was uninstalled. I didn't expect Testing to have issues this weird.
Debian Stretch x64 on a Dell XPS 17 laptop
bentHnau
 
Posts: 123
Joined: 2014-01-07 01:43
Location: California

Re: Installing git-all purges almost everything

Postby debiman » 2018-11-09 10:16

Segfault wrote:Wow, good job. :roll: You do know what apt install git-all does, right?

that is one weird package!

this is on debian stable (albeit without a gui):
Code: Select all
sudo apt -s install  git-all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  adwaita-icon-theme cvs cvsps dconf-gsettings-backend dconf-service emacs emacs24
  emacs24-bin-common emacs24-common gconf-service gconf2-common git-arch git-cvs git-doc git-el
  git-email git-gui git-mediawiki git-svn gitk gitweb glib-networking glib-networking-common
  glib-networking-services gnutls-bin gsettings-desktop-schemas gtk-update-icon-cache
  hicolor-icon-theme imagemagick-6-common libalgorithm-c3-perl libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libb-hooks-endofscope-perl libcairo-gobject2 libclass-c3-perl
  libclass-data-inheritable-perl libclass-factory-util-perl libclass-method-modifiers-perl
  libclass-singleton-perl libcolord2 libdata-optlist-perl libdatetime-format-builder-perl
  libdatetime-format-iso8601-perl libdatetime-format-strptime-perl libdatetime-locale-perl
  libdatetime-perl libdatetime-timezone-perl libdbd-sqlite3-perl libdbus-glib-1-2 libdconf1
  libdevel-stacktrace-perl libegl1-mesa libepoxy0 libeval-closure-perl libexception-class-perl
  libfftw3-double3 libgbm1 libgconf-2-4 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgif7
  libgnutls-dane0 libgtk-3-0 libgtk-3-common libjson-glib-1.0-0 libjson-glib-1.0-common libjson-perl
  liblockfile1 liblqr-1-0 libltdl7 libm17n-0 libmagickcore-6.q16-3 libmagickwand-6.q16-3
  libmediawiki-api-perl libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
  libnamespace-autoclean-perl libnamespace-clean-perl libotf0 libpackage-deprecationmanager-perl
  libpackage-stash-perl libparams-classify-perl libparams-util-perl libparams-validate-perl
  libparams-validationcompiler-perl libproxy1v5 librest-0.7-0 librole-tiny-perl librsvg2-2
  librsvg2-common libscalar-list-utils-perl libserf-1-1 libsoup-gnome2.4-1 libsoup2.4-1
  libspecio-perl libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl
  libsub-install-perl libsvn-perl libsvn1 libtcl8.6 libterm-readkey-perl libtest-fatal-perl libtk8.6
  libtry-tiny-perl libunbound2 libvariable-magic-perl libwayland-client0 libwayland-cursor0
  libwayland-egl1-mesa libwayland-server0 libxcb-xfixes0 libxcomposite1 libxcursor1 libxft2
  libxinerama1 libxkbcommon0 libxrandr2 libxss1 libxt6 libyaml-perl m17n-db tcl tcl8.6 tk tk8.6 tla
Suggested packages:
  mksh rcs emacs24-common-non-dfsg aspell mediawiki subversion colord libfftw3-bin libfftw3-dev
  dns-root-data gvfs m17n-docs libmagickcore-6.q16-3-extra libscalar-number-perl librsvg2-bin
  libyaml-shell-perl tcl-tclreadline
Recommended packages:
  emacs24-el git-daemon-run | git-daemon-sysvinit libemail-valid-perl at-spi2-core
  libclass-c3-xs-perl libdevel-lexalias-perl libgtk-3-bin libjson-xs-perl libpackage-stash-xs-perl
  libyaml-libyaml-perl | libyaml-syck-perl xterm | x-terminal-emulator tla-doc
The following NEW packages will be installed:
  adwaita-icon-theme cvs cvsps dconf-gsettings-backend dconf-service emacs emacs24
  emacs24-bin-common emacs24-common gconf-service gconf2-common git-all git-arch git-cvs git-doc
  git-el git-email git-gui git-mediawiki git-svn gitk gitweb glib-networking glib-networking-common
  glib-networking-services gnutls-bin gsettings-desktop-schemas gtk-update-icon-cache
  hicolor-icon-theme imagemagick-6-common libalgorithm-c3-perl libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libb-hooks-endofscope-perl libcairo-gobject2 libclass-c3-perl
  libclass-data-inheritable-perl libclass-factory-util-perl libclass-method-modifiers-perl
  libclass-singleton-perl libcolord2 libdata-optlist-perl libdatetime-format-builder-perl
  libdatetime-format-iso8601-perl libdatetime-format-strptime-perl libdatetime-locale-perl
  libdatetime-perl libdatetime-timezone-perl libdbd-sqlite3-perl libdbus-glib-1-2 libdconf1
  libdevel-stacktrace-perl libegl1-mesa libepoxy0 libeval-closure-perl libexception-class-perl
  libfftw3-double3 libgbm1 libgconf-2-4 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgif7
  libgnutls-dane0 libgtk-3-0 libgtk-3-common libjson-glib-1.0-0 libjson-glib-1.0-common libjson-perl
  liblockfile1 liblqr-1-0 libltdl7 libm17n-0 libmagickcore-6.q16-3 libmagickwand-6.q16-3
  libmediawiki-api-perl libmodule-implementation-perl libmodule-runtime-perl libmro-compat-perl
  libnamespace-autoclean-perl libnamespace-clean-perl libotf0 libpackage-deprecationmanager-perl
  libpackage-stash-perl libparams-classify-perl libparams-util-perl libparams-validate-perl
  libparams-validationcompiler-perl libproxy1v5 librest-0.7-0 librole-tiny-perl librsvg2-2
  librsvg2-common libscalar-list-utils-perl libserf-1-1 libsoup-gnome2.4-1 libsoup2.4-1
  libspecio-perl libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl
  libsub-install-perl libsvn-perl libsvn1 libtcl8.6 libterm-readkey-perl libtest-fatal-perl libtk8.6
  libtry-tiny-perl libunbound2 libvariable-magic-perl libwayland-client0 libwayland-cursor0
  libwayland-egl1-mesa libwayland-server0 libxcb-xfixes0 libxcomposite1 libxcursor1 libxft2
  libxinerama1 libxkbcommon0 libxrandr2 libxss1 libxt6 libyaml-perl m17n-db tcl tcl8.6 tk tk8.6 tla
0 upgraded, 132 newly installed, 0 to remove and 0 not upgraded.
Inst liblockfile1 (1.14-1+b1 Debian:9.5/stable [i386])
Inst liblqr-1-0 (0.4.2-2+b2 Debian:9.5/stable [i386])
Inst libfftw3-double3 (3.3.5-3 Debian:9.5/stable [i386])
Inst libltdl7 (2.4.6-2 Debian:9.5/stable [i386])
Inst imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u6 Debian-Security:9/stable [all])
Inst libmagickcore-6.q16-3 (8:6.9.7.4+dfsg-11+deb9u6 Debian-Security:9/stable [i386])
Inst libmagickwand-6.q16-3 (8:6.9.7.4+dfsg-11+deb9u6 Debian-Security:9/stable [i386])
Inst libxss1 (1:1.2.2-1 Debian:9.5/stable [i386])
Inst hicolor-icon-theme (0.15-1 Debian:9.5/stable [all])
Inst libgdk-pixbuf2.0-common (2.36.5-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [all])
Inst libgdk-pixbuf2.0-0 (2.36.5-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst gtk-update-icon-cache (3.22.11-1 Debian:9.5/stable [i386])
Inst librsvg2-2 (2.40.16-1+b1 Debian:9.5/stable [i386])
Inst librsvg2-common (2.40.16-1+b1 Debian:9.5/stable [i386])
Inst adwaita-icon-theme (3.22.0-1+deb9u1 Debian:9.5/stable [all])
Inst cvs (2:1.12.13+real-22+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst cvsps (2.1-8 Debian:9.5/stable [i386])
Inst libdconf1 (0.26.0-2+b1 Debian:9.5/stable [i386])
Inst dconf-service (0.26.0-2+b1 Debian:9.5/stable [i386])
Inst dconf-gsettings-backend (0.26.0-2+b1 Debian:9.5/stable [i386])
Inst emacs24-common (24.5+1-11+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [all])
Inst libunbound2 (1.6.0-3+deb9u1 Debian:9.5/stable, Debian:stable-updates [i386])
Inst libgnutls-dane0 (3.5.8-5+deb9u3 Debian:9.5/stable [i386])
Inst gnutls-bin (3.5.8-5+deb9u3 Debian:9.5/stable [i386])
Inst emacs24-bin-common (24.5+1-11+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst libdbus-glib-1-2 (0.108-2 Debian:9.5/stable [i386])
Inst gconf2-common (3.2.6-4 Debian:9.5/stable [all])
Inst libgconf-2-4 (3.2.6-4+b1 Debian:9.5/stable [i386])
Inst gconf-service (3.2.6-4+b1 Debian:9.5/stable [i386])
Inst libatk1.0-data (2.22.0-1 Debian:9.5/stable [all])
Inst libatk1.0-0 (2.22.0-1 Debian:9.5/stable [i386])
Inst libcairo-gobject2 (1.14.8-1 Debian:9.5/stable [i386])
Inst libgif7 (5.1.4-0.4 Debian:9.5/stable [i386])
Inst libgtk-3-common (3.22.11-1 Debian:9.5/stable [all])
Inst libatspi2.0-0 (2.22.0-6+deb9u1 Debian:9.5/stable [i386])
Inst libatk-bridge2.0-0 (2.22.0-2 Debian:9.5/stable [i386])
Inst libcolord2 (1.3.3-2 Debian:9.5/stable [i386])
Inst libepoxy0 (1.3.1-2 Debian:9.5/stable [i386])
Inst libjson-glib-1.0-common (1.2.6-1 Debian:9.5/stable [all])
Inst libjson-glib-1.0-0 (1.2.6-1 Debian:9.5/stable [i386])
Inst libproxy1v5 (0.4.14-2 Debian:9.5/stable [i386])
Inst glib-networking-common (2.50.0-1 Debian:9.5/stable [all])
Inst glib-networking-services (2.50.0-1+b1 Debian:9.5/stable [i386])
Inst gsettings-desktop-schemas (3.22.0-1 Debian:9.5/stable [all])
Inst glib-networking (2.50.0-1+b1 Debian:9.5/stable [i386])
Inst libsoup2.4-1 (2.56.0-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst libsoup-gnome2.4-1 (2.56.0-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst librest-0.7-0 (0.8.0-2 Debian:9.5/stable [i386])
Inst libwayland-client0 (1.12.0-1 Debian:9.5/stable [i386])
Inst libwayland-cursor0 (1.12.0-1 Debian:9.5/stable [i386])
Inst libwayland-server0 (1.12.0-1 Debian:9.5/stable [i386])
Inst libgbm1 (13.0.6-1+b2 Debian:9.5/stable [i386])
Inst libxcb-xfixes0 (1.12-1 Debian:9.5/stable [i386])
Inst libegl1-mesa (13.0.6-1+b2 Debian:9.5/stable [i386])
Inst libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.5/stable [i386])
Inst libxcomposite1 (1:0.4.4-2 Debian:9.5/stable [i386])
Inst libxcursor1 (1:1.1.14-1+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst libxinerama1 (2:1.1.3-1+b3 Debian:9.5/stable [i386])
Inst libxkbcommon0 (0.7.1-2~deb9u1 Debian:9.5/stable [i386])
Inst libxrandr2 (2:1.5.1-1 Debian:9.5/stable [i386])
Inst libgtk-3-0 (3.22.11-1 Debian:9.5/stable [i386])
Inst libotf0 (0.9.13-3+b1 Debian:9.5/stable [i386])
Inst libxft2 (2.3.2-1+b2 Debian:9.5/stable [i386])
Inst libxt6 (1:1.1.5-1 Debian:9.5/stable [i386])
Inst m17n-db (1.7.0-2 Debian:9.5/stable [all])
Inst libm17n-0 (1.7.0-3+b1 Debian:9.5/stable [i386])
Inst emacs24 (24.5+1-11+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Inst emacs (46.1 Debian:9.5/stable [all])
Inst git-doc (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst git-el (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst tla (1.3.5+dfsg1-2+b1 Debian:9.5/stable [i386])
Inst git-arch (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst libdbd-sqlite3-perl (1.54-1 Debian:9.5/stable [i386])
Inst git-cvs (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst libjson-perl (2.90-1 Debian:9.5/stable [all])
Inst libmediawiki-api-perl (0.41-1 Debian:9.5/stable [all])
Inst libclass-factory-util-perl (1.7-3 Debian:9.5/stable [all])
Inst libparams-classify-perl (0.013-6+b1 Debian:9.5/stable [i386])
Inst libmodule-runtime-perl (0.014-2 Debian:9.5/stable [all])
Inst libtry-tiny-perl (0.28-1 Debian:9.5/stable [all])
Inst libmodule-implementation-perl (0.09-1 Debian:9.5/stable [all])
Inst libsub-exporter-progressive-perl (0.001013-1 Debian:9.5/stable [all])
Inst libvariable-magic-perl (0.61-1 Debian:9.5/stable [i386])
Inst libb-hooks-endofscope-perl (0.21-1 Debian:9.5/stable [all])
Inst libpackage-stash-perl (0.37-1 Debian:9.5/stable [all])
Inst libsub-identify-perl (0.12-2+b1 Debian:9.5/stable [i386])
Inst libnamespace-clean-perl (0.27-1 Debian:9.5/stable [all])
Inst libnamespace-autoclean-perl (0.28-1 Debian:9.5/stable [all])
Inst libparams-util-perl (1.07-3+b1 Debian:9.5/stable [i386])
Inst libsub-install-perl (0.928-1 Debian:9.5/stable [all])
Inst libdata-optlist-perl (0.110-1 Debian:9.5/stable [all])
Inst libsub-exporter-perl (0.986-1 Debian:9.5/stable [all])
Inst libeval-closure-perl (0.14-1 Debian:9.5/stable [all])
Inst libclass-data-inheritable-perl (0.08-2 Debian:9.5/stable [all])
Inst libdevel-stacktrace-perl (2.0200-1 Debian:9.5/stable [all])
Inst libexception-class-perl (1.42-1 Debian:9.5/stable [all])
Inst libscalar-list-utils-perl (1:1.47-1 Debian:9.5/stable [i386])
Inst libparams-validationcompiler-perl (0.23-1 Debian:9.5/stable [all])
Inst libalgorithm-c3-perl (0.10-1 Debian:9.5/stable [all])
Inst libclass-c3-perl (0.32-1 Debian:9.5/stable [all])
Inst libmro-compat-perl (0.12-1 Debian:9.5/stable [all])
Inst libclass-method-modifiers-perl (2.12-1 Debian:9.5/stable [all])
Inst librole-tiny-perl (2.000005-1 Debian:9.5/stable [all])
Inst libtest-fatal-perl (0.014-1 Debian:9.5/stable [all])
Inst libspecio-perl (0.33-1 Debian:9.5/stable [all])
Inst libdatetime-locale-perl (1:1.11-1 Debian:9.5/stable [all])
Inst libclass-singleton-perl (1.5-1 Debian:9.5/stable [all])
Inst libdatetime-timezone-perl (1:2.09-1+2018g Debian:stable-updates [all])
Inst libdatetime-perl (2:1.42-1 Debian:9.5/stable [i386])
Inst libpackage-deprecationmanager-perl (0.17-1 Debian:9.5/stable [all])
Inst libdatetime-format-strptime-perl (1.7200-1 Debian:9.5/stable [all])
Inst libparams-validate-perl (1.26-1 Debian:9.5/stable [i386])
Inst libdatetime-format-builder-perl (0.8100-1 Debian:9.5/stable [all])
Inst libdatetime-format-iso8601-perl (0.08-2 Debian:9.5/stable [all])
Inst git-mediawiki (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst libserf-1-1 (1.3.9-3 Debian:9.5/stable [i386])
Inst libsvn1 (1.9.5-1+deb9u2 Debian:9.5/stable [i386])
Inst libsvn-perl (1.9.5-1+deb9u2 Debian:9.5/stable [i386])
Inst libyaml-perl (1.21-1 Debian:9.5/stable [all])
Inst libterm-readkey-perl (2.37-1 Debian:9.5/stable [i386])
Inst git-svn (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst git-email (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst libtcl8.6 (8.6.6+dfsg-1+b1 Debian:9.5/stable [i386])
Inst libtk8.6 (8.6.6-1+b1 Debian:9.5/stable [i386])
Inst tk8.6 (8.6.6-1+b1 Debian:9.5/stable [i386])
Inst tcl8.6 (8.6.6+dfsg-1+b1 Debian:9.5/stable [i386])
Inst tcl (8.6.0+9 Debian:9.5/stable [i386])
Inst tk (8.6.0+9 Debian:9.5/stable [i386])
Inst git-gui (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst gitk (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst gitweb (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Inst git-all (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf liblockfile1 (1.14-1+b1 Debian:9.5/stable [i386])
Conf liblqr-1-0 (0.4.2-2+b2 Debian:9.5/stable [i386])
Conf libfftw3-double3 (3.3.5-3 Debian:9.5/stable [i386])
Conf libltdl7 (2.4.6-2 Debian:9.5/stable [i386])
Conf imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u6 Debian-Security:9/stable [all])
Conf libmagickcore-6.q16-3 (8:6.9.7.4+dfsg-11+deb9u6 Debian-Security:9/stable [i386])
Conf libmagickwand-6.q16-3 (8:6.9.7.4+dfsg-11+deb9u6 Debian-Security:9/stable [i386])
Conf libxss1 (1:1.2.2-1 Debian:9.5/stable [i386])
Conf hicolor-icon-theme (0.15-1 Debian:9.5/stable [all])
Conf libgdk-pixbuf2.0-common (2.36.5-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [all])
Conf libgdk-pixbuf2.0-0 (2.36.5-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf gtk-update-icon-cache (3.22.11-1 Debian:9.5/stable [i386])
Conf librsvg2-2 (2.40.16-1+b1 Debian:9.5/stable [i386])
Conf librsvg2-common (2.40.16-1+b1 Debian:9.5/stable [i386])
Conf adwaita-icon-theme (3.22.0-1+deb9u1 Debian:9.5/stable [all])
Conf cvs (2:1.12.13+real-22+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf cvsps (2.1-8 Debian:9.5/stable [i386])
Conf libdconf1 (0.26.0-2+b1 Debian:9.5/stable [i386])
Conf dconf-service (0.26.0-2+b1 Debian:9.5/stable [i386])
Conf dconf-gsettings-backend (0.26.0-2+b1 Debian:9.5/stable [i386])
Conf emacs24-common (24.5+1-11+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [all])
Conf libunbound2 (1.6.0-3+deb9u1 Debian:9.5/stable, Debian:stable-updates [i386])
Conf libgnutls-dane0 (3.5.8-5+deb9u3 Debian:9.5/stable [i386])
Conf gnutls-bin (3.5.8-5+deb9u3 Debian:9.5/stable [i386])
Conf emacs24-bin-common (24.5+1-11+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf libdbus-glib-1-2 (0.108-2 Debian:9.5/stable [i386])
Conf gconf2-common (3.2.6-4 Debian:9.5/stable [all])
Conf libgconf-2-4 (3.2.6-4+b1 Debian:9.5/stable [i386])
Conf gconf-service (3.2.6-4+b1 Debian:9.5/stable [i386])
Conf libatk1.0-data (2.22.0-1 Debian:9.5/stable [all])
Conf libatk1.0-0 (2.22.0-1 Debian:9.5/stable [i386])
Conf libcairo-gobject2 (1.14.8-1 Debian:9.5/stable [i386])
Conf libgif7 (5.1.4-0.4 Debian:9.5/stable [i386])
Conf libgtk-3-common (3.22.11-1 Debian:9.5/stable [all])
Conf libatspi2.0-0 (2.22.0-6+deb9u1 Debian:9.5/stable [i386])
Conf libatk-bridge2.0-0 (2.22.0-2 Debian:9.5/stable [i386])
Conf libcolord2 (1.3.3-2 Debian:9.5/stable [i386])
Conf libepoxy0 (1.3.1-2 Debian:9.5/stable [i386])
Conf libjson-glib-1.0-common (1.2.6-1 Debian:9.5/stable [all])
Conf libjson-glib-1.0-0 (1.2.6-1 Debian:9.5/stable [i386])
Conf libproxy1v5 (0.4.14-2 Debian:9.5/stable [i386])
Conf glib-networking-common (2.50.0-1 Debian:9.5/stable [all])
Conf glib-networking-services (2.50.0-1+b1 Debian:9.5/stable [i386])
Conf gsettings-desktop-schemas (3.22.0-1 Debian:9.5/stable [all])
Conf glib-networking (2.50.0-1+b1 Debian:9.5/stable [i386])
Conf libsoup2.4-1 (2.56.0-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf libsoup-gnome2.4-1 (2.56.0-2+deb9u2 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf librest-0.7-0 (0.8.0-2 Debian:9.5/stable [i386])
Conf libwayland-client0 (1.12.0-1 Debian:9.5/stable [i386])
Conf libwayland-cursor0 (1.12.0-1 Debian:9.5/stable [i386])
Conf libwayland-server0 (1.12.0-1 Debian:9.5/stable [i386])
Conf libgbm1 (13.0.6-1+b2 Debian:9.5/stable [i386])
Conf libxcb-xfixes0 (1.12-1 Debian:9.5/stable [i386])
Conf libegl1-mesa (13.0.6-1+b2 Debian:9.5/stable [i386])
Conf libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.5/stable [i386])
Conf libxcomposite1 (1:0.4.4-2 Debian:9.5/stable [i386])
Conf libxcursor1 (1:1.1.14-1+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf libxinerama1 (2:1.1.3-1+b3 Debian:9.5/stable [i386])
Conf libxkbcommon0 (0.7.1-2~deb9u1 Debian:9.5/stable [i386])
Conf libxrandr2 (2:1.5.1-1 Debian:9.5/stable [i386])
Conf libgtk-3-0 (3.22.11-1 Debian:9.5/stable [i386])
Conf libotf0 (0.9.13-3+b1 Debian:9.5/stable [i386])
Conf libxft2 (2.3.2-1+b2 Debian:9.5/stable [i386])
Conf libxt6 (1:1.1.5-1 Debian:9.5/stable [i386])
Conf m17n-db (1.7.0-2 Debian:9.5/stable [all])
Conf libm17n-0 (1.7.0-3+b1 Debian:9.5/stable [i386])
Conf emacs24 (24.5+1-11+deb9u1 Debian:9.5/stable, Debian-Security:9/stable [i386])
Conf emacs (46.1 Debian:9.5/stable [all])
Conf git-doc (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf git-el (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf tla (1.3.5+dfsg1-2+b1 Debian:9.5/stable [i386])
Conf git-arch (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf libdbd-sqlite3-perl (1.54-1 Debian:9.5/stable [i386])
Conf git-cvs (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf libjson-perl (2.90-1 Debian:9.5/stable [all])
Conf libmediawiki-api-perl (0.41-1 Debian:9.5/stable [all])
Conf libclass-factory-util-perl (1.7-3 Debian:9.5/stable [all])
Conf libparams-classify-perl (0.013-6+b1 Debian:9.5/stable [i386])
Conf libmodule-runtime-perl (0.014-2 Debian:9.5/stable [all])
Conf libtry-tiny-perl (0.28-1 Debian:9.5/stable [all])
Conf libmodule-implementation-perl (0.09-1 Debian:9.5/stable [all])
Conf libsub-exporter-progressive-perl (0.001013-1 Debian:9.5/stable [all])
Conf libvariable-magic-perl (0.61-1 Debian:9.5/stable [i386])
Conf libb-hooks-endofscope-perl (0.21-1 Debian:9.5/stable [all])
Conf libpackage-stash-perl (0.37-1 Debian:9.5/stable [all])
Conf libsub-identify-perl (0.12-2+b1 Debian:9.5/stable [i386])
Conf libnamespace-clean-perl (0.27-1 Debian:9.5/stable [all])
Conf libnamespace-autoclean-perl (0.28-1 Debian:9.5/stable [all])
Conf libparams-util-perl (1.07-3+b1 Debian:9.5/stable [i386])
Conf libsub-install-perl (0.928-1 Debian:9.5/stable [all])
Conf libdata-optlist-perl (0.110-1 Debian:9.5/stable [all])
Conf libsub-exporter-perl (0.986-1 Debian:9.5/stable [all])
Conf libeval-closure-perl (0.14-1 Debian:9.5/stable [all])
Conf libclass-data-inheritable-perl (0.08-2 Debian:9.5/stable [all])
Conf libdevel-stacktrace-perl (2.0200-1 Debian:9.5/stable [all])
Conf libexception-class-perl (1.42-1 Debian:9.5/stable [all])
Conf libscalar-list-utils-perl (1:1.47-1 Debian:9.5/stable [i386])
Conf libparams-validationcompiler-perl (0.23-1 Debian:9.5/stable [all])
Conf libalgorithm-c3-perl (0.10-1 Debian:9.5/stable [all])
Conf libclass-c3-perl (0.32-1 Debian:9.5/stable [all])
Conf libmro-compat-perl (0.12-1 Debian:9.5/stable [all])
Conf libclass-method-modifiers-perl (2.12-1 Debian:9.5/stable [all])
Conf librole-tiny-perl (2.000005-1 Debian:9.5/stable [all])
Conf libtest-fatal-perl (0.014-1 Debian:9.5/stable [all])
Conf libspecio-perl (0.33-1 Debian:9.5/stable [all])
Conf libdatetime-locale-perl (1:1.11-1 Debian:9.5/stable [all])
Conf libclass-singleton-perl (1.5-1 Debian:9.5/stable [all])
Conf libdatetime-timezone-perl (1:2.09-1+2018g Debian:stable-updates [all])
Conf libdatetime-perl (2:1.42-1 Debian:9.5/stable [i386])
Conf libpackage-deprecationmanager-perl (0.17-1 Debian:9.5/stable [all])
Conf libdatetime-format-strptime-perl (1.7200-1 Debian:9.5/stable [all])
Conf libparams-validate-perl (1.26-1 Debian:9.5/stable [i386])
Conf libdatetime-format-builder-perl (0.8100-1 Debian:9.5/stable [all])
Conf libdatetime-format-iso8601-perl (0.08-2 Debian:9.5/stable [all])
Conf git-mediawiki (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf libserf-1-1 (1.3.9-3 Debian:9.5/stable [i386])
Conf libsvn1 (1.9.5-1+deb9u2 Debian:9.5/stable [i386])
Conf libsvn-perl (1.9.5-1+deb9u2 Debian:9.5/stable [i386])
Conf libyaml-perl (1.21-1 Debian:9.5/stable [all])
Conf libterm-readkey-perl (2.37-1 Debian:9.5/stable [i386])
Conf git-svn (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf git-email (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf libtcl8.6 (8.6.6+dfsg-1+b1 Debian:9.5/stable [i386])
Conf libtk8.6 (8.6.6-1+b1 Debian:9.5/stable [i386])
Conf tk8.6 (8.6.6-1+b1 Debian:9.5/stable [i386])
Conf tcl8.6 (8.6.6+dfsg-1+b1 Debian:9.5/stable [i386])
Conf tcl (8.6.0+9 Debian:9.5/stable [i386])
Conf tk (8.6.0+9 Debian:9.5/stable [i386])
Conf git-gui (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf gitk (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf gitweb (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
Conf git-all (1:2.11.0-3+deb9u4 Debian-Security:9/stable [all])
WTF does that mean?
User avatar
debiman
 
Posts: 3064
Joined: 2013-03-12 07:18


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable