Suddenly not getting to boot sequence on drive

If none of the more specific forums is the right place to ask

Suddenly not getting to boot sequence on drive

Postby flipjargendy » 2018-11-13 20:28

This system has been running for a couple of years with no major recent changes. It will not even attempt to boot from the SSD. I've booted a live USB and am able to mount the SSD and read files. For some reason, the Lenovo laptop boots directly to a Boot/App menu. When I place an HHD in that has a live system on it, it boots up fine. I suspect that there is something odd going on with the boot partition of the SSD. But I'm shooting in the dark.

Some additional info about the SSD: it is encrypted and passes the Lenovo bios/diagnositcs. The day before, I did update the system, which I do at least once a week. Unfortunately, I did not look to see what the updates were this time. The SDD has Deb 9 on it.
My typewriter never has kernel panic. I hate technology!!!
User avatar
flipjargendy
 
Posts: 60
Joined: 2007-11-12 23:44
Location: Earth

Re: Suddenly not getting to boot sequence on drive

Postby cronoik » 2018-11-13 20:46

flipjargendy wrote: For some reason, the Lenovo laptop boots directly to a Boot/App menu.
Do you mean grub? If this is the case, please boot the system without the parameters "quiet splash" and check the messages.
Have a nice day!
cronoik
 
Posts: 288
Joined: 2015-05-20 21:17

Re: Suddenly not getting to boot sequence on drive

Postby flipjargendy » 2018-11-13 20:58

It may be something specific to Lenovo. Here is a screenshot of a screen like mine: https://lnv.i.lithium.com/t5/image/serv ... 2A81?v=1.0

The computer doesn't even boot to grub at all... it goes straight to the screen in that link.
My typewriter never has kernel panic. I hate technology!!!
User avatar
flipjargendy
 
Posts: 60
Joined: 2007-11-12 23:44
Location: Earth

Re: Suddenly not getting to boot sequence on drive

Postby cronoik » 2018-11-13 21:04

Is the ssd currently connected to the laptop (I'm asking because it isn't listed)? In case it is currently not connected and therefore not listed, what happens when you connect the ssd and selected it in this boot screen (hit enter)? Did you test the ssd with another laptop and tried to boot? Maybe your /boot partition is broken?
Have a nice day!
cronoik
 
Posts: 288
Joined: 2015-05-20 21:17

Re: Suddenly not getting to boot sequence on drive

Postby milomak » 2018-11-13 21:23

what laptop is this?

is it a bios or an uefi one?

sounds like something has changed with the drive order
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop: Lenovo ideapad Y700 [nVidia Optimus] (64-bit) - Debian Sid, Win10,
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Debian Sid
milomak
 
Posts: 1855
Joined: 2009-06-09 22:20

Re: Suddenly not getting to boot sequence on drive

Postby flipjargendy » 2018-11-13 21:27

I guess, it would be UEFI... its a Lenovo E560. I turned off Legacy booting in favor of UEFI.

sounds like something has changed with the drive order


Do mean that the partitions could have changed number or something?

EDIT: I should mention that when I choose the SDD, it just returns to the boot/app menu screen again. Also, I don't have another laptop to test with like cronoik suggested....... I'm backing up my home dir right now and am going to setup a new system.
My typewriter never has kernel panic. I hate technology!!!
User avatar
flipjargendy
 
Posts: 60
Joined: 2007-11-12 23:44
Location: Earth


Return to General Questions

Who is online

Users browsing this forum: jrobin28260 and 7 guests

fashionable