Many Error While Updating

If none of the more specific forums is the right place to ask

Many Error While Updating

Postby intellinux420 » 2018-11-14 09:45

I have installed Debian 9 using a pen drive. I have already used su - command to become root user. When reloading Synaptic package manager I get: The repository 'cdrom://[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25] stretch Release' does not have a Release file.

Every time when using apt-get update I get these many errors:

W: The repository 'cdrom://[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25] stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
E: Failed to fetch cdrom://[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25]/dists/stretch/main/binary-amd64/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
E: Some index files failed to download. They have been ignored, or old ones used instead.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:3 and /etc/apt/sources.list:5

I am trying all different things to correct this. I have reinstalled Debian 9 about 6 time and breaking it again and again by doing all crap I get in google.
Please Help...

Thanks and here is the source list:


deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25]/ stretch main

deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25]/ stretch main

deb http://ftp.us.debian.org/debian/ stretch main non-free
deb-src http://ftp.us.debian.org/debian/ stretch main non-free

deb http://security.debian.org/debian-security/ stretch/updates main non-free
deb-src http://security.debian.org/debian-security/ stretch/updates main non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main non-free
deb-src http://ftp.us.debian.org/debian/ stretch-updates main non-free
Last edited by intellinux420 on 2018-11-14 11:47, edited 1 time in total.
intellinux420
 
Posts: 3
Joined: 2018-11-14 09:23

Re: Many Error While Updating

Postby arochester » 2018-11-14 10:53

It would have helped if you had included your sources list.

The CD is still listed as a Repository in your sources list.

You can disable it by putting a # at the beginning of the CD line.
arochester
 
Posts: 1349
Joined: 2010-12-07 19:55

Re: Many Error While Updating

Postby arochester » 2018-11-14 11:57

Change it to this
Code: Select all

deb http://ftp.us.debian.org/debian/ stretch main non-free
deb http://ftp.us.debian.org/debian/ stretch-updates main non-free
deb http://security.debian.org/debian-security/ stretch/updates main


"Security" only does "main"
arochester
 
Posts: 1349
Joined: 2010-12-07 19:55

Re: Many Error While Updating

Postby intellinux420 » 2018-11-14 12:50

I removed all lines from sources.list and copy and pasted those 3 lines.
That worked.

Do I have to add any more lines ?
How can I Mark my post as answered ?

Thanks
intellinux420
 
Posts: 3
Joined: 2018-11-14 09:23

Re: Many Error While Updating

Postby None1975 » 2018-11-14 13:00

intellinux420 wrote:Do I have to add any more lines ?Thanks

Hello. Check this.
User avatar
None1975
 
Posts: 703
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: Many Error While Updating

Postby intellinux420 » 2018-11-15 10:37

That Helped
Thanks
intellinux420
 
Posts: 3
Joined: 2018-11-14 09:23


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable