Cannot install libgtk-3-dev and others [SOLVED]

If none of the more specific forums is the right place to ask

Cannot install libgtk-3-dev and others [SOLVED]

Postby Scorpion » 2018-11-24 20:46

Code: Select all
apt install libgtk-3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk-3-dev : Depends: libegl1-mesa-dev but it is not going to be installed
                Depends: libwayland-dev (>= 1.9.91) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

(Also aptitude fails). So I tried to install the missing dependencies:
Code: Select all
apt install libegl1-mesa-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libegl1-mesa-dev : Depends: libegl1-mesa (= 13.0.6-1+b2) but 18.1.9-1~bpo9+1 is to be installed
                    Depends: libwayland-egl1-mesa (= 13.0.6-1+b2)
                    Depends: libwayland-dev (>= 1.2.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: Select all
apt install libwayland-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwayland-dev : Depends: libwayland-client0 (= 1.12.0-1) but 1.16.0-1~bpo9+1 is to be installed
                  Depends: libwayland-server0 (= 1.12.0-1) but 1.16.0-1~bpo9+1 is to be installed
E: Unable to correct problems, you have held broken packages.

How so? Is a fresh installation. Should I fill a bug?
How is possible that debian doesn' t support libgtk-3-dev?
Last edited by Scorpion on 2018-11-25 08:55, edited 1 time in total.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Head_on_a_Stick » 2018-11-24 20:48

In case of dependency problems, always post your sources:
Code: Select all
apt policy
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8324
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-24 20:53

Code: Select all
apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 100 http://ftp.debian.org/debian stretch-backports/non-free amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=non-free,b=amd64
     origin ftp.debian.org
 100 http://ftp.debian.org/debian stretch-backports/contrib amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=contrib,b=amd64
     origin ftp.debian.org
 100 http://ftp.debian.org/debian stretch-backports/main amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=amd64
     origin ftp.debian.org
 500 http://security.debian.org/debian-security stretch/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch/non-free amd64 Packages
     release v=9.6,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch/contrib amd64 Packages
     release v=9.6,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch/main amd64 Packages
     release v=9.6,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin deb.debian.org
Pinned packages:
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Head_on_a_Stick » 2018-11-24 21:13

What does this say
Code: Select all
aptitude why-not libegl1-mesa

Do you have many packages installed from backports?
aptitude fails

Does it offer any choices for resolution? The exact error messages are always preferred.
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8324
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Cannot install libgtk-3-dev and others, broken packages

Postby stevepusser » 2018-11-24 21:29

Since you have installed certain runtime libraries from stretch-backports, you will also have to install the various matching -dev packages which libgtk-3-dev depends on from stretch-backports as necessary.

That's not a bug, that's just how these things work.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10278
Joined: 2009-10-06 05:53

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-24 22:24

stevepusser wrote:Since you have installed certain runtime libraries from stretch-backports, you will also have to install the various matching -dev packages which libgtk-3-dev depends on from stretch-backports as necessary.

That's not a bug, that's just how these things work.

How am I supposed to do that? There is some problem.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-24 22:27

Head_on_a_Stick wrote:What does this say
Code: Select all
aptitude why-not libegl1-mesa

Do you have many packages installed from backports?
aptitude fails

Does it offer any choices for resolution? The exact error messages are always preferred.

It is installed but is the newest version, it seems that I need to downgrade.
Code: Select all
aptitude install libegl1-mesa
libegl1-mesa is already installed at the requested version (18.1.9-1~bpo9+1)
libegl1-mesa is already installed at the requested version (18.1.9-1~bpo9+1)
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-24 22:33

Option 1:
aptitude install libgtk-3-dev
The following NEW packages will be installed:
libegl1-mesa-dev{ab} libgtk-3-dev libwayland-bin{a} libwayland-dev{ab}
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,117 kB of archives. After unpacking 12.1 MB will be used.
The following packages have unmet dependencies:
libegl1-mesa-dev : Depends: libegl1-mesa (= 13.0.6-1+b2) but 18.1.9-1~bpo9+1 is installed
Depends: libwayland-egl1-mesa (= 13.0.6-1+b2) but 18.1.9-1~bpo9+1 is installed
libwayland-dev : Depends: libwayland-client0 (= 1.12.0-1) but 1.16.0-1~bpo9+1 is installed
Depends: libwayland-server0 (= 1.12.0-1) but 1.16.0-1~bpo9+1 is installed
libglvnd-dev : Breaks: libegl1-mesa-dev (< 17.2.0~rc4-1) but 13.0.6-1+b2 is to be installed
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) libegl1-mesa-dev [Not Installed]
2) libgtk-3-dev [Not Installed]
3) libwayland-dev [Not Installed]



Accept this solution? [Y/n/q/?]

Nothing happens if I accept.
2:
Code: Select all
aptitude install libgtk-3-dev
The following NEW packages will be installed:
  libegl1-mesa-dev{ab} libgtk-3-dev libwayland-bin{a} libwayland-dev{ab}
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,117 kB of archives. After unpacking 12.1 MB will be used.
The following packages have unmet dependencies:
 libegl1-mesa-dev : Depends: libegl1-mesa (= 13.0.6-1+b2) but 18.1.9-1~bpo9+1 is installed
                    Depends: libwayland-egl1-mesa (= 13.0.6-1+b2) but 18.1.9-1~bpo9+1 is installed
 libwayland-dev : Depends: libwayland-client0 (= 1.12.0-1) but 1.16.0-1~bpo9+1 is installed
                  Depends: libwayland-server0 (= 1.12.0-1) but 1.16.0-1~bpo9+1 is installed
 libglvnd-dev : Breaks: libegl1-mesa-dev (< 17.2.0~rc4-1) but 13.0.6-1+b2 is to be installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libegl1-mesa-dev [Not Installed]                   
2)     libgtk-3-dev [Not Installed]                       
3)     libwayland-dev [Not Installed]                     



Accept this solution? [Y/n/q/?] .
The following actions will resolve these dependencies:

     Install the following packages:                                           
1)     libegl1-mesa-dev [18.1.9-1~bpo9+1 (stretch-backports)]                   
2)     libwayland-bin [1.16.0-1~bpo9+1 (stretch-backports)]                     
3)     libwayland-dev [1.16.0-1~bpo9+1 (stretch-backports)]                     

     Upgrade the following packages:                                           
4)     libwayland-cursor0 [1.12.0-1 (now, stable) -> 1.16.0-1~bpo9+1 (stretch-ba



Accept this solution? [Y/n/q/?] y

Works for libgtk-3-dev. I still need one package:
Option 1 (other package):
Code: Select all
apt build-dep vlc
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:vlc : Depends: libgles2-mesa-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@debian-desktop:~# aptitude build-dep vlc
The following NEW packages will be installed:
  libgles2-mesa-dev{b}
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 75.6 kB of archives. After unpacking 622 kB will be used.
The following packages have unmet dependencies:
 libglvnd-dev : Breaks: libgles2-mesa-dev (< 17.2.0~rc4-1) but 13.0.6-1+b2 is to be installed
 libgles2-mesa-dev : Depends: libgles2-mesa (= 13.0.6-1+b2) but 18.1.9-1~bpo9+1 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libgles2-mesa-dev [Not Installed]                 



Accept this solution? [Y/n/q/?]


Nothing happens.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby stevepusser » 2018-11-24 22:53

I've had to go through over thirty different solutions with aptitude until it finally came up with the correct one--are you giving up after just one?

If you want to build a package in the cloud on a basic, vanilla Stretch, you can also do that on the free OpenSuse Build Service. There's a beginner's guide in the HowTo section here by yrs truly, or you can also do that on your own system with pbuilder, which is also pretty cool.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10278
Joined: 2009-10-06 05:53

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-25 08:05

I tried a lot of things aptitude buidl-dep installed a bunch of packages.
The problem is that now:
Option 2:
Code: Select all
     
...
 Remove the following packages:                                                           
1)      libegl-mesa0 [18.1.9-1~bpo9+1 (now, stretch-backports)]                               
2)      libegl1 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                     
3)      libgl1 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                       
4)      libgl1-nvidia-glvnd-glx [390.87-2~bpo9+1 (now, stretch-backports)]                     
5)      libgles-nvidia2 [390.87-2~bpo9+1 (now, stretch-backports)]                             
6)      libgles2 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                     
7)      libglvnd-dev [1.1.0-1~bpo9+1 (now, stretch-backports)]                                 
8)      libglx-mesa0 [18.1.9-1~bpo9+1 (now, stretch-backports)]                               
9)      libglx-nvidia0 [390.87-2~bpo9+1 (now, stretch-backports)]                             
10)     libglx0 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                     
11)     libwayland-egl1 [1.16.0-1~bpo9+1 (now, stretch-backports)]                             
12)     nvidia-driver [390.87-2~bpo9+1 (now, stretch-backports)]                               
13)     nvidia-driver-libs [390.87-2~bpo9+1 (now, stretch-backports)]                         
14)     nvidia-egl-icd [390.87-2~bpo9+1 (now, stretch-backports)]                             
15)     nvidia-vulkan-common [390.87-2~bpo9+1 (now, stretch-backports)]                       
16)     nvidia-vulkan-icd [390.87-2~bpo9+1 (now, stretch-backports)]   

I' m using the 4.18 kernel if I remove the nvida-driver 390 my machine won't boot.
I checked other 40 options but are always like this:
Code: Select all
     
...
Remove the following packages:                                                           
1)      libcuda1 [390.87-2~bpo9+1 (now, stretch-backports)]                                   
2)      libcuinj64-9.1 [9.1.85-4~bpo9+1 (now, stretch-backports)]                             
3)      libegl-mesa0 [18.1.9-1~bpo9+1 (now, stretch-backports)]                               
4)      libegl1 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                     
5)      libgl1 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                       
6)      libgl1-nvidia-glvnd-glx [390.87-2~bpo9+1 (now, stretch-backports)]                     
7)      libgles-nvidia2 [390.87-2~bpo9+1 (now, stretch-backports)]                             
8)      libgles2 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                     
9)      libglvnd-dev [1.1.0-1~bpo9+1 (now, stretch-backports)]                                 
10)     libglx-mesa0 [18.1.9-1~bpo9+1 (now, stretch-backports)]                               
11)     libglx0 [1.1.0-1~bpo9+1 (now, stretch-backports)]                                     
12)     libnvcuvid1 [390.87-2~bpo9+1 (now, stretch-backports)]                                 
13)     libwayland-egl1 [1.16.0-1~bpo9+1 (now, stretch-backports)]                             
14)     nvidia-cuda-dev [9.1.85-4~bpo9+1 (now, stretch-backports)]                             
15)     nvidia-cuda-toolkit [9.1.85-4~bpo9+1 (now, stretch-backports)]                         
16)     nvidia-driver [390.87-2~bpo9+1 (now, stretch-backports)]                               
17)     nvidia-driver-bin [390.87-2~bpo9+1 (now, stretch-backports)]                           
18)     nvidia-driver-libs [390.87-2~bpo9+1 (now, stretch-backports)]                         
19)     nvidia-egl-icd [390.87-2~bpo9+1 (now, stretch-backports)]                             
20)     nvidia-opencl-icd [390.87-2~bpo9+1 (now, stretch-backports)]                           
21)     nvidia-profiler [9.1.85-4~bpo9+1 (now, stretch-backports)]                             
22)     nvidia-smi [390.87-2~bpo9+1 (now, stretch-backports)]                                 
23)     nvidia-vdpau-driver [390.87-2~bpo9+1 (now, stretch-backports)]                         
24)     nvidia-visual-profiler [9.1.85-4~bpo9+1 (now, stretch-backports)]                     
25)     xserver-xorg-video-nvidia [390.87-2~bpo9+1 (now, stretch-backports)]                   

      Install the following packages:                                                         
26)     libglx0-glvnd-nvidia [384.130-1 (stable)]                                             

      Downgrade the following packages:                                                       
27)     glx-alternative-mesa [0.8.8~bpo9+1 (now, stretch-backports) -> 0.8.3~deb9u1 (stable)] 
28)     glx-alternative-nvidia [0.8.8~bpo9+1 (now, stretch-backports) -> 0.8.3~deb9u1 (stable)]
29)     glx-diversions [0.8.8~bpo9+1 (now, stretch-backports) -> 0.8.3~deb9u1 (stable)]       
30)     libegl-nvidia0 [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]       
31)     libegl1-mesa [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]       
32)     libegl1-mesa-dev [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]   
33)     libgbm1 [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]             
34)     libgl1-mesa-dev [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]     
35)     libgl1-mesa-glx [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]     
36)     libglapi-mesa [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]       
37)     libgles2-mesa [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]       
38)     libglx-nvidia0 [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]       
39)     libnvidia-cfg1 [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]       
40)     libnvidia-egl-wayland1 [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]
41)     libnvidia-eglcore [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]     
42)     libnvidia-glcore [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]     
43)     libnvidia-ml1 [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]         
44)     libwayland-bin [1.16.0-1~bpo9+1 (now, stretch-backports) -> 1.12.0-1 (stable)]         
45)     libwayland-client0 [1.16.0-1~bpo9+1 (now, stretch-backports) -> 1.12.0-1 (stable)]     
46)     libwayland-cursor0 [1.16.0-1~bpo9+1 (now, stretch-backports) -> 1.12.0-1 (stable)]     
47)     libwayland-dev [1.16.0-1~bpo9+1 (now, stretch-backports) -> 1.12.0-1 (stable)]         
48)     libwayland-egl1-mesa [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]
49)     libwayland-server0 [1.16.0-1~bpo9+1 (now, stretch-backports) -> 1.12.0-1 (stable)]     
50)     mesa-common-dev [18.1.9-1~bpo9+1 (now, stretch-backports) -> 13.0.6-1+b2 (stable)]     
51)     nvidia-alternative [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]   
52)     nvidia-egl-wayland-icd [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]
53)     nvidia-kernel-support [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]
54)     nvidia-vulkan-icd [390.87-2~bpo9+1 (now, stretch-backports) -> 384.130-1 (stable)]     
55)     update-glx [0.8.8~bpo9+1 (now, stretch-backports) -> 0.8.3~deb9u1 (stable)]           

      Leave the following dependencies unresolved:                                             
56)     nvidia-settings recommends libgl1-nvidia-glvnd-glx | libgl1-nvidia-glx                 
57)     nvidia-settings recommends nvidia-vdpau-driver                                         
58)     libcudart9.1 recommends libcuda1 (>= 387.26) | libcuda-9.1-1                           
59)     nvidia-cuda-dev recommends libcuda1 (>= 387.26) | libcuda-9.1-1                       
60)     nvidia-opencl-dev recommends nvidia-opencl-icd                                         
61)     nvidia-driver-bin recommends nvidia-driver                                             
62)     nvidia-kernel-dkms recommends nvidia-driver (>= 390.87) | libcuda1 (>= 390.87)         
63)     nvidia-opencl-common recommends nvidia-opencl-icd | nvidia-legacy-390xx-opencl-icd     
64)     xserver-xorg-video-nvidia recommends nvidia-driver (>= 390.87)                         
65)     xserver-xorg-video-nvidia recommends nvidia-vdpau-driver (>= 390.87)     

Should I keep checking?Will aptitude tell me that i saw all the options?
Maybe is there a problem with the 390 driver?
With package should I build to fix my problem?
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-25 08:17

Code: Select all
aptitude build-dep libgles2-mesa-dev
[Solution 1 nothing happens]
The following actions will resolve these dependencies:

     Remove the following packages:                                                           
1)     nvidia-vulkan-icd [390.87-2~bpo9+1 (now, stretch-backports)]                           

     Downgrade the following packages:                                                         
2)     libvulkan1 [1.1.70+dfsg1-1~bpo9+1 (now, stretch-backports) -> 1.0.39.0+dfsg1-1 (stable)]

     Leave the following dependencies unresolved:                                             
3)     nvidia-driver-libs recommends nvidia-vulkan-icd (= 390.87-2~bpo9+1)                     
4)     nvidia-vulkan-common recommends nvidia-vulkan-icd | nvidia-legacy-390xx-vulkan-icd     



Accept this solution? [Y/n/q/?]

If I remove nvidia-vulkan-icd [390.87-2~bpo9+1 (now, stretch-backports), will cuda and the driver have problems?
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others, broken packages

Postby Scorpion » 2018-11-25 08:45

I checked it should be fine without.
i ran aptitude build-dep libgles2-mesa-dev but it only removed the packages without installing ibgles2-mesa-dev.
Code: Select all
aptitude why-not libgles2-mesa-dev
i   libgtk-3-dev     Depends libegl1-mesa-dev                 
i A libegl1-mesa-dev Depends libglvnd-dev                     
i A libglvnd-dev     Breaks  libgles2-mesa-dev (< 17.2.0~rc4-1)
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others [SOLVED]

Postby Scorpion » 2018-11-25 08:52

stevepusser wrote:Since you have installed certain runtime libraries from stretch-backports, you will also have to install the various matching -dev packages which libgtk-3-dev depends on from stretch-backports as necessary.

That's not a bug, that's just how these things work.

Right I need to use the backports, thanks. :D
Code: Select all
aptitude install -t stretch-backports libgles2-mesa-dev

I made a lot of unnecessary comments, the solution was very easy.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Cannot install libgtk-3-dev and others [SOLVED]

Postby stevepusser » 2018-11-25 19:34

Another way around it would be to use Synaptic. After enabling backports and reloading, you can tell Synaptic to prefer packages from backports to get around the low pinning status. Remember to revert all those settings changes after you disable the backports repo, too,because Synaptic has a sort of bug where it won't start if it's left preferring a deactivated repository.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10278
Joined: 2009-10-06 05:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable