Install anbox from stretch-backports

If none of the more specific forums is the right place to ask

Install anbox from stretch-backports

Postby Bloris » 2019-02-05 17:00

Hiiiiii :D

I'm trying to install anbox from stretch-backports and it gives me dependency problem:

Code: Select all
root@msi:/home/xxx# apt-get install anbox
 anbox : Dipende: libegl1 ma non sta per essere installato


I've already installed libegl1-mesa

Code: Select all
dpkg -l | grep libegl
ii  libegl1-mesa:amd64                            13.0.6-1+b2                                amd64        free implementation of the EGL API -- runtime
ii  libegl1-mesa:i386                             13.0.6-1+b2                                i386         free implementation of the EGL API -- runtime


There is a way to fix this without destroy something?

Sorry for my bad english.

Thank you,
Loris
Bloris
 
Posts: 24
Joined: 2018-12-09 15:53

Re: Install anbox from stretch-backports

Postby Head_on_a_Stick » 2019-02-05 18:56

Try
Code: Select all
# aptitude install -t stretch-backports anbox

If that doesn't work then specify the dependency manually:
Code: Select all
# apt install -t stretch-backports anbox libegl1
User avatar
Head_on_a_Stick
 
Posts: 10335
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Install anbox from stretch-backports

Postby stevepusser » 2019-02-05 19:13

You'll need to add libegl1:i386 to that command in your case, too...possibly more packages, too. It might just be easier to upgrade to backport's Mesa packages if that's what it wants.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Foliate 1.5.3, Minitube 3.1, wine-staging 4.12, Virtual Box 5.2.32 & 6.0.10, Pale Moon 28.6.1, Waterfox 56.2.12
User avatar
stevepusser
 
Posts: 11007
Joined: 2009-10-06 05:53

Re: Install anbox from stretch-backports

Postby Bloris » 2019-02-05 20:30

I was able to install it using apt command, but it simply crash during the loading... giving me this message:

Code: Select all
kernel: vgaarb: this pci device is not a vga device


It could be mine missconfiguration or it is a bug to report?
Bloris
 
Posts: 24
Joined: 2018-12-09 15:53

Re: Install anbox from stretch-backports

Postby GarryRicketson » 2019-02-05 21:16

Why not show us the output of :
Code: Select all
lspci
first, the error says you do NOT have a
vga device.
https://www.systutorials.com/docs/linux/man/8-lspci/
==========
https://wiki.debian.org/HowToIdentifyADevice/PCI
User avatar
GarryRicketson
 
Posts: 5877
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Install anbox from stretch-backports

Postby Bloris » 2019-02-05 21:32

Sorry, but i thought was obvious i had the vga :P My bad anyway

Code: Select all
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)
03:00.0 Ethernet controller: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller (rev 10)
Bloris
 
Posts: 24
Joined: 2018-12-09 15:53

Re: Install anbox from stretch-backports

Postby Head_on_a_Stick » 2019-02-06 07:02

Bloris wrote:
Code: Select all
kernel: vgaarb: this pci device is not a vga device

Put this error message into your favourite search engine, looks like it's related to Bumblebee.
User avatar
Head_on_a_Stick
 
Posts: 10335
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Install anbox from stretch-backports

Postby Bloris » 2019-02-06 08:00

Already did, but i dont have bumblebee installed.

I've NVIDIA Drivers, but no Bumblebee configuration. Anyway i will continue to search something.

Ty
Bloris
 
Posts: 24
Joined: 2018-12-09 15:53

Re: Install anbox from stretch-backports

Postby stevepusser » 2019-02-07 22:59

Bloris wrote:Already did, but i dont have bumblebee installed.

I've NVIDIA Drivers, but no Bumblebee configuration. Anyway i will continue to search something.

Ty


Wait, what? What's going on with your graphics, then?

To tell us, install inxi and report the output of
Code: Select all
inxi -Gxxx


BTW, Skylake Intel graphics require firmware-misc-nonfree be installed to work correctly.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Foliate 1.5.3, Minitube 3.1, wine-staging 4.12, Virtual Box 5.2.32 & 6.0.10, Pale Moon 28.6.1, Waterfox 56.2.12
User avatar
stevepusser
 
Posts: 11007
Joined: 2009-10-06 05:53


Return to General Questions

Who is online

Users browsing this forum: efrpcabo, Head_on_a_Stick, peter_irich and 13 guests

fashionable