Trying to watch Netflix on Debian using Firefox

If none of the more specific forums is the right place to ask

Trying to watch Netflix on Debian using Firefox

Postby albsanrom » 2019-02-07 18:35

I am using Debian Stretch and and Firefox 60.5.0esr (64-bit). Widevine and OpenH264 are installed in Add-ons and I toggled 'Play DRM-controlled content' in Preferences. However I am still unable to use Netflix on my browser. The alert 'Firefox is installing components needed to play the audio or video on this page. Please try again later.' keeps popping up on top of the screen.
albsanrom
 
Posts: 4
Joined: 2019-02-07 18:31

Re: Trying to watch Netflix on Debian using Firefox

Postby arochester » 2019-02-07 18:51

Were to attached to the Internet and did it install Widevine?

https://itsfoss.com/netflix-firefox-linux/
arochester
 
Posts: 1390
Joined: 2010-12-07 19:55

Re: Trying to watch Netflix on Debian using Firefox

Postby bw123 » 2019-02-07 19:05

I have it all turned off, but did you check these and all the other media.gmp settings? Does it work on chromium browser?
Code: Select all
// Disable Freedom Violating DRM Feature
pref("browser.eme.ui.enabled", false);
// EME
pref("media.eme.enabled", false);
pref("media.eme.apiVisible", false);

// Google Widevine DRM
// https://blog.mozilla.org/futurereleases/2016/04/08/mozilla-to-test-widevine-cdm-in-firefox-nightly/
// https://wiki.mozilla.org/QA/Widevine_CDM
// https://bugzilla.mozilla.org/show_bug.cgi?id=1288580
pref("media.gmp-widevinecdm.visible", false);
pref("media.gmp-widevinecdm.enabled", false);
pref("media.gmp-widevinecdm.autoupdate", false);
// Disable openh264.
pref("media.gmp-gmpopenh264.enabled", false);


Wow, you get around? Here's links to your other posts... good luck.

https://www.questarter.com/q/trying-to- ... 03115.html
https://www.queryxchange.com/q/2_140311 ... on-debian/
https://superuser.com/questions/1403115 ... ng-firefox
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: Trying to watch Netflix on Debian using Firefox

Postby albsanrom » 2019-02-07 20:04

bw123 wrote:I have it all turned off, but did you check these and all the other media.gmp settings? Does it work on chromium browser?
Code: Select all
// Disable Freedom Violating DRM Feature
pref("browser.eme.ui.enabled", false);
// EME
pref("media.eme.enabled", false);
pref("media.eme.apiVisible", false);

// Google Widevine DRM
// https://blog.mozilla.org/futurereleases/2016/04/08/mozilla-to-test-widevine-cdm-in-firefox-nightly/
// https://wiki.mozilla.org/QA/Widevine_CDM
// https://bugzilla.mozilla.org/show_bug.cgi?id=1288580
pref("media.gmp-widevinecdm.visible", false);
pref("media.gmp-widevinecdm.enabled", false);
pref("media.gmp-widevinecdm.autoupdate", false);
// Disable openh264.
pref("media.gmp-gmpopenh264.enabled", false);


Wow, you get around? Here's links to your other posts... good luck.

https://www.questarter.com/q/trying-to- ... 03115.html
https://www.queryxchange.com/q/2_140311 ... on-debian/
https://superuser.com/questions/1403115 ... ng-firefox


I just posted the same question in superuser in stackexchange. Idk about those other ones

Where is media.gmp?

Yes, I can watch Netflix on other browsers. But I'd rather use Firefox

Idk about media.gmp. But I checked true for media.gmp-gmpopenh264.enabled in firefox-esr.js, and that hasn't resolved the issue:

Code: Select all
// This is the Debian specific preferences file for Firefox ESR
// You can make any change in here, it is the purpose of this file.
// You can, with this file and all files present in the
// /etc/firefox-esr directory, override any preference you can see in
// about:config.
//
// Note that pref("name", value, locked) is allowed in these
// preferences files if you don't want users to be able to override
// some preferences.

pref("extensions.update.enabled", true);

// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");

// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);

// Disable openh264.
pref("media.gmp-gmpopenh264.enabled", true);

// Default to classic view for about:newtab
pref("browser.newtabpage.enhanced", false, sticky);

// Disable health report upload
pref("datareporting.healthreport.uploadEnabled", false);

// Default to no suggestions in the urlbar. This still brings a panel asking
// the user whether they want to opt-in on first use.
pref("browser.urlbar.suggest.searches", false);
albsanrom
 
Posts: 4
Joined: 2019-02-07 18:31

Re: Trying to watch Netflix on Debian using Firefox

Postby bw123 » 2019-02-07 20:38

AFAICT firefox-esr.js only applies when creating a new profile it doesn't change settings in current profiles.

Mozilla support or maybe netflix is probably the best place to find out what needs to be set, but let people know here if you find out?

Your post on superuser is probably off-topic, since it is about netflix.
https://superuser.com/help/on-topic
...
and it is not about …

programming and software development,
video games or consoles,
websites or web services like Facebook, Twitter, and WordPress,

User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: Trying to watch Netflix on Debian using Firefox

Postby NFT5 » 2019-02-08 03:08

This is a bug in Firefox ESR that has been deemed not important enough to fix. Amazing given how many people would be using ESR and watch Netflix.

The only solution I've found is to download from Mozilla and extract to your home directory. This works and is simple and safe for all to use, but offends my OCD in the sense that program files should not be in the home directory and there is a limitation of use only by that user.

Another alternative may be to use a compatible repository, like that for MX, where they have the later version and backport it. I haven't tried this yet but should work and will provide updates as well. Caution recommended if you don't know what you're doing here - the potential to bork your system is high.
User avatar
NFT5
 
Posts: 251
Joined: 2014-10-10 11:38
Location: Canberra, Australia

Re: Trying to watch Netflix on Debian using Firefox

Postby bw123 » 2019-02-08 04:04

Any chance this bug is related?
https://bugs.debian.org/cgi-bin/bugrepo ... bug=921381

here's another... people should check bug reports. That's as far as I'll go for a problem I don;t have.
https://bugs.debian.org/cgi-bin/bugrepo ... bug=921121
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: Trying to watch Netflix on Debian using Firefox

Postby rivenathos » 2019-02-08 04:25

If you are not extremely concerned with the potential security issue of running a previous version of Firefox, you can downgrade. This might not be the solution for everyone, but it works for me right now since I do watch Netflix on my computers.

Code: Select all
apt-get install firefox-esr=60.3.0esr-1~deb9u1


If this bug is not going to be fixed until the next update of Firefox, this downgrade may help others in some respect until that occurs.
Currently running Debian 9 GNOME on a Dell OptiPlex 3010, Dell Inspiron 1545, and a Dell Inspiron 531.
Linux User #461545
User avatar
rivenathos
 
Posts: 212
Joined: 2009-01-09 11:57
Location: Georgia, USA

Re: Trying to watch Netflix on Debian using Firefox

Postby albsanrom » 2019-02-08 09:35

bw123 wrote:Any chance this bug is related?
https://bugs.debian.org/cgi-bin/bugrepo ... bug=921381

here's another... people should check bug reports. That's as far as I'll go for a problem I don;t have.
https://bugs.debian.org/cgi-bin/bugrepo ... bug=921121


Yes, it is indeed. I changed the line
Code: Select all
pref("app.update.channel", "default");

in /usr/lib/firefox-esr/defaults/pref/channel-prefs.js to
Code: Select all
pref("app.update.channel", "esr");

and now it works.
albsanrom
 
Posts: 4
Joined: 2019-02-07 18:31

Re: Trying to watch Netflix on Debian using Firefox

Postby NFT5 » 2019-02-08 10:29

albsanrom wrote:and now it works.


Confirmed. ESR is back to being able to work with Netflix.
User avatar
NFT5
 
Posts: 251
Joined: 2014-10-10 11:38
Location: Canberra, Australia


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable