fstab mounts not binding on boot.

If none of the more specific forums is the right place to ask

fstab mounts not binding on boot.

Postby Munty Scruntfundle » 2019-02-09 11:42

I'm running the debian version for the pi boards.

I've had this problem before when mounting in fstab, the file is run before the network is ready therefore the mounts fail without warning. Running mount -a when the system is fully booted forks fine.

Where do I drop the boot setting for "Wait for Network"?

Thanks.
Munty Scruntfundle
 
Posts: 17
Joined: 2018-11-27 16:53

Re: fstab mounts not binding on boot.

Postby Bloom » 2019-02-09 11:54

This is an fstab entry I used when I was still using a NAS (nowadays, I use LizardFS):
Code: Select all
NAS:/volume1/music     /mnt/Music   nfs4   rw,hard,intr,async,rsize=1048576,wsize=1048576,actimeo=0,timeo=14,nodev,nosuid,noauto,x-systemd.automount,x-systemd.device-timeout=10 0 0

The key options here are:
noauto -- do not automatically mount this entry while booting
x-systemd.automount -- have systemd automatically mount it AFTER the network has been started.
User avatar
Bloom
 
Posts: 75
Joined: 2017-11-11 12:23

Re: fstab mounts not binding on boot.

Postby p.H » 2019-02-09 20:59

Bloom wrote:x-systemd.automount -- have systemd automatically mount it AFTER the network has been started.

AFAICS, x-systemd.automount is for on-demand automatic mouting and has nothing to do with waiting after the network is up. This is the purpose of the _netdev option.
p.H
 
Posts: 772
Joined: 2017-09-17 07:12

Re: fstab mounts not binding on boot.

Postby kevinthefixer » 2019-02-10 01:49

One can also pass noauto,users options in fstab then place a mount script in (IIRC) /etc/NetworkManager/dispatcher.d/ directory. See man networkmanager for details.
kevinthefixer
 
Posts: 126
Joined: 2018-05-05 22:30


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable