Dependency failed for /boot LUKS on external USB drive after

If none of the more specific forums is the right place to ask

Dependency failed for /boot LUKS on external USB drive after

Postby temporpippo » 2019-07-21 19:14

Please somebody help me :( after a firmware update my Debian Sid with encrypted LUKS root does not boot clean anymore.

At boot, after inserting my passphrase, there are a bunch of messages and a timeout for like 30 seconds, and then finally I receive some yellow and red warnings about "dependency failed for /boot" and "/boot/efi". I am prompted for the root password for a recovery shell. The crazy thing is that in this shell the filesystem is mounted correctly! But I cannot start GDM3 or network.

My laptop is a Thinkpad X280 on dual boot. On partition 3 there is Windows 10, then there are three system and recovery partitions for windows, and then partition 5 is an encrypted LUKS which contains a single ext4 partition with root filesystem (including home etc, no swap). The boot drive is an external USB key which has two partitions: one to be mounted at /boot and one to be mounted at /boot/efi. I need to plug the USB key and then power on the laptop in order to boot linux, but the BIOS automatically boots Windows if a USB boot drive is not found.

Today, on Debian Sid, I did a firmware update (1.29 I think) and I guess something wrong happened. The GRUB entry 4.19.0-5 does not work anymore (complains about a missing UUID and gives me the initramfs shell, but I didn't touch the partition table!) and the old 4.19.0-4 as explained above hangs on for 30 seconds and then prompts me for the recovery shell (where, oddly, partitions are indeed mounted correctly).

Windows 10 boots correctly.

Some relevant info:

uname -r
Code: Select all

lsblk -o name,uuid,mountpoint

Code: Select all
NAME                UUID                                 MOUNTPOINT
├─nvme0n1p1         7C73-6F5A                           
├─nvme0n1p3         305C76675C76282C                     /media/windows
├─nvme0n1p4         FEA47899A478565D                     
└─nvme0n1p5         cb3c672b-efca-4dc5-8d2c-48e2b6bf5ebe
  └─nvme0n1p5_crypt 624d89ed-ee58-42b9-a6c2-16bdb2bcecb8 /

Code: Select all
nvme0n1p5_crypt UUID=cb3c672b-efca-4dc5-8d2c-48e2b6bf5ebe none luks

Code: Select all
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/nvme0n1p5_crypt /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sdc2 during installation
UUID=3ace0b0e-e917-48d2-bdc9-db8032a0dbd7 /boot           ext4    defaults        0       2
# /boot/efi was on /dev/sdc1 during installation
UUID=2724-DDC9  /boot/efi       vfat    umask=0077      0       1
# added by me: windows partition
/dev/nvme0n1p3   /media/windows   ntfs   user   0   1

Any help appreciated :(
Posts: 6
Joined: 2019-07-21 19:08

Re: Dependency failed for /boot LUKS on external USB drive a

Postby temporpippo » 2019-07-26 18:21

Actually this worked for me (note: I cannot add the [SOLVED] tag to the topic for some reasons)
Posts: 6
Joined: 2019-07-21 19:08

Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests