rxvt-unicode PowerlineSymbols issue

If none of the more specific forums is the right place to ask

rxvt-unicode PowerlineSymbols issue

Postby bcarraghan » 2019-08-14 04:35

Hi guys,

I'm trying to get the symbols for Powerline to show up for urxvt.

This is what I tried:
[*] installing a nerd font etc "Inconsolata Nerd Font"
[*] installing the powerline symbols via fontconfig (https://powerline.readthedocs.io/en/mas ... fontconfig).
[*] removing 70-no-bitmaps.conf from /etc/fonts/conf.d

Installing the PowerlineSymbols font, I can see it in the dropdown of Libreoffice. If I try setting my .Xresources config to that font I get an error that the fontset doesn't exist.

Here is my .Xresources:
Code: Select all
! urxvt
URxvt*font: xft:monospace:pixelsize=13:antialias=true:hinting=true,xft:PowerlineSymbols
URxvt.transparent: true
URxvt.shading: 20
URxvt*buffered: true
URxvt*cursorBlink: true
URxvt*depth: 32
URxvt*borderless: 1
URxvt*scrollBar: false
URxvt*loginShell: true
Urxvt*secondaryScroll:  true    # Enable Shift-PageUp/Down in screen
URxvt*saveLines: 16384
URxvt*termName: rxvt-unicode


Looking all over and I can't seem to figure out what the issue is. I'm coming from Archlinux and I didn't really have this issue there.

Thanks
bcarraghan
 
Posts: 2
Joined: 2019-08-14 04:22

Re: rxvt-unicode PowerlineSymbols issue

Postby ruwolf » 2019-08-14 12:24

How does the error message look exactly, literally?
User avatar
ruwolf
 
Posts: 365
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: rxvt-unicode PowerlineSymbols issue

Postby None1975 » 2019-08-14 15:02

Hello. You are doing everything wrong. No need to touch system wide configuration. Just place new fonts in user dir
Code: Select all
.local/share/fonts/

Create dir (in .config dir)
Code: Select all
fontconfig
create file
Code: Select all
fonts.conf

with following content
Code: Select all
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <selectfont>
    <acceptfont>
      <pattern>
        <patelt name="family"><string>terminess powerline</string></patelt>
      </pattern>
    </acceptfont>
  </selectfont>
</fontconfig>

and re-run
Code: Select all
fc-cache -vf


For example, in .Xresources file you can specified which fonts you will go to use
Code: Select all
URxvt*font : xft:TerminessTTF Nerd Font:size=13


P.S.
You can try this repo. This repo contains pre-patched and adjusted fonts for usage with the Powerline statusline plugin.
OS: Debian Buster / WM: Awesome
Debian Wiki | DontBreakDebian, My config files in github
User avatar
None1975
 
Posts: 903
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: rxvt-unicode PowerlineSymbols issue

Postby Head_on_a_Stick » 2019-08-18 19:09

bcarraghan wrote:removing 70-no-bitmaps.conf from /etc/fonts/conf.d

Did you also add a symlink to /usr/share/fontconfig/conf.avail/70-yes-bitmaps.conf?
Code: Select all
# dpkg-reconfigure fontconfig-config

^ That will offer an option to enable bitmap fonts for you correctly.
User avatar
Head_on_a_Stick
 
Posts: 10364
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: rxvt-unicode PowerlineSymbols issue

Postby bcarraghan » 2019-08-20 20:58

Head_on_a_Stick wrote:
bcarraghan wrote:removing 70-no-bitmaps.conf from /etc/fonts/conf.d

Did you also add a symlink to /usr/share/fontconfig/conf.avail/70-yes-bitmaps.conf?
Code: Select all
# dpkg-reconfigure fontconfig-config

^ That will offer an option to enable bitmap fonts for you correctly.


Thank you, this is what I was missing. I see what you mentioned was listed on this page: https://wiki.debian.org/Fonts#Adding_fonts. I must have missed it.
bcarraghan
 
Posts: 2
Joined: 2019-08-14 04:22


Return to General Questions

Who is online

Users browsing this forum: CwF and 9 guests

fashionable