luks password prompt shows asterisks

If none of the more specific forums is the right place to ask

luks password prompt shows asterisks

Postby paulclou » 2019-09-01 02:45

Hi all,

A few months ago, one of my computers running Debian stable began to echo one asterisk per character at the prompt to unlock a luks encrypted disk. I resorted to wiping the drive and reinstalling Debian stable today, and it displayed the same problem. Do you have any suggestions on mitigating this problem?

The system is running i5-8400, Asus B360-H.

https://i.imgur.com/L5kyPsc.jpg
Image

Thank you.
paulclou
 
Posts: 18
Joined: 2011-10-17 08:08

Re: luks password prompt shows asterisks

Postby Hallvor » 2019-09-01 06:54

I think it's a "feature"...
Lenovo Thinkpad T440S, Intel Core i7-4600U CPU @ 2.10GHz, 8 GB RAM, 256 GB SSD, Debian Buster (KDE)
User avatar
Hallvor
 
Posts: 940
Joined: 2009-04-16 18:35
Location: Norway

Re: luks password prompt shows asterisks

Postby p.H » 2019-09-01 09:36

My latest buster installation on LUKS does not display asterisks when I type the passphrase.
Could it be because you have plymouth installed ?
p.H
 
Posts: 1091
Joined: 2017-09-17 07:12

Re: luks password prompt shows asterisks

Postby paulclou » 2019-09-01 15:28

p.H wrote:My latest buster installation on LUKS does not display asterisks when I type the passphrase.
Could it be because you have plymouth installed ?

Nope. And it occurred right after the reboot of Debian 10 installation barebone (with iwlwifi nonfree firmware).
paulclou
 
Posts: 18
Joined: 2011-10-17 08:08

Re: luks password prompt shows asterisks

Postby CwF » 2019-09-02 23:52

My upgraded to buster does echo, and backspaces the echo..but it also changed to high res. I think my stretch doesn't echo. I find no setting to change it, interesting.
Try turning off the echo when you enter password by pressing TAB or BACKSPACE first, then passphrase.
CwF
 
Posts: 446
Joined: 2018-06-20 15:16

Re: luks password prompt shows asterisks

Postby paulclou » 2019-09-03 01:42

CwF wrote:My upgraded to buster does echo, and backspaces the echo..but it also changed to high res. I think my stretch doesn't echo. I find no setting to change it, interesting.
Try turning off the echo when you enter password by pressing TAB or BACKSPACE first, then passphrase.

The closest thing I can find is for systemd-ask-password https://github.com/systemd/systemd/issues/8495. I don't understand what systemd-ask-password has to do with luks during boot up. I believe echoing password length strongly weakens the encryption, and should not be enabled as default. Also, I cannot untoggle the asterisks by pressing TAB or BACKSPACE first, but I will test that again. Out of my six Debian machines from stable to testing, only one echos the asterisks. Should I contact the mailing list?
paulclou
 
Posts: 18
Joined: 2011-10-17 08:08

Re: luks password prompt shows asterisks

Postby CwF » 2019-09-04 15:55

paulclou wrote:Should I contact the mailing list?

could, but it seems the argument is well under way. I think the insecurity idea is flawed, do you type it with your hands covered? I think I'd rather have the feedback on a boot prompt, but generally agree the standard is no echo for passwords.
CwF
 
Posts: 446
Joined: 2018-06-20 15:16


Return to General Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable