L2TP + IPSec does not work in Debian 10

If none of the more specific forums is the right place to ask

L2TP + IPSec does not work in Debian 10

Postby Abormot » 2019-09-18 05:11

I installed nerwork-manager-l2tp-gnome with all dependecies and libraries but it does not connect to my server.
Abormot
 
Posts: 36
Joined: 2019-08-16 16:47

Re: L2TP + IPSec does not work in Debian 10

Postby csarnow » 2019-10-25 20:58

I have the same problem.
I can connect with a windows client and with my android phone, but with linux it does not work.
the logfile says
VPN connection: failed to connect: 'invalid ipsec-gateway-id 'ipsec-gateway-id''

Which is BS, because I did not enter "ipsec-gateway-id" as "ipsec-gateway-id".
I tried setting this to the gateway hostname, to the gateway ip address, deleting it from the config, and the error message stays the same.

Anyone got any ideas???
csarnow
 
Posts: 2
Joined: 2019-10-25 20:53

Re: L2TP + IPSec does not work in Debian 10

Postby Thomas Reynold » 2019-10-29 06:32

Hey Guys I also use Split Tunneling feature and some time L2TP of the vpn that I am using . It work fine on my PC and helps me alot in gaming scenarios.
That earlier days back I asked In the forum about how to access other regions when I play Pubg on my PC. So I used VPN in this regard.
SO its fine working since then.

It depends that which services you are consuming for the L2TP because it varies from provider to provider.
If it is free version then definitely its an alarming situation, so you should use other reliable one.
Thomas Reynold
 
Posts: 7
Joined: 2019-10-17 05:40

Re: L2TP + IPSec does not work in Debian 10

Postby trinidad » 2019-10-29 13:16

You can't believe your eyes if your imagination is out of focus.
trinidad
 
Posts: 76
Joined: 2016-08-04 14:58

Re: L2TP + IPSec does not work in Debian 10

Postby csarnow » 2019-11-01 12:35

Since I last posted, I have played around a bit more with the VPN configuration.
I could not get it to work with the network-manager-l2tp plugin, but with plain config files
for strongswan (NOT libreswan) and xl2tpd and pppd I finally have it working!

One reason my first attempts without network-manager-l2tp did not work, is that my VPN username
contains a backslash, which needs to be escaped in the config file (two backslashes instead of one).
csarnow
 
Posts: 2
Joined: 2019-10-25 20:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable