[SOLVED] GNS3 not working properly

If none of the more specific forums is the right place to ask

[SOLVED] GNS3 not working properly

Postby PsySc0rpi0n » 2019-10-28 20:51

Hello...

GNS3 problems again.

After I have installed GNS3 I tried to build a very basic example with 2 VPCS (Virtual PC Simulator) and an Ethernet switch. But I just can't start the VPCS. I get the following error:

2019-10-27 00:14:59 ERROR node:237 error while starting PC1: No path to a VPCS executable has been set


So I searched but found nothing really useful. After digging a bit more I found there is this software that needs to be installed with GNS3 which is VPCS from SourceForge. I downloaded it from there and tried to compile but got the following error:

gcc -O2 -m64 -DLinux -Di386 -DHV -Wall -I. -DTAP -c hv.c
In file included from hv.c:45:
./getopt.h:53:5: error: conflicting types for ‘getopt’
int getopt(int argc, char** argv, char* optstr);
^~~~~~
In file included from /usr/include/x86_64-linux-gnu/bits/getopt_posix.h:27,
from /usr/include/unistd.h:869,
from hv.c:33:
/usr/include/x86_64-linux-gnu/bits/getopt_core.h:91:12: note: previous declaration of ‘getopt’ was here
extern int getopt (int ___argc, char *const *___argv, const char *__shortopts)
^~~~~~
make: *** [Makefile.linux:38: hv.o] Error 1


I just can't make this to work.

Anyone can help me?
User avatar
PsySc0rpi0n
 
Posts: 118
Joined: 2012-10-24 13:54
Location: Portugal

Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable