[solved] Buster no splash screen; updated

If none of the more specific forums is the right place to ask

[solved] Buster no splash screen; updated

Postby ticojohn » 2019-10-31 18:57

I have a desktop with two drives. The SSD has Stretch and the HDD has Buster (upgraded from Stretch). When I boot Buster I do not get the splash screen and instead just get the text output. I have searched the web for solutions and have tried several things, all to no avail. I have checked plymouthd-start.service and it would appear that Plymouth should be showing the splash screen.
Code: Select all
$ systemctl status plymouth-start.service
● plymouth-start.service - Show Plymouth Boot Screen
   Loaded: loaded (/lib/systemd/system/plymouth-start.service; static; vendor pr
   Active: inactive (dead) since Thu 2019-10-31 13:12:05 CST; 19min ago
  Process: 550 ExecStart=/sbin/plymouthd --mode=boot --pid-file=/run/plymouth/pi
  Process: 553 ExecStartPost=/bin/plymouth show-splash (code=exited, status=0/SU

However, when I look at journalctl I see that Plymouth is being told to write out runtime data (two instances)
Code: Select all
Oct 31 12:56:57 debian systemd[1]: Starting Tell Plymouth To Write Out Runtime Data...
Oct 31 12:56:57 debian systemd[1]: Condition check resulted in Commit a transient machine-id on disk being skipped.
Oct 31 12:56:57 debian systemd[1]: Starting Set console font and keymap...
Oct 31 12:56:57 debian systemd[1]: Starting udev Kernel Device Manager...
Oct 31 12:56:57 debian systemd-tmpfiles[326]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:1] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher → /run/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
Oct 31 12:56:57 debian systemd-tmpfiles[326]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:2] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache → /run/speech-dispatcher/.cache; please update the tmpfiles.d/ drop-in file accordingly.
Oct 31 12:56:57 debian systemd-tmpfiles[326]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:3] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.speech-dispatcher → /run/speech-dispatcher/.speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
Oct 31 12:56:57 debian systemd-tmpfiles[326]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:4] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache/speech-dispatcher → /run/speech-dispatcher/.cache/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
Oct 31 12:56:57 debian systemd-tmpfiles[326]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:5] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/log → /run/speech-dispatcher/log; please update the tmpfiles.d/ drop-in file accordingly.
Oct 31 12:56:57 debian systemd[1]: Received SIGRTMIN+20 from PID 231 (plymouthd).
Oct 31 12:56:57 debian systemd[1]: Started Set console font and keymap.
Oct 31 12:56:57 debian systemd[1]: plymouth-read-write.service: Succeeded.
Oct 31 12:56:57 debian systemd[1]: Started Tell Plymouth To Write Out Runtime Data.
Oct 31 12:56:58 debian apparmor.systemd[325]: Restarting AppArmor

I have looked for errors that might be causing the text output, and here is a list generated with journalctl -b -p 3
Code: Select all
-- Logs begin at Thu 2019-10-31 12:56:56 CST, end at Thu 2019-10-31 13:10:21 CST. --
Oct 31 12:56:56 debian kernel: usbhid 2-1:1.1: couldn't find an input interrupt endpoint

That error is caused by a Genius mouse. I disconnected the mouse and re-booted the machine. I get the same text output with no error. I have "quiet splash" set in grub. Here is my /etc/default/grub file. And YES, I did a update-grub after making changes.
Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Other than the no splash screen issue, the upgrade from Stretch went well and Buster seems to be working with no issues.

If anybody has any suggestions as to what I can do to ge the Plymouth splash screen working, I would appreciate the help. Oh, by the way, when I boot Stretch, same machine different drive, I do not get any text output during boot. Of course I do not have Plymouth installed.

Thanks in advance.

Here's some additional info:
Just looked at the /var/log/boot.log and here are the first lines:
Code: Select all
root@debian:~# cat /var/log/boot.log
/dev/sdb1: clean, 186284/30040064 files, 3787066/120139520 blocks
[  OK  ] Started Tell Plymouth To Write Out Runtime Data.
[  OK  ] Started Set console font and keymap.
[  OK  ] Started Create Volatile Files and Directories.

So even thought the plymouth-start.service specifically states to show splash the boot process start by telling Plymouth to out put text
Code: Select all
Process: 553 ExecStartPost=/bin/plymouth show-splash (code=exited, status=0/SU

I also saw where Plymouth will not do the splash screen if the hardware does not support DRM.
Here is what I see from glx_info. SO it would appear that my hardware supports DRM.
Code: Select all
john@debian:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes

I also made all the changes recommended in the Debian Wiki for Plymouth.
I am stumped. Still no help from the forum.
Last edited by ticojohn on 2019-11-04 18:12, edited 1 time in total.
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-01 22:37

Well, I found something that might be an issue. In the Debian Plymouth Wiki it instructs the user to edit the /etc/initramfs_tools/modules file to add
Code: Select all
intel_agp
drm
i915 modeset=1

I did that and then did update-initramfs -u
When I look at loaded modules, using lsmod, I do not see intel_agp added. I then looked at /lib/modules/4.19.0-6-amd64/modules.builtin and do not find intel_agp. I do find intel-agp.ko . However I can not load that module either. So is this what is causing Plymouth to go directly to text instead of the splash screen? And if so, how do I fix the problem?
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-01 22:53

I think I am totally lost with this. 3d graphics rendering works so everything must be copacetic with graphics drivers. So I give up until I get some help. Thanks to all those reading.
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby stevepusser » 2019-11-02 00:33

Seems to be related to your graphics hardware and drivers--but I don't see those mentioned at all in your posts!

FWIW, Debian Buster's plymouth works fine on an Intel GPU for me:
Code: Select all
inxi -G

Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A
           Display: x11 server: X.Org 1.20.4 driver: intel resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.3.6
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11254
Joined: 2009-10-06 05:53

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-02 12:42

Thanks for the feedback @stevepusser. The only thing I mentioned about the graphics was that the glxinfo showed rendering was Yes.
Here is the graphics info:
Code: Select all
inxi -G
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.4 driver: intel resolution: 1152x864~75Hz
  OpenGL: renderer: Mesa DRI Intel Haswell Desktop v: 4.5 Mesa 18.3.6

Perhaps you are correct about the graphics. If it is the graphics, is there any way to not have Plymouth show the boot text? I have tried to disable and mask Plymouth, but to no avail. I would attempt to remove Plymouth but that would be a real nightmare as it would remove so many other things. I suppose i can live with the boot text but it isn't what I have become accustomed to and is somewhat distracting.
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-02 19:10

Just found something interesting. If I push the "Home" screen during boot, the boot text will be hidden and I get a grey screen with three dots showing boot progress. So I guess Plymouth is capable of doing the graphical display but just isn't doing it by default, Not sure where to go from here. I have verified that I have "quiet splash" in /etc/default/grub. Maybe the problem is that Plymouth is not finding the theme that I have selected. I selected the "spinner" theme but pushing the home button shows a screen with the three dots (maybe the default) and not the "spinner".
Code: Select all
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby stevepusser » 2019-11-02 22:19

You also have to do some tinkering in the terminal to tell Plymouth what theme to use--I skimmed over your previous posts and didn't see that, but I could have missed it.

Adrian wrote a GUI for MX to set Plymouth and GRUB options that makes that a lot simpler, and it looks like it will run just fine on vanilla Debian, if you want to install that and give it a try. 19.9 is the Buster version: http://mxrepo.com/mx/repo/pool/main/m/mx-boot-options/

You should make a backup of your system with Timeshift or something before trying it, of course, in case it loses the Debian GRUB screen.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11254
Joined: 2009-10-06 05:53

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-02 22:39

I did not mention it but yes, I installed the Plymouth themes and went through the process of setting the theme. The -R, as you probably know, automatically generates a new initramfs.
Code: Select all
plymouth-set-default-theme -R spinner

I suspect there is some graphics setting that I just haven't got set correctly. I'll keep searching for an answer and hopefully will find something. If I do I will post my solution. And I'll keep hoping that somebody here has a solution.

As always, thanks for your input stevepusser.
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-03 12:37

I did some further research and found a site (Ubuntu) that shows how to test Plymouth. I am assuming that even though it is an Ubuntu site the instructions would be the same for Debian. Here is the URL.
https://wiki.ubuntu.com/Plymouth#Testing
I followed the Post Boot instructions as per the site
Code: Select all
You can experiment with Plymouth after your system has booted. To start the Plymouth daemon:

    Boot system and login as usual

    (i) [RECOMMENDED] Install plymouth-x11 package (allows you to see the boot screen in an X11 window)

        sudo apt-get install plymouth-x11

    Start a terminal (such as gnome-terminal)
    Start the Plymouth daemon by running the following:

        sudo plymouthd --debug --tty=`tty` --no-daemon

Plymouth is now running, so we can have some fun:

    To check if Plymouth really is running:

        sudo plymouth --ping && echo plymouth is running || echo plymouth NOT running
    To show a message on our "boot" screen

        Start another gnome-terminal terminal/tab

        Run the following to show the Plymouth window:

            sudo plymouth show-splash
        Display a message

            sudo plymouth message --text="hello world"

When I do the plymouth --ping I get the result that plymouth is running. But plymouth show-splash does NOT show the splash screen.
To quote Alice, "Curiouser and Curiouser"
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby kedaha » 2019-11-03 13:48

ticojohn wrote:To quote Alice, "Curiouser and Curiouser"

hi,
Certainly is; I've been reading your topic and likewise am a bit baffled why it isn't working for you.
Another way to test plymouth, without rebooting, is to run the following commands as root:
Code: Select all
# plymouthd; plymouth --show-splash; for ((I=0; I<12; I++)); do plymouth --update=test$I; sleep 1; done; plymouth quit
# plymouthd --mode=shutdown; plymouth --show-splash; for ((I=0; I<8; I++)); do plymouth --update=test$I; sleep 1; done; plymouth quit

They're from an old topic of mine I wrote back in 2011 and they still work on my system in Buster having run plymouth-set-default-theme -R spinner and other themes. Try running them. Thanks.
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3017
Joined: 2008-05-24 12:26

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-03 15:12

I just tried your commands from the gnome terminal. It gives a blank screen and after a few seconds asks me to login. Do I need to run in tty?

Just tried in terminal tty1. No splash.
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-03 15:32

I keep coming back to the Debian Wiki Plymouth. In that wiki it indicated that I need to modify /etc/iniramfs-tools/modules as such.
Code: Select all
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.

intel_agp
drm
i915 modeset=1

The items added are intel_agp, drm, and i915.modeset=1. I have searched and "intel_agp" does not appear anywhere in my installation.
There is a agppart-intel, I wonder if this is the problem. I have loaded all the firmware, both free and non-free.

This is really exasperating.
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby kedaha » 2019-11-03 19:48

The commands I posted are for use in a terminal, not from a tty. If plymouth works then after a few seconds you should get the desktop back. I might mention that I use mate with automatic login.
I don't suppose substituting agppart-intel for intel_agp in /etc/iniramfs-tools/modules does any good?
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3017
Joined: 2008-05-24 12:26

Re: Buster no splash screen; updated

Postby ticojohn » 2019-11-03 20:34

I tried to run tour commands from a terminal and I get a black screen that then asks for a logon.
I checked the bootlog and journalctl, it appears that apgpart is getting loaded but I will change that line in modules and see what happens. I am NOT hopeful.

Interestingly, there is a driver in modules.builtin called intel-agp, not intel_agp

I added agppart-intel and intel-agp. Neither helped.

If I could just have a quiet boot I would be happy. I removed "splash" from the grub commandline and left "quiet". Still get boot messages. ARGGGHHHH ! I suppose that if Buster were installed on a SSD instead of an HDD the boot would be so fast that I would probably hard see the messages.

Maybe I'll re-install Stretch. :lol:
I'm not irrational, I'm just quantum probabilistic.
User avatar
ticojohn
 
Posts: 821
Joined: 2009-08-29 18:10
Location: Costa Rica

Re: Buster no splash screen; updated

Postby kedaha » 2019-11-03 21:08

I doubt it but there might be some remnant from the stretch installation resulting in no splash screen. If it worked in stretch, it must surely work in buster.
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3017
Joined: 2008-05-24 12:26

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable