Problems about config in debian

If none of the more specific forums is the right place to ask

Problems about config in debian

Postby macair2019 » 2019-11-02 00:57

Hello friends.
I have a question asking for your kind help.
I am trying to make a debian package ask questions to users

I am using debuild to build the package

I have a config and a templates file in debian directory

config file:

Code: Select all
#!/bin/sh
# Exit on error
set -e
# Source debconf library.
. /usr/share/debconf/confmodule
# Ask questions
db_input medium packagename/question1 || true
# Show interface
db_go || true

templates file:

Code: Select all
Template: packagename/question1
Type: boolean
Default: true
Description: Borro versiones anteriores de este paquete ubicadas
Asi es

I put # Source debconf library. . /usr/share/debconf/confmodule # Fetching configuration from debconf db_get packagename/question1 ANSWER1=$RET

inside my postinst script

When I executes:

Code: Select all
sudo debian/config


there is no response at all, silent as a good, correct unix statement.

I know templates is ok because if I write sometihng wrong it complains. for example removing a space, produces: "Template parse error near `Asi es', in stanza #1 of debian/templates"

If I make debuild, I get a package and with dpkg-i, the package is installed, but without answers.

What can I do to get questions to the user?
Thank's a lot!
,
macair2019
 
Posts: 1
Joined: 2019-11-02 00:45
Location: luandon

Return to General Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable