Package " gstreamer1.0-plugins-good" upgrade problem

If none of the more specific forums is the right place to ask

Package " gstreamer1.0-plugins-good" upgrade problem

Postby makh » 2019-11-02 04:22

Hello

I am getting this issue repeatedly, after upgrading to Buster. It looks to be strange!

Code: Select all
apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  gstreamer1.0-plugins-good
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
24 not fully installed or removed.
Need to get 0 B/2,924 kB of archives.
After this operation, 774 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Reading changelogs... Done
(Reading database ... 177685 files and directories currently installed.)
Preparing to unpack .../gstreamer1.0-plugins-good_1.14.4-1_amd64.deb ...
Unpacking gstreamer1.0-plugins-good:amd64 (1.14.4-1) over (1.10.4-1) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-plugins-good_1.14.4-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstlame.so', which is also in package gstreamer1.0-plugins-ugly:amd64 1:1.10.4-dmo1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer1.0-plugins-good_1.14.4-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I have removed the extra repository of debian-multimedia, on upgrade, but should this issue still continue?

Thankyou
HP Probook 440 G2: Arch, Debian Stable
Server: none
Past: Debian, Centos, Ubuntu, Opensuse
GUI: Openbox, Cinnamon
Chroot: Debian, Ubuntu, Fedora
VM: Devuan

Employing the best:
Arabic
Debian
Homeopathic

For new: Try Linux Mint
User avatar
makh
 
Posts: 639
Joined: 2011-10-09 09:16

Re: Package " gstreamer1.0-plugins-good" upgrade problem

Postby dilberts_left_nut » 2019-11-02 07:36

makh wrote:
Code: Select all
gstreamer1.0-plugins-ugly:amd64 1:1.10.4-dmo1
DebianMultimedia strikes again.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5017
Joined: 2009-10-05 07:54
Location: enzed

Re: Package " gstreamer1.0-plugins-good" upgrade problem

Postby kedaha » 2019-11-02 10:37

Is the gstreamer1.0-plugins-ugly package from dmo still installed? You haven't purged it?
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3017
Joined: 2008-05-24 12:26

Re: Package " gstreamer1.0-plugins-good" upgrade problem

Postby stevepusser » 2019-11-02 22:25

kedaha wrote:Is the gstreamer1.0-plugins-ugly package from dmo still installed? You haven't purged it?


You may have closed the deb-multimedia gateway, but doing so doesn't destroy the packages already in your world, unlike Ghostbuster's Gozer.
Last edited by stevepusser on 2019-11-04 19:53, edited 1 time in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11256
Joined: 2009-10-06 05:53

Re: Package " gstreamer1.0-plugins-good" upgrade problem

Postby kedaha » 2019-11-02 23:08

Indeed
$ ls -l /var/lib/dpkg/info | grep gstreamer1.0-plugins-ugly
What does the above command show?
One solution might be to backup and then remove the 2 ugly info files there followed by
# dpkg --configure -a
# apt update
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3017
Joined: 2008-05-24 12:26


Return to General Questions

Who is online

Users browsing this forum: No registered users and 21 guests

fashionable