update error

If none of the more specific forums is the right place to ask

update error

Postby reica » 2019-11-12 04:41

Hi, I'm running Debian-stretch armhf on a banana pi m1.
Recently I tried to install mysql-server from the mysql depository.
I was not happy with the results and went back to mariadb-server.
Howeverwhen I do an apt update I get the following error:

W: GPG error: http://repo.mysql.com/apt/debian stretch InRelease: The following signatures were invalid: EXPKEYSIG 8C718D3B5072E1F5 MySQL Release Engineering <mysql-build@oss.oracle.com>
E: The repository 'http://repo.mysql.com/apt/debian stretch InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

The http://repo.mysql.com...etc is not in the sources list.
I no longer need the source entry.
Could anyone tell me how to get rid of this warning. Where do I delete this entry.
reica
 
Posts: 2
Joined: 2019-11-12 04:15

Re: update error

Postby Dai_trying » 2019-11-12 05:15

It is likely in a file inside the /ect/apt/sources.list.d/ and you could either delete the offending file or comment out the line with the offending source.
Dai_trying
 
Posts: 834
Joined: 2016-01-07 12:25

Re: update error

Postby reica » 2019-11-12 23:23

Thank you Dal_trying. It was indeed and has been deleted now. No more warnings :)
reica
 
Posts: 2
Joined: 2019-11-12 04:15

Re: update error

Postby Dai_trying » 2019-11-13 07:43

You're welcome :)
Dai_trying
 
Posts: 834
Joined: 2016-01-07 12:25


Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable