Xorg broken after update

If none of the more specific forums is the right place to ask

Xorg broken after update

Postby Sante » 2019-11-13 20:55

Hello, first off I don't need support, I just rsync'ed a system snapshot so I'm fine. But the last time I upgraded my packages via discover Xorg broke , so no GUI. Tried in vain reinstalling-reconfiguring everything xorg - related and the video drivers but no dice. So you all may want to be careful about the latest package upgrades, at least using discover to deploy them. My debian is no frankendebian btw, it's a clean and fresh buster configuration.


106 packages were marked for installation:
Code: Select all
 base-files chromium chromium-common chromium-sandbox distro-info-data fonts-noto-cjk fonts-noto-cjk-extra fonts-opensymbol
  gir1.2-javascriptcoregtk-4.0 gir1.2-nm-1.0 gir1.2-webkit2-4.0 libfribidi-dev libfribidi0 libfribidi0:i386 libglib2.0-0
  libglib2.0-0:i386 libglib2.0-bin libglib2.0-data libglib2.0-dev libglib2.0-dev-bin libglib2.0-doc libjavascriptcoregtk-4.0-18
  libmariadb3 libncurses-dev libncurses6 libncurses6:i386 libncursesw6 libnm0 libnss-myhostname libnss-systemd libpam-systemd
  libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-help-common libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde5
  libreoffice-l10n-it libreoffice-librelogo libreoffice-math libreoffice-nlpsolver libreoffice-report-builder
  libreoffice-report-builder-bin libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql
  libreoffice-style-breeze libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer
  libsystemd0 libsystemd0:i386 libtinfo-dev libtinfo6 libtinfo6:i386 libudev1 libudev1:i386 libwebkit2gtk-4.0-37 libxslt1.1
  libxslt1.1:i386 linux-compiler-gcc-8-x86 linux-headers-4.19.0-6-amd64 linux-headers-4.19.0-6-common linux-image-4.19.0-6-amd64
  linux-kbuild-4.19 linux-libc-dev mariadb-client-core-10.3 mariadb-common mariadb-server-core-10.3 ncurses-base ncurses-bin
  ncurses-term network-manager python-cryptography python2.7 python2.7-dev python2.7-minimal python3-cryptography python3-uno
  qemu-kvm qemu-system-common qemu-system-data qemu-system-gui qemu-system-x86 qemu-utils systemd systemd-sysv udev uno-libs3
  ure


Always be praised Our Lord of backups, have a nice time
Sante
 
Posts: 12
Joined: 2018-12-09 04:17

Re: Xorg broken after update

Postby Head_on_a_Stick » 2019-11-16 19:34

*cough*pebkac*cough*
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Xorg broken after update

Postby Sante » 2019-11-21 03:48

actually it was a couch. so it's just my fault for relying on the gui package manager ?
Sante
 
Posts: 12
Joined: 2018-12-09 04:17

Re: Xorg broken after update

Postby stevepusser » 2019-11-21 18:47

It probably wasn't due to Discover, but since it seems to be a graphics driver problem, and since we have no information about your hardware and driver situation before the update, we can't say anything one way or another.

But since no one else has reported similar problems here, that argues for the problem being on your end. :(
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.9, Telegram-desktop 1.8.15, Pale Moon 28.8.0, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11316
Joined: 2009-10-06 05:53

Re: Xorg broken after update

Postby Head_on_a_Stick » 2019-11-23 12:02

Sante wrote:actually it was a couch.

Heathen slob! :x

Sante wrote:so it's just my fault for relying on the gui package manager ?

Yes. At least the command line would have given decent error messages. And as Steve notes nobody else is complaining about this.
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Xorg broken after update

Postby Sante » 2019-11-27 04:19

It probably wasn't due to Discover, but since it seems to be a graphics driver problem, and since we have no information about your hardware and driver situation before the update, we can't say anything one way or another.


Very right. It's a core i7-7700 system, MSI board (H110M Pro-VH) with integrated intel graphics. 8 GB system ram.
BTW I attempted to upgrade via the tty and got no errors. Rebooting, again no gui, on a bare text tty, so I had to restore the system. It is a debian 10 clean install and so far upgrading packages didn't cause anything to break. graphics driver i915 is in use.
Sante
 
Posts: 12
Joined: 2018-12-09 04:17

Re: Xorg broken after update

Postby Head_on_a_Stick » 2019-11-28 16:38

Do you still have the X.Org logs for the failed sessions? They usually show exactly what happened.
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable