[Solved] package installation problems

If none of the more specific forums is the right place to ask

[Solved] package installation problems

Postby chadrick » 2019-12-28 23:58

Hi All,

While trying to install nvidia-detect, I keep getting the following message:
Errors were encountered while processing:
xserver-xorg-video-nvidia
xserver-xorg-video-nvidia-legacy-390xx


I am not sure what to do. I have tried to install them and I have tried to uninstall them. I am not sure what the computer needs me to do.

Any ideas?

chadrick
Last edited by chadrick on 2019-12-29 03:30, edited 2 times in total.
chadrick
 
Posts: 83
Joined: 2016-01-06 00:32

Re: nvidia-detect installation problems

Postby stevepusser » 2019-12-29 01:48

How are you installing packages? The command line would show you the actual errors referred to instead of hiding them in a GUI.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12000
Joined: 2009-10-06 05:53

Re: package installation problems

Postby chadrick » 2019-12-29 01:50

sudo apt-get install nvidia-detect

I do not have a GUI. That is the overarching problem that I am trying to solve. I upgraded to Buster and now all I have is the command line. I think it has something to do with my Nvidia graphics card since I had the same problem when I upgraded to Stretch a few years ago.

This time around, I tried to use the Debian repos and I also tried to use the binary blog from the Nvidia website. Neither worked but I think that I messed something up by trying two different ways.
chadrick
 
Posts: 83
Joined: 2016-01-06 00:32

Re: package installation problems

Postby chadrick » 2019-12-29 02:09

Here is a more detailed listing of the error message:

sudo apt-get install nvidia-detect
[sudo] password for sarah:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
xserver-xorg-video-nvidia xserver-xorg-video-nvidia-legacy-390xx
The following NEW packages will be installed:
nvidia-detect
0 upgraded, 1 newly installed, 2 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/205 kB of archives.
After this operation, 42.8 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 359401 files and directories currently installed.)
Removing xserver-xorg-video-nvidia (418.74-1) ...
dpkg: error processing package xserver-xorg-video-nvidia (--remove):
installed xserver-xorg-video-nvidia package post-removal script subprocess returned error exit status 128
Removing xserver-xorg-video-nvidia-legacy-390xx (390.116-1) ...
dpkg: error processing package xserver-xorg-video-nvidia-legacy-390xx (--remove):
installed xserver-xorg-video-nvidia-legacy-390xx package post-removal script subprocess returned error exit status 20
Errors were encountered while processing:
xserver-xorg-video-nvidia
xserver-xorg-video-nvidia-legacy-390xx
E: Sub-process /usr/bin/dpkg returned an error code (1)
chadrick
 
Posts: 83
Joined: 2016-01-06 00:32

Re: package installation problems

Postby chadrick » 2019-12-29 02:38

I deleted some files based on another post and this is the result:

sudo apt-get install nvidia-detect
Reading package lists... Done
Building dependency tree
Reading state information... Done
nvidia-detect is already the newest version (418.74-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up nvidia-legacy-390xx-kernel-dkms:i386 (390.116-1) ...
Removing old nvidia-legacy-390xx-390.116 DKMS files...

------------------------------
Deleting module version: 390.116
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-390xx-390.116 DKMS files...
Building for 4.9.0-3-amd64
Building initial module for 4.9.0-3-amd64
Error! Bad return status for module build on kernel: 4.9.0-3-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-legacy-390xx/390.116/build/make.log for more information.
dpkg: error processing package nvidia-legacy-390xx-kernel-dkms:i386 (--configure):
installed nvidia-legacy-390xx-kernel-dkms:i386 package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
nvidia-legacy-390xx-kernel-dkms:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
chadrick
 
Posts: 83
Joined: 2016-01-06 00:32

Re: package installation problems

Postby chadrick » 2019-12-29 03:29

Ok. I think I am on to something. I removed every Nvidia driver in aptitude. I was then able to install nvidia-detect.

chadrick
chadrick
 
Posts: 83
Joined: 2016-01-06 00:32

Re: [Solved] package installation problems

Postby stevepusser » 2019-12-29 20:02

You're still running the Stretch 4.9 kernel in a Buster install. The Nvidia dkms packages won't build on that kernel due to it being built with Stretch's gcc-6. The solution is to upgrade to the standard Buster 4.19 kernel, which the Stretch-Buster upgrade guide should have told you to do.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12000
Joined: 2009-10-06 05:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 27 guests

fashionable