Installing Kate installs a bunch of vlc stuff

If none of the more specific forums is the right place to ask

Installing Kate installs a bunch of vlc stuff

Postby crappie_stalker » 2020-01-29 13:47

Using a fresh install of debian testing with XFCE. Installing Kate installs a bunch of vlc crap.
Code: Select all
sudo apt-get --no-install-recommends install kate -s
...
The following NEW packages will be installed:
  kate kate5-data kio kpackagetool5 ktexteditor-data ktexteditor-katepart kwayland-data libaribb24-0 libbasicusageenvironment1 libcddb2
  libdbusmenu-qt5-2 libdouble-conversion3 libdvbpsi10 libebml4v5 libeditorconfig0 libfam0 libgit2-28 libgles2 libgroupsock8
  libhttp-parser2.9 libixml10 libkf5activities5 libkf5archive5 libkf5attica5 libkf5auth-data libkf5authcore5 libkf5bookmarks-data
  libkf5bookmarks5 libkf5calendarevents5 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5declarative5 libkf5doctools5 libkf5globalaccel-bin
  libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-data
  libkf5iconthemes5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5
  libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5 libkf5notifications-data
  libkf5notifications5 libkf5package-data libkf5package5 libkf5parts-data libkf5parts5 libkf5plasma5 libkf5plasmaquick5 libkf5quickaddons5
  libkf5service-bin libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5
  libkf5syntaxhighlighting-data libkf5syntaxhighlighting5 libkf5texteditor-bin libkf5texteditor5 libkf5textwidgets-data libkf5textwidgets5
  libkf5threadweaver5 libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5 libkf5widgetsaddons-data libkf5widgetsaddons5
  libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-data libkf5xmlgui5 libkwalletbackend5-5 liblirc-client0 liblivemedia77
  liblua5.2-0 libmad0 libmatroska6v5 libmbedcrypto3 libmbedtls12 libmbedx509-0 libmicrodns0 libmtp-common libmtp9 libnfs13
  libopenmpt-modplug1 libpcre2-16-0 libphonon4qt5-4 libphonon4qt5-data libplacebo7 libpolkit-qt5-1-1 libprotobuf-lite17 libqt5core5a
  libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickcontrols2-5 libqt5quicktemplates2-5
  libqt5script5 libqt5sql5 libqt5svg5 libqt5texttospeech5 libqt5widgets5 libqt5x11extras5 libqt5xml5 libresid-builder0c2a libsdl-image1.2
  libsidplay2 libspatialaudio0 libupnp13 libusageenvironment3 libva-wayland2 libvlc5 libvlccore9 libxcb-composite0 libxcb-damage0
  libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-render-util0 libxcb-res0 libxcb-xinerama0 libxcb-xinput0 libxcb-xkb1 libxcb-xv0
  libxkbcommon-x11-0 phonon4qt5 phonon4qt5-backend-vlc plasma-framework qml-module-org-kde-kconfig qml-module-org-kde-kquickcontrols
  qml-module-org-kde-kquickcontrolsaddons qml-module-qtgraphicaleffects qml-module-qtqml-models2 qml-module-qtquick-controls
  qml-module-qtquick-controls2 qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-privatewidgets
  qml-module-qtquick-templates2 qml-module-qtquick-window2 qml-module-qtquick2 vlc-data vlc-plugin-base vlc-plugin-video-output

libvlc5
libvlccore9
phonon4qt5-backend-vlc
vlc-data
vlc-plugin-base
vlc-plugin-video-output
crappie_stalker
 
Posts: 2
Joined: 2020-01-29 13:03

Re: Installing Kate installs a bunch of vlc stuff

Postby L_V » 2020-01-29 15:08

Install phonon4qt5-backend-null, and try again to see.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: Installing Kate installs a bunch of vlc stuff

Postby crappie_stalker » 2020-01-29 19:33

Thanks L_V and the person who pm'd me. That worked perfectly. It got rid of the vlc stuff and a bit more.
crappie_stalker
 
Posts: 2
Joined: 2020-01-29 13:03

Re: Installing Kate installs a bunch of vlc stuff

Postby L_V » 2020-01-29 19:41

I must say it is really weird that even with "--no-install-recommends " option, kate still depends on phonon4qt5-backend-vlc.
It should not.....
The fact is that default phonon4qt5 dependency is phonon4qt5-backend-vlc.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: Installing Kate installs a bunch of vlc stuff

Postby stevepusser » 2020-01-30 00:17

KDE requires phonon, and phonon requires a backend. The vlc one just happens to be the default. You can also use the gstreamer backend if you want one that works without the vlc libraries.

Most users don't care about the few MB that the vlc version requires, being that drives are yuge these days.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 11983
Joined: 2009-10-06 05:53

Re: Installing Kate installs a bunch of vlc stuff

Postby L_V » 2020-01-30 19:53

stevepusser wrote:KDE requires phonon
There is a tremendous difference between installing KDE, and kate which is a qt5 text editor.
I've never seen anyone trying to play an audio file with a text editor.
Kate dependencies are:
Code: Select all
kate5-data
kio
ktexteditor-katepart
libc6
libgcc1
libkf5activities5
libkf5bookmarks5
libkf5completion5
libkf5configcore5
libkf5configgui5
libkf5configwidgets5
libkf5coreaddons5
libkf5crash5
libkf5dbusaddons5
libkf5guiaddons5
libkf5i18n5
libkf5iconthemes5
libkf5itemmodels5
libkf5jobwidgets5
libkf5kiocore5
libkf5kiofilewidgets5
libkf5kiowidgets5
libkf5newstuff5
libkf5parts5
libkf5plasma5
libkf5service-bin
libkf5service5
libkf5texteditor5
libkf5textwidgets5
libkf5threadweaver5
libkf5wallet-bin
libkf5wallet5
libkf5widgetsaddons5
libkf5windowsystem5
libkf5xmlgui5
libqt5core5a
libqt5dbus5
libqt5gui5
libqt5sql5
libqt5widgets5
libqt5xml5
libstdc++6
plasma-framework
qml-module-org-kde-kquickcontrolsaddons
qml-module-qtquick-layouts
qml-module-qtquick2

What is strange (although logical), I don't find any kate dependency which requires phonon4qt5.
Did somebody find it ?

EDIT:
I've checked all dependencies with a script: no phonon4qt5 found anywhere.
The answer is may be OP "Using a fresh install of debian testing".
To be clarified on a "stable" environment.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04


Return to General Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable