Incorrect mime type for html, defaults to Thunderbird

If none of the more specific forums is the right place to ask

Incorrect mime type for html, defaults to Thunderbird

Postby hermit » 2020-01-31 22:03

I've had this since the latest 'major' update. I click on something with an html extension and it brings up Thunderbird instead of a browser. I've tried the GUI. I've grepped through /home/hermit/.local/share/mime

I'm just not getting anywhere. It' is getting annoying.
hermit
 
Posts: 12
Joined: 2013-08-05 23:19

Re: Incorrect mime type for html, defaults to Thunderbird

Postby sunrat » 2020-01-31 23:59

You don't say what DE you are using. I guess you mean you click on a saved local html file? Most DEs allow you to right click on a file and select "Open With...", which shows a list of applications and also "Other Application..." or something similar. Click on that and select which one you want and tick the check box which says something like "Always use this application for this type of file".
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3186
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Incorrect mime type for html, defaults to Thunderbird

Postby Head_on_a_Stick » 2020-02-01 08:59

hermit wrote:I've grepped through /home/hermit/.local/share/mime

Edit ~/.config/mimeapps.list instead.

For the lazy:
Code: Select all
sed -i 's/thunderbird/firefox-esr/' ~/.config/mimeapps.list
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12488
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Incorrect mime type for html, defaults to Thunderbird

Postby hermit » 2020-02-01 23:13

That did it. I had temporarily fixed it by tying the function to a specific app but this is the better/correct solution. Thank you very much. I appreciate your input.
hermit
 
Posts: 12
Joined: 2013-08-05 23:19

Re: Incorrect mime type for html, defaults to Thunderbird

Postby Head_on_a_Stick » 2020-02-02 09:31

Please prepend [SOLVED] to the thread title to help others with this problem.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12488
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to General Questions

Who is online

Users browsing this forum: esters and 10 guests

fashionable