[SOLVED] Encrypted luks2 partition won't boot

If none of the more specific forums is the right place to ask

[SOLVED] Encrypted luks2 partition won't boot

Postby Danielsan » 2020-02-03 21:34

Hi guys,

I have a very annoying issue, I use a Debian VM to handle some specific task. It is Sid on Virtualbox with macOS as host. Today after a reboot it stopped to boot because after inserting the password I received this warning:

Code: Select all
libgcc_s.so.1 must be installed for pthread_cancel to work
aborted


And It requested again the password.

I chrooted and reinstalled a bunch of packages that have that library, I also installed GNULIB that should handle pthread tasks, and did a fsck; but none of those worked and I don't understand how to fix it.

Any ideas?

Everything is on / with a very small swap partition.
Last edited by Danielsan on 2020-02-04 16:35, edited 1 time in total.
User avatar
Danielsan
 
Posts: 559
Joined: 2010-10-10 22:36

Re: Encrypted luks2 partition won't boot

Postby p.H » 2020-02-04 13:49

Maybe sid is broken again ?

libgcc_s.so.1 seems to be a "soft" dependency of libpthread (not shown by ldd, loaded only when needed). Did you check if it is included in the initramfs ?
p.H
 
Posts: 1260
Joined: 2017-09-17 07:12

Re: [SOLVED] Encrypted luks2 partition won't boot

Postby Danielsan » 2020-02-04 16:39

Hi,

thanks for your reply.

Eventually came a bug report:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=950551

And SID got broken again because a missing hook in the initram image.

I am bit of disoriented about this behavior, however I was able to run again my box but I am not sure if I will able to re-run it again...

Other reports:

https://salsa.debian.org/kernel-team/in ... 5ef9ccc015
User avatar
Danielsan
 
Posts: 559
Joined: 2010-10-10 22:36

Re: [SOLVED] Encrypted luks2 partition won't boot

Postby p.H » 2020-02-05 12:31

Danielsan wrote:Eventually came a bug report:

A change in a package broke another package. That's what sid/unstable is for.

Danielsan wrote:I am bit of disoriented about this behavior, however I was able to run again my box but I am not sure if I will able to re-run it again...

What do you mean ? According to the links you posted, the issue has been fixed.
p.H
 
Posts: 1260
Joined: 2017-09-17 07:12

Re: [SOLVED] Encrypted luks2 partition won't boot

Postby Danielsan » 2020-02-05 15:10

p.H wrote:A change in a package broke another package. That's what sid/unstable is for.


I am agreed however it doesn't seem very smart throwing a change and see what happens without caring anything else.

p.H wrote:What do you mean ? According to the links you posted, the issue has been fixed.


Everything works properly however none all the suggestions worked for me, hence I was able to reload Debian but without understanding which fixing actually worked.
User avatar
Danielsan
 
Posts: 559
Joined: 2010-10-10 22:36

Re: [SOLVED] Encrypted luks2 partition won't boot

Postby p.H » 2020-02-05 21:51

The fix was simply to update the broken package.
p.H
 
Posts: 1260
Joined: 2017-09-17 07:12

Re: [SOLVED] Encrypted luks2 partition won't boot

Postby Danielsan » 2020-02-06 04:13

From my understanding the fix was to go on an older kernel creating a symlink of that library where missing and regenareting the initramfs for the broken kernel...
User avatar
Danielsan
 
Posts: 559
Joined: 2010-10-10 22:36

Re: [SOLVED] Encrypted luks2 partition won't boot

Postby p.H » 2020-02-06 14:42

The kernel was not broken. The initramfs was. Booting with an older kernel (using an older initramfs) was just a temporary workaround in order to boot the system. The real fix was to update the package which needed to be updated.
p.H
 
Posts: 1260
Joined: 2017-09-17 07:12


Return to General Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable