[Resolved] App: Vidcutter Odd Error Message

If none of the more specific forums is the right place to ask

[Resolved] App: Vidcutter Odd Error Message

Postby JeSuisFlaneur » 2020-02-10 15:22

I ask you for some help with installing this app. I have to cut some dashcam footage to send it to an auto insurance company.

I tried to install "vidcutter" per the Github pages:

"Ubuntu/Mint/Debian/KDE Neon and other Ubuntu flavors + derivatives
Users can install the latest release via:
ppa:ozmartian/apps
The following set of commands will get you up and running:
sudo add-apt-repository ppa:ozmartian/apps
sudo apt update
sudo apt install vidcutter"

but on running it:

Code: Select all
mark@Lexington:~$ sudo add-apt-repository ppa:ozmartian/apps
 [ OFFICIAL VidCutter PPA ]

Welcome to the official Ubuntu-flavoured home of VidCutter.

If packages for your distro are not available you can head over to the GitHub Releases page and download the latest version as an AppImage, which comes pre-bundled with the latest versions of all dependencies & tested to work on Trusty through to current stable release Ubuntu versions.

* RELEASES PAGE: https://github.com/ozmartian/vidcutter/releases/latest *
 More info: https://launchpad.net/~ozmartian/+archive/ubuntu/apps
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpezi4k2yb/pubring.gpg' created
gpg: /tmp/tmpezi4k2yb/trustdb.gpg: trustdb created
gpg: key 9BCA8B4F51A082C4: public key "Launchpad PPA for ozmartian" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no valid OpenPGP data found.

mark@Lexington:~$ sudo aptitude update
Hit http://security.debian.org/debian-security buster/updates InRelease
Hit http://deb.debian.org/debian buster InRelease         
Hit http://deb.debian.org/debian buster-updates InRelease
Ign http://ppa.launchpad.net/ozmartian/apps/ubuntu focal InRelease
Err http://ppa.launchpad.net/ozmartian/apps/ubuntu focal Release
  404  Not Found [IP: 2001:67c:1560:8008::15 80]
E: The repository 'http://ppa.launchpad.net/ozmartian/apps/ubuntu focal Release' does not have a Release file.
E: Failed to download some files
W: Failed to fetch http://ppa.launchpad.net/ozmartian/apps/ubuntu/dists/focal/Release: 404  Not Found [IP: 2001:67c:1560:8008::15 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
                                         
mark@Lexington:~$ sudo apt install vidcutter
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package vidcutter
Last edited by JeSuisFlaneur on 2020-02-10 19:10, edited 1 time in total.
JeSuisFlaneur
 
Posts: 42
Joined: 2019-08-28 16:00

Re: App: Vidcutter Odd Error Message

Postby Head_on_a_Stick » 2020-02-10 16:21

PPAs may cause problems with Debian, they are not recommended. Why not try the AppImage instead? Did you even read the error message?

And anyway you don't need this "vidcutter" at all, ffmpeg can cut videos: https://superuser.com/questions/138331/ ... t-up-video
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12486
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: App: Vidcutter Odd Error Message

Postby JeSuisFlaneur » 2020-02-10 17:02

Mr Head on a stick

If I understood the error message, which I read several times, I will still be posting as I have no understanding of what it means. Or what to do about it. That's why I post here, this forum.

As for the CLI ffmpeg, I'm not skilled in using that. The auto insurance company is waiting. Forgive my hurry.

And I've never heard of appimage before. But thanks I will research it and be better informed in the future.
JeSuisFlaneur
 
Posts: 42
Joined: 2019-08-28 16:00

Re: App: Vidcutter Odd Error Message

Postby Head_on_a_Stick » 2020-02-10 17:28

JeSuisFlaneur wrote:Mr Head on a stick

Please, call me HoaS. Or just "wanker" if you're feeling informal :mrgreen:

JeSuisFlaneur wrote:If I understood the error message, which I read several times, I will still be posting as I have no understanding of what it means. Or what to do about it. That's why I post here, this forum.

You didn't understand this:
Code: Select all
If packages for your distro are not available you can head over to the GitHub Releases page and download the latest version as an AppImage

Seems pretty clear to me... :?

But I will grant that this bit is a little more esoteric:
JeSuisFlaneur wrote:
Code: Select all
Err http://ppa.launchpad.net/ozmartian/apps/ubuntu focal Release
  404  Not Found [IP: 2001:67c:1560:8008::15 80]

^ The source you have added has "focal" as the distribution but that does not exist: http://ppa.launchpad.net/ozmartian/apps/ubuntu/dists/

I think Xenial is closest to Debian buster so edit the file so it points to that instead. But it's risky so I really would advise you to try the AppImage instead, or use ffmpeg.

Find the file with:
Code: Select all
grep focal /etc/apt/sources.list{,.d/*}

JeSuisFlaneur wrote:As for the CLI ffmpeg, I'm not skilled in using that.

The thread I linked in my last post explains how to use ffmpeg to extract a timed segment of video. Skill up d00d :)
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12486
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to General Questions

Who is online

Users browsing this forum: marsdr and 20 guests

fashionable