PC reboots when I systemctl poweroff

If none of the more specific forums is the right place to ask

PC reboots when I systemctl poweroff

Postby demoso » 2020-02-16 15:35

I have a Lenovo thinkcentre M10AY-001YUS that I installed Debian 10 on. When I type the command systemctl poweroff the computers reboots instead of shutting down. If I disable wake on lan in the BIOS then it does shutdown properly. It also does this if I push the power button. The problem is I want to be able to use wake on lan so I don't want to disable it. The BIOS is updated with the most recent from Lenovo's website. Any help would be greatly appreciated. Just and FYI I am a completely new to Debian and linux and am setting this box up to learn so if you give me instructions to run please be specific and patient. Thanks.
demoso
 
Posts: 5
Joined: 2014-05-15 20:54

Re: PC reboots when I systemctl poweroff

Postby Hallvor » 2020-02-16 21:05

How about

Code: Select all
# shutdown -h now

Code: Select all
# poweroff

or
Code: Select all
# halt
Last edited by Hallvor on 2020-02-16 21:49, edited 1 time in total.
Lenovo ThinkPad T440S, Intel Core i7-4600U CPU @ 2.10GHz, 8 GB RAM, 256 GB SSD, Debian Buster (KDE)
Lenovo ThinkPad X240, Intel Core i5-4300U CPU @ 2.90GHz, 8 GB RAM, 120 GB SSD, Debian Buster (KDE)
User avatar
Hallvor
 
Posts: 1031
Joined: 2009-04-16 18:35
Location: Norway

Re: PC reboots when I systemctl poweroff

Postby Head_on_a_Stick » 2020-02-17 15:35

@Hallvor:
Code: Select all
empty@E485:~ $ ls -l /sbin/{shutdown,poweroff,halt}                                     
lrwxrwxrwx 1 root root 14 Jan 29 18:07 /sbin/halt -> /bin/systemctl
lrwxrwxrwx 1 root root 14 Jan 29 18:07 /sbin/poweroff -> /bin/systemctl
lrwxrwxrwx 1 root root 14 Jan 29 18:07 /sbin/shutdown -> /bin/systemctl
empty@E485:~ $

@OP: try adding this kernel command line parameter:
Code: Select all
acpi=noirq

This is a kernel bug so you could try the newer version available from the buster-backports repositories to see if it works without disabling interrupt requests via ACPI. If that doesn't fix things then you may have to pursue this upstream (ie, with the kernel devs).
User avatar
Head_on_a_Stick
 
Posts: 11587
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: PC reboots when I systemctl poweroff

Postby demoso » 2020-02-18 01:54

Hallvor wrote:How about

Code: Select all
# shutdown -h now

Code: Select all
# poweroff

or
Code: Select all
# halt


shutdown -h now does not work. From what I have been reading Debian 10 switched to systemd. So I must use commands systemctl poweroff, systemctl reboot, systemctl halt. they all reboot the machine except systemctl halt which doesn't completely poweroff the PC instead it just displays "system halted" on the screen and the power stays on.
demoso
 
Posts: 5
Joined: 2014-05-15 20:54

Re: PC reboots when I systemctl poweroff

Postby demoso » 2020-02-18 01:56

Head_on_a_Stick wrote:@Hallvor:
Code: Select all
empty@E485:~ $ ls -l /sbin/{shutdown,poweroff,halt}                                     
lrwxrwxrwx 1 root root 14 Jan 29 18:07 /sbin/halt -> /bin/systemctl
lrwxrwxrwx 1 root root 14 Jan 29 18:07 /sbin/poweroff -> /bin/systemctl
lrwxrwxrwx 1 root root 14 Jan 29 18:07 /sbin/shutdown -> /bin/systemctl
empty@E485:~ $

@OP: try adding this kernel command line parameter:
Code: Select all
acpi=noirq

This is a kernel bug so you could try the newer version available from the buster-backports repositories to see if it works without disabling interrupt requests via ACPI. If that doesn't fix things then you may have to pursue this upstream (ie, with the kernel devs).


When I get a chance I will do a little research on how to add a kernel command and then try this. I will let you know if it works.
demoso
 
Posts: 5
Joined: 2014-05-15 20:54


Re: PC reboots when I systemctl poweroff

Postby djk44883 » 2020-02-19 21:55

There are a variety of wol "flags". You may have one set to wake on broadcast messages - like when a printer announces it's self. The tool ethool https://manpages.debian.org/buster/ethtool/ethtool.8.en.html sets these options:
Sets Wake-on-LAN options. Not all devices support this. The argument to this option is a string of characters specifying which options to enable.
p Wake on PHY activity
u Wake on unicast messages
m Wake on multicast messages
b Wake on broadcast messages
a Wake on ARP
g Wake on MagicPacket™
s Enable SecureOn™ password for MagicPacket™
f Wake on filter(s)
d Disable (wake on nothing). This option clears all previous options.


Generally you'd just want "g" A generic example (replace eth0 with your network interface device name):
Code: Select all
ethtool -s eth0 wol g


Or you might have a bug or irq issue.
djk44883
 
Posts: 89
Joined: 2010-12-11 13:14


Return to General Questions

Who is online

Users browsing this forum: Geo and 8 guests

fashionable