Default audio device issue

If none of the more specific forums is the right place to ask

Default audio device issue

Postby terabros1 » 2020-06-23 18:43

Hello all, I am running into issues with jackd not selecting the correct audio device connected to my raspberry pi when I run the following command through a webserver using php:

Code: Select all
dbus-run-session /media/pi/root0/home/pi/jacktrip/src/jacktrip -C cmn16.stanford.edu -q8 2>&1


It works perfectly fine from the console but when I try issuing the same command using a web server via a php file, the Audio interface is not selected correctly and hence the default Audio0 is selected and my connected headphones and mic don’t work.

Error from web server:

Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode


From console:

Acquire audio card Audio2
creating alsa driver ... hw:A96|hw:A96|1024|2|48000|0|0|nomon|swmeter|-|32bit


Any help resolving this issue will be much appreciated!
terabros1
 
Posts: 2
Joined: 2020-06-23 18:35

Re: Default audio device issue

Postby Head_on_a_Stick » 2020-06-23 18:59

terabros1 wrote:raspberry pi

Are you running Raspbian?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12194
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Default audio device issue

Postby terabros1 » 2020-06-24 15:53

Head_on_a_Stick wrote:
terabros1 wrote:raspberry pi

Are you running Raspbian?


Yes!

Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster
terabros1
 
Posts: 2
Joined: 2020-06-23 18:35

Re: Default audio device issue

Postby Head_on_a_Stick » 2020-06-24 16:22

Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12194
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Default audio device issue

Postby pendrachken » 2020-06-24 16:39

Default audio card for the user the web interface is running at is likely audiocard0. Specify the card you want with the command or find what user the web interface is running under and set up the default card to be the one you want.
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
pendrachken
 
Posts: 1374
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable