about apt-get update

If none of the more specific forums is the right place to ask

about apt-get update

Postby maslakd » 2020-06-23 20:20

Hi
i have debian9.7 and wanna upgrade it to 9.9

when i ran apt-get apt-get update, i got some errors;
# sudo apt-get update
Ign:1 http://webmin.mirror.somersettechsoluti ... repository sarge InRelease
Hit:2 http://webmin.mirror.somersettechsoluti ... repository sarge Release
Hit:3 http://security.debian.org/debian-security stretch/updates InRelease
Hit:4 http://security.debian.org stretch/updates InRelease
Ign:6 http://download.webmin.com/download/repository sarge InRelease
Ign:7 http://httpredir.debian.org/debian stretch InRelease
Get:8 http://httpredir.debian.org/debian stretch-updates InRelease [93.6 kB]
Err:9 https://packages.sury.org/php stretch InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
Hit:10 http://httpredir.debian.org/debian stretch Release
Hit:11 http://download.webmin.com/download/repository sarge Release
Fetched 93.6 kB in 0s (94.0 kB/s)
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/php stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
W: Failed to fetch https://packages.sury.org/php/dists/stretch/InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
W: Some index files failed to download. They have been ignored, or old ones used instead.

How can i fix it?
maslakd
 
Posts: 3
Joined: 2020-06-23 20:15

Re: about apt-get update

Postby arochester » 2020-06-23 20:28

You don't have Debian 9.7. You have a FrankenDebian, https://wiki.debian.org/DontBreakDebian ... nkenDebian

If you have anything valuable then copy it off to an external USB.

Make a new install.

Keep your sources list within reason. https://wiki.debian.org/SourcesList
arochester
 
Posts: 1687
Joined: 2010-12-07 19:55

Re: about apt-get update

Postby Head_on_a_Stick » 2020-06-24 16:28

The packages.sury.org repository is actually run by a Debian developer so the OP should probably ask them about the problem.

https://github.com/oerdnj/deb.sury.org/issues
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12194
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: about apt-get update

Postby eriefisher » 2020-06-24 21:29

The solution is in the error.

https://packages.sury.org/php/

You will see the apt.gpg key but click on the README.TXT instead.
____________________________________________
There's a manual?
Siduction
Debian Sid
Xfce4 4.14
User avatar
eriefisher
 
Posts: 114
Joined: 2008-06-04 03:49
Location: Ontario's South Coast

Re: about apt-get update

Postby maslakd » 2020-06-25 08:01

Thank you guys.

i could manage to upgrade my debian server from 9.7 to 10 Buster yesterday.

# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster

But i notice that kernel version has not changed
# uname -r
#1 SMP Debian 4.9.130-2 (2018-10-27)
How can i upgraded it too?
regards
maslakd
 
Posts: 3
Joined: 2020-06-23 20:15

Re: about apt-get update

Postby sickpig » 2020-06-25 10:56

/boot should have the new 4.19 kernel
rebooting will boot you into new one
User avatar
sickpig
 
Posts: 378
Joined: 2019-01-23 10:34

Re: about apt-get update

Postby maslakd » 2020-06-25 14:38

Thank you very much

It worked after rebooting.

regards
maslakd
 
Posts: 3
Joined: 2020-06-23 20:15


Return to General Questions

Who is online

Users browsing this forum: No registered users and 16 guests

fashionable