Trying to install trillian... libpango in sid is ourdated

If none of the more specific forums is the right place to ask

Trying to install trillian... libpango in sid is ourdated

Postby wrecked_machine » 2020-07-05 01:21

I'm trying to install Trillian, an essential app for my production environment. It requires libpango 1.3 or above; the version in Sid is still at 1.0. Any workarounds?
wrecked_machine
 
Posts: 7
Joined: 2020-07-04 15:00

Re: Trying to install trillian... libpango in sid is ourdate

Postby Head_on_a_Stick » 2020-07-05 08:13

wrecked_machine wrote:the version in Sid is still at 1.0

No it isn't, the sid version is 1.44.7. Even oldoldstable has v1.36.8.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Trying to install trillian... libpango in sid is ourdate

Postby wrecked_machine » 2020-07-05 08:42

Head_on_a_Stick wrote:
wrecked_machine wrote:the version in Sid is still at 1.0

No it isn't, the sid version is 1.44.7. Even oldoldstable has v1.36.8.


Ok, you're right... schoolchild error on my part. The version on my system is 1.44.7. Great. So why does gdebi insist it's an unresolvable dependency, and dpkg give me the following output? Note that it says libpango is not installed:

Code: Select all
sudo dpkg -i trillian_2.0.0.7_v5_amd64.deb                             
Selecting previously unselected package trillian.
(Reading database ... 325443 files and directories currently installed.)
Preparing to unpack trillian_2.0.0.7_v5_amd64.deb ...
Unpacking trillian (2.0.0.7) ...
dpkg: dependency problems prevent configuration of trillian:
 trillian depends on libatkmm-1.6-1v5 (>= 2.22.0); however:
  Package libatkmm-1.6-1v5 is not installed.
 trillian depends on libcairomm-1.0-1v5 (>= 1.10.0); however:
  Package libcairomm-1.0-1v5 is not installed.
 trillian depends on libgtkmm-3.0-1v5 (>= 3.12.0); however:
  Package libgtkmm-3.0-1v5 is not installed.
 trillian depends on libpango1.0-0 (>= 1.30.0); however:
  Package libpango1.0-0 is not installed.
 trillian depends on libpangomm-1.4-1v5 (>= 2.28.0); however:
  Package libpangomm-1.4-1v5 is not installed.
 trillian depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0 is not installed.
 trillian depends on libwebkitgtk-3.0-0 (>= 1.8.0); however:
  Package libwebkitgtk-3.0-0 is not installed.
wrecked_machine
 
Posts: 7
Joined: 2020-07-04 15:00

Re: Trying to install trillian... libpango in sid is ourdate

Postby Head_on_a_Stick » 2020-07-05 08:44

Try
Code: Select all
# apt install -f

Or
Code: Select all
# apt install /full/path/to/trillian_2.0.0.7_v5_amd64.deb

EDIT: actually gdebi should resolve and install the dependencies but the full error message will give us some more clues.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Trying to install trillian... libpango in sid is ourdate

Postby eriefisher » 2020-07-05 22:11

The problem is with the version scheme. You likely have libpango-1...... but it's asking for libpango1......Notice no (-) before the 1. I have run into it a couple times. They way around it was to edit the control file. I used dpkg-deb to unpack the deb then edited the control file then repack the deb and install. This will explain it.

https://unix.stackexchange.com/question ... deb/138190
____________________________________________
There's a manual?
Siduction
Debian Sid
Xfce4 4.14
User avatar
eriefisher
 
Posts: 129
Joined: 2008-06-04 03:49
Location: Ontario's South Coast

Re: Trying to install trillian... libpango in sid is ourdate

Postby stevepusser » 2020-07-06 03:34

Nonsense. Libpangomm is not the same package as libpango, and even Stretch had an acceptable version.

https://packages.debian.org/search?suit ... mm-1.4-1v5

https://packages.debian.org/search?suit ... pango1.0-0

These problems are almost always due to crazy sources that the user has messed around with, missing sources because they installed without a net connection, or rarely a bad mirror.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: Trying to install trillian... libpango in sid is ourdate

Postby eriefisher » 2020-07-07 10:56

____________________________________________
There's a manual?
Siduction
Debian Sid
Xfce4 4.14
User avatar
eriefisher
 
Posts: 129
Joined: 2008-06-04 03:49
Location: Ontario's South Coast

Re: Trying to install trillian... libpango in sid is ourdate

Postby stevepusser » 2020-07-07 23:36

wrecked_machine wrote:I'm trying to install Trillian, an essential app for my production environment. It requires libpango 1.3 or above; the version in Sid is still at 1.0. Any workarounds?


You're using Sid for a production environment? Well, at least you have an appropriate user name.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable