Cannot install anbox [SOLVED]

If none of the more specific forums is the right place to ask

Re: Cannot install anbox

Postby Scorpion » 2020-07-08 19:18

Code: Select all
grep -v '^$\|^#' /etc/apt/sources.list{,.d/*}
/etc/apt/sources.list:deb http://deb.debian.org/debian buster main contrib non-free
/etc/apt/sources.list:deb-src http://deb.debian.org/debian buster main contrib non-free
/etc/apt/sources.list:deb http://security.debian.org/debian-security buster/updates main contrib non-free
/etc/apt/sources.list:deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
/etc/apt/sources.list:deb http://deb.debian.org/debian buster-backports main contrib non-free
/etc/apt/sources.list.d/home:stevenpusser:codelite.list:deb http://download.opensuse.org/repositories/home:/stevenpusser:/codelite/Debian_9.0/ /

What mirror? How should I change the sources?

I cannot use anbox:
Code: Select all
anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity
[ 2020-07-08 20:03:43] [launch.cpp:214@operator()] Session manager failed to become ready

Is the "--package" the apk file? Where should I put those files?
What is the "--component"?
User avatar
Scorpion
 
Posts: 238
Joined: 2018-10-17 11:38

Re: Cannot install anbox

Postby Head_on_a_Stick » 2020-07-08 19:41

Scorpion wrote:What mirror?

https://www.debian.org/mirror/list

Scorpion wrote:How should I change the sources?

Code: Select all
# apt edit-sources
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12647
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Cannot install anbox

Postby stevepusser » 2020-07-09 03:02

That's a pretty old Liquorix kernel--I stopped building them there after Liquorix itself set up its own Debian repository. Why reinvent the wheel?

It probably has some nice unpatched security holes by now.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12075
Joined: 2009-10-06 05:53

Re: Cannot install anbox

Postby Scorpion » 2020-07-09 06:32

I change the sources to "ftp.it.debian.org ".

stevepusser wrote:That's a pretty old Liquorix kernel--I stopped building them there after Liquorix itself set up its own Debian repository. Why reinvent the wheel?

It probably has some nice unpatched security holes by now.

I had the repo from https://liquorix.net/:
Code: Select all
codename="$(find /etc/apt -type f -name '*.list' | xargs grep -E '^deb' | awk '{print $3}' | grep -Eo '^[a-z]+' | sort | uniq -c | sort -n | tail -n1 | grep -Eo '[a-z]+$')" && sudo apt-get install apt-transport-https curl && echo -e "deb http://liquorix.net/debian $codename main\ndeb-src http://liquorix.net/debian $codename main\n\n# Mirrors:\n#\n# Unit193 - France\n# deb http://mirror.unit193.net/liquorix $codename main\n# deb-src http://mirror.unit193.net/liquorix $codename main" | sudo tee /etc/apt/sources.list.d/liquorix.list && curl 'https://liquorix.net/linux-liquorix.pub' | sudo apt-key add - && sudo apt-get update


Now my repos are:
Code: Select all
inxi -r
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://ftp.it.debian.org/debian buster main contrib non-free
           2: deb-src http://ftp.it.debian.org/debian buster main contrib non-free
           3: deb http://security.debian.org/debian-security buster/updates main contrib non-free
           4: deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
           5: deb http://ftp.it.debian.org/debian buster-backports main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/liquorix.list
           1: deb http://liquorix.net/debian buster main
           2: deb-src http://liquorix.net/debian buster main


I am using apt upgrade, now there are a lot of packages to upgrade:
Code: Select all
182 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
User avatar
Scorpion
 
Posts: 238
Joined: 2018-10-17 11:38

Re: Cannot install anbox

Postby Scorpion » 2020-07-09 14:33

"lxc-templates" version:
Code: Select all
apt install lxc-templates
Reading package lists... Done
Building dependency tree       
Reading state information... Done
lxc-templates is already the newest version (3.0.4-0+deb10u1).

Code: Select all
apt update
Get:1 http://ftp.it.debian.org/debian buster InRelease [121 kB]
Hit:2 http://security.debian.org/debian-security buster/updates InRelease
Get:4 http://ftp.it.debian.org/debian buster-backports InRelease [46.7 kB]
Get:5 http://ftp.it.debian.org/debian buster/non-free Sources [85.9 kB]
Get:6 http://ftp.it.debian.org/debian buster/main Sources [7,831 kB]                       
Hit:3 https://liquorix.net/debian buster InRelease                       
Get:7 http://ftp.it.debian.org/debian buster/contrib Sources [43.1 kB]                                       
Get:8 http://ftp.it.debian.org/debian buster/main amd64 Packages [7,905 kB]                                 
Get:9 http://ftp.it.debian.org/debian buster/main i386 Packages [7,862 kB]                                   
Get:10 http://ftp.it.debian.org/debian buster/main Translation-en [5,969 kB]                                 
Get:11 http://ftp.it.debian.org/debian buster/main amd64 DEP-11 Metadata [3,807 kB]                         
Get:12 http://ftp.it.debian.org/debian buster/main DEP-11 48x48 Icons [3,770 kB]                             
Get:13 http://ftp.it.debian.org/debian buster/main DEP-11 64x64 Icons [7,596 kB]                             
Get:14 http://ftp.it.debian.org/debian buster/contrib i386 Packages [46.9 kB]                               
Get:15 http://ftp.it.debian.org/debian buster/contrib amd64 Packages [51.0 kB]                               
Get:16 http://ftp.it.debian.org/debian buster/contrib Translation-en [44.7 kB]                               
Get:17 http://ftp.it.debian.org/debian buster/contrib amd64 DEP-11 Metadata [11.5 kB]                       
Get:18 http://ftp.it.debian.org/debian buster/contrib DEP-11 48x48 Icons [56.4 kB]                           
Get:19 http://ftp.it.debian.org/debian buster/contrib DEP-11 64x64 Icons [110 kB]                           
Get:20 http://ftp.it.debian.org/debian buster/non-free amd64 Packages [87.7 kB]                             
Get:21 http://ftp.it.debian.org/debian buster/non-free i386 Packages [76.3 kB]                               
Get:22 http://ftp.it.debian.org/debian buster/non-free Translation-en [88.9 kB]                             
Get:23 http://ftp.it.debian.org/debian buster/non-free amd64 DEP-11 Metadata [9,096 B]                       
Get:24 http://ftp.it.debian.org/debian buster/non-free DEP-11 48x48 Icons [3,491 B]                         
Get:25 http://ftp.it.debian.org/debian buster/non-free DEP-11 64x64 Icons [38.3 kB]                         
Get:26 http://ftp.it.debian.org/debian buster-backports/main amd64 Packages [334 kB]                         
Get:27 http://ftp.it.debian.org/debian buster-backports/main i386 Packages [330 kB]                         
Get:28 http://ftp.it.debian.org/debian buster-backports/main Translation-en [267 kB]                         
Get:29 http://ftp.it.debian.org/debian buster-backports/contrib amd64 Packages [7,652 B]                     
Get:30 http://ftp.it.debian.org/debian buster-backports/contrib i386 Packages [7,252 B]                     
Get:31 http://ftp.it.debian.org/debian buster-backports/contrib Translation-en [5,936 B]                     
Get:32 http://ftp.it.debian.org/debian buster-backports/non-free amd64 Packages [23.8 kB]                   
Get:33 http://ftp.it.debian.org/debian buster-backports/non-free i386 Packages [16.4 kB]                     
Get:34 http://ftp.it.debian.org/debian buster-backports/non-free Translation-en [30.8 kB]                   
Fetched 46.7 MB in 27s (1,761 kB/s)                                                                         
Reading package lists... Done
Building dependency tree       
Reading state information... Done
184 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@debian-desktop:~# apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  im-config libfcitx-config4 libfcitx-core0 libfcitx-gclient1 libfcitx-qt5-1 libfcitx-qt5-data
  libfcitx-utils0 libgettextpo0 libm17n-0 libotf0 libpresage-data libpresage1v5 m17n-db presage
  python3-gst-1.0
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  amd64-microcode firmware-amd-graphics firmware-linux-nonfree linux-headers-4.19.0-9-amd64
  linux-headers-4.19.0-9-common linux-headers-5.7.0-7.1-liquorix-amd64 linux-image-4.19.0-9-amd64
  linux-image-5.7.0-7.1-liquorix-amd64
The following packages will be upgraded:
  base-files cups cups-bsd cups-client cups-common cups-core-drivers cups-daemon cups-ipp-utils cups-ppdc
  cups-server-common distro-info-data dtv-scan-tables ffmpeg fonts-opensymbol fuse gir1.2-lokdocview-0.1
  gir1.2-pango-1.0 iputils-ping iputils-tracepath libavcodec-dev libavcodec58 libavcodec58:i386
  libavdevice58 libavfilter7 libavformat-dev libavformat58 libavresample-dev libavresample4
  libavresample4:i386 libavutil-dev libavutil56 libavutil56:i386 libbrlapi0.6 libcuda1 libcuda1:i386
  libcuda1-i386:i386 libcups2 libcups2:i386 libcups2-dev libcupsimage2 libcupsimage2-dev libegl-nvidia0
  libegl-nvidia0:i386 libel-api-java libfuse2 libgl1-nvidia-glvnd-glx libgl1-nvidia-glvnd-glx:i386
  libgles-nvidia1 libgles-nvidia1:i386 libgles-nvidia2 libgles-nvidia2:i386 libglx-nvidia0
  libglx-nvidia0:i386 libjsp-api-java liblibreofficekitgtk libnss-myhostname libnvcuvid1 libnvidia-cbl
  libnvidia-compiler libnvidia-eglcore libnvidia-eglcore:i386 libnvidia-fatbinaryloader
  libnvidia-fatbinaryloader:i386 libnvidia-glcore libnvidia-glcore:i386 libnvidia-glvkspirv
  libnvidia-glvkspirv:i386 libnvidia-ml1 libnvidia-ptxjitcompiler1 libnvidia-ptxjitcompiler1:i386
  libnvidia-rtcore libpam-systemd libpango-1.0-0 libpango-1.0-0:i386 libpango1.0-0 libpango1.0-dev
  libpango1.0-doc libpangocairo-1.0-0 libpangocairo-1.0-0:i386 libpangoft2-1.0-0 libpangoft2-1.0-0:i386
  libpangoxft-1.0-0 libpostproc-dev libpostproc55 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-avmedia-backend-vlc libreoffice-base libreoffice-base-core libreoffice-base-drivers
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-evolution
  libreoffice-gnome libreoffice-gtk3 libreoffice-help-common libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-librelogo libreoffice-math libreoffice-nlpsolver
  libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-hsqldb
  libreoffice-sdbc-postgresql libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher
  libreoffice-writer libreofficekit-data libruby2.5 libspeechd2 libssh-gcrypt-4 libswresample-dev
  libswresample3 libswresample3:i386 libswscale-dev libswscale5 libsystemd-dev libsystemd0 libsystemd0:i386
  libtag1-dev libtag1v5 libtag1v5-vanilla libtagc0 libudev-dev libudev1 libudev1:i386 libvncclient1
  libvncserver-config libvncserver-dev libvncserver1 libwebsocket-api-java linux-headers-amd64
  linux-headers-liquorix-amd64 linux-image-amd64 linux-image-liquorix-amd64 nvidia-alternative nvidia-driver
  nvidia-driver-bin nvidia-driver-libs nvidia-driver-libs:i386 nvidia-driver-libs-i386:i386
  nvidia-egl-common:i386 nvidia-egl-icd nvidia-egl-icd:i386 nvidia-kernel-dkms nvidia-kernel-support
  nvidia-legacy-check nvidia-opencl-common nvidia-opencl-icd nvidia-smi nvidia-vdpau-driver
  nvidia-vulkan-common nvidia-vulkan-icd nvidia-vulkan-icd:i386 ovmf pango1.0-tools python3-brlapi
  python3-speechd python3-uno rake ruby2.5 rubygems-integration speech-dispatcher
  speech-dispatcher-audio-plugins speech-dispatcher-espeak-ng systemd systemd-sysv timeshift tzdata udev
  uno-libs3 ure wpasupplicant xbrlapi xdg-utils xserver-xorg-video-nvidia
184 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 376 MB of archives.
After this operation, 743 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

I upgraded, the nvidia-driver and nvidia-kernel-dkms became broken. I wasn' t able to use the GUI, "Failed to load kernel modules".
Luckily the timeshift monthly backup was yesterday.

Is that for the liquorix repo?
Now if the system updates it will be a problem.
User avatar
Scorpion
 
Posts: 238
Joined: 2018-10-17 11:38

Re: Cannot install anbox

Postby Head_on_a_Stick » 2020-07-09 19:14

If you want the Liquorix kernel to be kept updated then install their kernel metapackage and please stop asking off-topic questions.

I presume this thread can now be marked [SOLVED]?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12647
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Cannot install anbox

Postby Scorpion » 2020-07-09 19:21

Head_on_a_Stick wrote:If you want the Liquorix kernel to be kept updated then install their kernel metapackage and please stop asking off-topic questions.

I presume this thread can now be marked [SOLVED]?

Their kernel metapackage?
But it is not normal that If I use apt upgrade all kernels get ruined.

The thread is solved I will open a new one about using anbox, that is not so off-topic.
User avatar
Scorpion
 
Posts: 238
Joined: 2018-10-17 11:38

Previous

Return to General Questions

Who is online

Users browsing this forum: No registered users and 20 guests

fashionable