is anyone using wps office?

If none of the more specific forums is the right place to ask

is anyone using wps office?

Postby milomak » 2020-07-16 22:12

i seem to have an issue that it is not picking up my LC_TIME locale setting

i have run softmaker free 2018 and libreoffice and they pick up that i am typing dates as dd/mm/yy

yet wps despite various interventions sees that as mm/dd/yy

my locale is
Code: Select all

wps doesn't care if i install it as a deb

tried flatpak and set the environment
Code: Select all
flatpak override --env=LC_TIME=en_NZ.UTF-8 com.wps.Office

nope still sees the date as mm/dd/yy
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Sid (External SSD)
Laptop: Lenovo ideapad Y700-15ISK [nVidia Optimus] (64-bit) - Sid, Win10, Solus
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
Posts: 2055
Joined: 2009-06-09 22:20

Re: is anyone using wps office?

Postby ruwolf » 2020-07-16 23:57

I am afraid, that you are asking on wrong place.
It seems to be proprietary software, which is not part of Debian.
You should ask Kingsoft instead, in my opinion...
User avatar
Posts: 429
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: is anyone using wps office?

Postby cuckooflew » 2020-07-17 01:34

I think so as well, it is funny though, these proprietary soft wares seem to almost never offer support. Any way , maybe someone will come a long that is using it, ......I was doing some searches, because until now I had never heard of this WPS office, and was curious about what it is,...sound lovely, from one article I read:
I tried WPS office ONCE and, in addition to being closed source it then put it's tendrils into every document on the computer and complained mightily when I wanted to use LO or KO. So I uninstalled it tha day.

I uninstalled it on Linux because I found out, using my Task Manager & the terminal, that it was trying to access my webcam (!) something that an Office suite shouldn't absolutely need to do. I went to check the processes because the opening page of Writer was trying to download the Free Templates thumbnails but it was blocked by the GUFW firewall, which is the default Home firewall behavior (Deny Incoming) for all programs, except browsers, unless you add an exception rule to them. Of course, in Linux, WPS Office can't do anything without the proper permissions and I don't really know how it behaves under Windows, but I'm posting this here as a warning.
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
Just say NO to help vampires!
Posts: 683
Joined: 2018-05-10 19:34
Location: Some where out west

Return to General Questions

Who is online

Users browsing this forum: No registered users and 17 guests