Is DPM enabled for Radeon cards by default? Fans too loud

If none of the more specific forums is the right place to ask

Is DPM enabled for Radeon cards by default? Fans too loud

Postby Lysander » 2020-07-28 08:54

I'm posting this in the General section rather than Hardware because I am increasingly thinking that this is a driver issue.

I bought a second hand Radeon 6870 off ebay and the fans are rather loud, even on idle. I thought this may be a hardware issue, but reading around I came across this:

https://forums.freebsd.org/threads/amd- ... lem.58939/

Everything is fine, however, my graphics card [6870] fan is very noisy (for the example on ubuntu it is really quiet). The fan is loud even during idle.


This is exactly the issue I am experiencing, and it's interesting to note that the issue goes away on Ubuntu where DPM has been enabled by default since 14.04.

Temps are very good, around 40C idle, 70C when gaming.

Before I do something crazy like install Ubuntu, I will run a test in a live environment and see if that makes any difference.

Since I think this is an issue with DPM, how can I check if it's enabled by default, and how can I enable it if it isn't? Is it simply a matter of adding

Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"

to GRUB?

I have the microcode drivers installed.

EDIT: I just came across this, maybe it'll help with the fan speed

https://sourceforge.net/projects/amdovdrvctrl/

More evidence that this is software related:

https://webcache.googleusercontent.com/ ... clnk&gl=uk
User avatar
Lysander
 
Posts: 622
Joined: 2017-02-23 10:07
Location: London

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Head_on_a_Stick » 2020-07-28 16:10

Lysander wrote:on Ubuntu where DPM has been enabled by default

That's not an Ubuntu thing, it's a kernel thing: https://kernelnewbies.org/Linux_3.13#Ra ... ii_support

Check if it's enabled in your system with
Code: Select all
cat /sys/modules/radeon/parameters/dpm

Lysander wrote:how can I enable it if it isn't? Is it simply a matter of adding

Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1"

to GRUB?

Add that to /etc/default/grub then run 'update-grub' (as root) to generate a new configuration file.

For fan speed control see https://wiki.archlinux.org/index.php/ATI#Fan_Speed

Lysander wrote:I have the microcode drivers installed

What are "microcode drivers"? Do you mean the non-free firmware that is required for AMD cards?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12647
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Lysander » 2020-07-28 16:42

Head_on_a_Stick wrote:
Lysander wrote:on Ubuntu where DPM has been enabled by default

That's not an Ubuntu thing, it's a kernel thing: https://kernelnewbies.org/Linux_3.13#Ra ... ii_support


Ah OK. I just tried 20.04 on USB, no difference though. Still the same. 20.04 does look very swish though.

Head_on_a_Stick wrote:Check if it's enabled in your system with
Code: Select all
cat /sys/modules/radeon/parameters/dpm


This just said

Code: Select all
# cat: /sys/modules/radeon/parameters/dpm: No such file or directory


However, dmseg gave me this in Ubuntu

Code: Select all
root@ubuntu:~# dmesg | grep radeon
[    2.010281] [drm] radeon kernel modesetting enabled.
[    2.010361] radeon 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xd0000000 -> 0xdfffffff
[    2.010363] radeon 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xf7dc0000 -> 0xf7ddffff
[    2.010365] radeon 0000:01:00.0: vgaarb: deactivate vga console
[    2.012872] radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[    2.012874] radeon 0000:01:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[    2.012999] [drm] radeon: 1024M of VRAM memory ready
[    2.013000] [drm] radeon: 1024M of GTT memory ready.
[    2.018330] [drm] radeon: dpm initialized
[    2.021243] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[    2.041922] radeon 0000:01:00.0: WB enabled
[    2.041925] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0x(____ptrval____)
[    2.041927] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0x(____ptrval____)
[    2.042696] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0x(____ptrval____)
[    2.042702] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[    2.042752] radeon 0000:01:00.0: radeon: using MSI.
[    2.042783] [drm] radeon: irq initialized.
[    3.012221] fbcon: radeondrmfb (fb0) is primary device
[    3.063738] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[    3.078633] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
[   10.070523] radeon_dp_aux_transfer_native: 242 callbacks suppressed
[  139.138536] radeon_dp_aux_transfer_native: 74 callbacks suppressed
[  145.818578] radeon_dp_aux_transfer_native: 242 callbacks suppressed
[  151.850508] radeon_dp_aux_transfer_native: 74 callbacks suppressed
[  159.702544] radeon_dp_aux_transfer_native: 326 callbacks suppressed
[  164.714507] radeon_dp_aux_transfer_native: 200 callbacks suppressed


And this in Debian

Code: Select all
[    1.986618] [drm] radeon kernel modesetting enabled.
[    1.987145] radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[    1.987147] radeon 0000:01:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[    1.987283] [drm] radeon: 1024M of VRAM memory ready
[    1.987284] [drm] radeon: 1024M of GTT memory ready.
[    1.987321] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/BARTS_pfp.bin
[    1.987341] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/BARTS_me.bin
[    1.987356] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/BTC_rlc.bin
[    1.987384] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/BARTS_mc.bin
[    1.987412] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/BARTS_smc.bin
[    1.992388] [drm] radeon: dpm initialized
[    1.992513] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/SUMO_uvd.bin
[    1.994041] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[    2.007463] radeon 0000:01:00.0: WB enabled
[    2.007466] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0x(____ptrval____)
[    2.007467] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0x(____ptrval____)
[    2.008236] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0x(____ptrval____)
[    2.008241] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[    2.008291] radeon 0000:01:00.0: radeon: using MSI.
[    2.008322] [drm] radeon: irq initialized.
[    2.994118] fbcon: radeondrmfb (fb0) is primary device
[    3.058780] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[    3.088944] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
[   23.587858] radeon_dp_aux_transfer_native: 326 callbacks suppressed
[   32.246536] radeon_dp_aux_transfer_native: 158 callbacks suppressed


So it looks like it is enabled.

Temps are also very good though in spite of this thing running loudly. 42C at the moment.

Head_on_a_Stick wrote:For fan speed control see https://wiki.archlinux.org/index.php/ATI#Fan_Speed


Thanks, though I can't see this being a good solution for gaming.

Head_on_a_Stick wrote:
Lysander wrote:I have the microcode drivers installed

What are "microcode drivers"? Do you mean the non-free firmware that is required for AMD cards?


Yes, that's what I mean. Sorry for the lazy terminology.

The weird thing is that this happens immediately when I turn the PC on. Yesterday it went on for about 20-30 mins after the PC was turned on, and then the fans went quiet. Most odd.

I don't want to be messing around with fan speeds in the BIOS though. I suppose the only other options is looking inside the card to see if there's dust.
User avatar
Lysander
 
Posts: 622
Joined: 2017-02-23 10:07
Location: London

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Head_on_a_Stick » 2020-07-28 16:53

Lysander wrote:
Head_on_a_Stick wrote:Check if it's enabled in your system with
Code: Select all
cat /sys/modules/radeon/parameters/dpm


This just said

Code: Select all
# cat: /sys/modules/radeon/parameters/dpm: No such file or directory

So which parameters are available in /sys/modules/radeon/ then? Look around the sysfs directories, I'm not running Linux atm so I can't help directly.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12647
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Lysander » 2020-07-28 16:55

Head_on_a_Stick wrote:
Lysander wrote:
Head_on_a_Stick wrote:Check if it's enabled in your system with
Code: Select all
cat /sys/modules/radeon/parameters/dpm


This just said

Code: Select all
# cat: /sys/modules/radeon/parameters/dpm: No such file or directory

So which parameters are available in /sys/modules/radeon/ then? Look around the sysfs directories, I'm not running Linux atm so I can't help directly.


Weird, I must have been doing something wrong. Anyway, I got this

Code: Select all
-1


This means that it's auto. I wonder if I should change it to enabled through GRUB?

EDIT: Just did it anyway, no difference. So I'm guessing dust or maybe a BIOS setting. I can't understand why it would be the BIOS though, I have had nothing like this in the other cards I've used.
User avatar
Lysander
 
Posts: 622
Joined: 2017-02-23 10:07
Location: London

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Lysander » 2020-07-28 19:31

Just took the card apart, cleaned out all the dust and gunk and reapplied thermal paste. Fans are still loud. No idea what the issue could be, maybe it's meant to be like this.
User avatar
Lysander
 
Posts: 622
Joined: 2017-02-23 10:07
Location: London

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Lysander » 2020-07-29 17:36

OK, I went to try out amdgpu-fan from the Arch page so it could automatically adjust the fan speed at higher temps.

The installation was apparently successful and the program automatically created the config file in /etc/amdgpu-fan.yml. But when trying to run the program through

Code: Select all
amdgpu-fan


I get

Code: Select all
root@psychopig-xxxvii:/home/lysander/amdgpu# amdgpu-fan
starting amdgpu-fan
Traceback (most recent call last):
  File "/usr/local/bin/amdgpu-fan", line 10, in <module>
    sys.exit(main())
  File "/usr/local/lib/python3.7/dist-packages/amdgpu_fan/controller.py", line 78, in main
    FanController(config).main()
  File "/usr/local/lib/python3.7/dist-packages/amdgpu_fan/controller.py", line 35, in main
    logger.debug(f'{name}: Temp {temp}, Setting fan speed to: {speed}, fan speed{card.fan_speed}, min:{card.fan_min}, max:{card.fan_max}')
  File "/usr/local/lib/python3.7/dist-packages/amdgpu_fan/lib/amdgpu.py", line 64, in fan_min
    return int(self.read_endpoint('pwm1_min'))
  File "/usr/local/lib/python3.7/dist-packages/amdgpu_fan/lib/amdgpu.py", line 36, in read_endpoint
    with open(self._endpoints[endpoint], 'r') as e:
KeyError: 'pwm1_min'



It also says the service is not found

Code: Select all
root@psychopig-xxxvii:/home/lysander/amdgpu# systemctl start amdgpu-fan.service
Failed to start amdgpu-fan.service: Unit amdgpu-fan.service not found.



Any idea what I could be doing wrong here to get the program to run correctly?

Also apparently I cannot change the fan speed manually. I get this error:

Code: Select all
root@psychopig-xxxvii:~# echo "1" > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable
-bash: /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable: Permission denied


Which, according to this means that doing so is not possible.

Okay, there is not a "File" called pwm1_enable in that path, and the system is telling you that it is not permissible to create one.

"Files" in the /sys file system are things that act like files that are dynamically generated by the kernel to expose some of the inner working of the kernel. It will create the contents on demand. Likewise, if the kernel wants to accept input from user space, it will allow you to write to those "Files" as a way of communicating something to the kernel. That that "file" does not exist means that you are chasing ghosts here. I am not saying that it will not work; I am saying that the solutions you have been chasing seem to be deprecated.
User avatar
Lysander
 
Posts: 622
Joined: 2017-02-23 10:07
Location: London

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Head_on_a_Stick » 2020-07-29 19:16

Lysander wrote:The installation was apparently successful

How did you install it, exactly?

Lysander wrote:when trying to run the program through

Code: Select all
amdgpu-fan


I get

Have you checked the shebang for the script? Arch doesn't use Python2 any more but Debian does.

Lysander wrote:It also says the service is not found

Sounds like you didn't install the unit file.

Lysander wrote:Also apparently I cannot change the fan speed manually. I get this error:

Code: Select all
root@psychopig-xxxvii:~# echo "1" > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable
-bash: /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable: Permission denied


Which, according to this means that doing so is not possible

No, doesn't look like it.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12647
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Is DPM enabled for Radeon cards by default? Fans too lou

Postby Lysander » 2020-07-30 07:50

Head_on_a_Stick wrote:
Lysander wrote:The installation was apparently successful

How did you install it, exactly?


I took the following steps:

1. Installed python3 and python3-pip from the Debian repos. The amdgpu-fan page says that it only works with python3.
2. Downloaded the amdgpu-fan zip and extracted it to its own folder, I than navigated to that folder in the terminal.
3. I then ran
Code: Select all
pip3 install amdgpu-fan


It downloaded some more files and I then got a notification in the terminal saying the installation was successful [though sometimes this isn't necessarily true].

Head_on_a_Stick wrote:
Lysander wrote:when trying to run the program through

Code: Select all
amdgpu-fan


I get

Have you checked the shebang for the script? Arch doesn't use Python2 any more but Debian does.


I take it python 2 and 3 don't tread on each other and are independent? Kind of like qt4 and qt5.

Head_on_a_Stick wrote:
Lysander wrote:It also says the service is not found

Sounds like you didn't install the unit file.


This is something to do with systemd, I take it. Do I have to write something to /usr/lib?

Head_on_a_Stick wrote:
Lysander wrote:Also apparently I cannot change the fan speed manually. I get this error:

Code: Select all
root@psychopig-xxxvii:~# echo "1" > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable
-bash: /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable: Permission denied


Which, according to this means that doing so is not possible

No, doesn't look like it.


Bugger.

EDIT: very, very weirdly this card seems to store the last fan speed it utilised before shutdown in its BIOS or something. I recall last night, after four or so hours of high fan-level, the fan went very quiet [in the middle of a game!] till I turned the PC off. Temps fine the whole time. Now, I've turned the PC on and the GPU fan is quiet just like last night. Very strange. Other times I've turned the PC on and the GPU fan has been loud, just as loud as it was when I turned the computer off before - it must be something to do with the last fan speed being stored in the mb/gpu BIOS because the fan level is noticeable immediately when the PC is turned on. Who knows what weird rules Sapphire made for this thing!
User avatar
Lysander
 
Posts: 622
Joined: 2017-02-23 10:07
Location: London


Return to General Questions

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable