Upgrade fail cant find archive linux-image-4.9.0-9-686-pae

If none of the more specific forums is the right place to ask

Upgrade fail cant find archive linux-image-4.9.0-9-686-pae

Postby ericoberg1 » 2020-08-10 21:00

Hi All,

Running 9.9 stretch on an Atom computer. Install was easy, been working fine for months. I run sudo apt-get update and everything runs no problem. Go to run upgrade and get this:

atom@Atom:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package linux-image-4.9.0-9-686-pae needs to be reinstalled, but I can't find an archive for it.
atom@Atom:~$

I know that from the update, I am connecting to all the right places (text at the bottom). What am I doing wrong?

Thank you,
ericoberg1


Here is the update result:

atom@Atom:~$ sudo apt-get update
Get:1 http://security.debian.org/debian-security stretch/updates InRelease [53.0 kB]
Ign:2 http://ftp.us.debian.org/debian stretch InRelease
Get:3 http://ftp.us.debian.org/debian stretch-updates InRelease [93.6 kB]
Hit:4 http://ftp.us.debian.org/debian stretch Release
Get:5 http://security.debian.org/debian-security stretch/updates/non-free Sources [1,216 B]
Get:6 http://security.debian.org/debian-security stretch/updates/main Sources [227 kB]
Get:7 http://security.debian.org/debian-security stretch/updates/main i386 Packages [547 kB]
Get:8 http://security.debian.org/debian-security stretch/updates/main Translation-en [241 kB]
Get:9 http://ftp.us.debian.org/debian stretch-updates/non-free Sources [816 B]
Get:10 http://ftp.us.debian.org/debian stretch-updates/non-free i386 Packages [632 B]
Get:11 http://ftp.us.debian.org/debian stretch-updates/non-free Translation-en [673 B]
Get:12 http://security.debian.org/debian-security stretch/updates/non-free i386 Packages [1,592 B]
Get:13 http://security.debian.org/debian-security stretch/updates/non-free Translation-en [691 B]
Get:15 http://ftp.us.debian.org/debian stretch/non-free Sources [79.1 kB]
Get:16 http://ftp.us.debian.org/debian stretch/contrib Sources [44.5 kB]
Get:17 http://ftp.us.debian.org/debian stretch/contrib i386 Packages [47.7 kB]
Get:18 http://ftp.us.debian.org/debian stretch/contrib Translation-en [45.8 kB]
Get:19 http://ftp.us.debian.org/debian stretch/contrib i386 DEP-11 Metadata [7,332 B]
Get:20 http://ftp.us.debian.org/debian stretch/contrib DEP-11 64x64 Icons [100 kB]
Get:21 http://ftp.us.debian.org/debian stretch/non-free i386 Packages [69.4 kB]
Get:22 http://ftp.us.debian.org/debian stretch/non-free Translation-en [80.2 kB]
Get:23 http://ftp.us.debian.org/debian stretch/non-free i386 DEP-11 Metadata [7,472 B]
Get:24 http://ftp.us.debian.org/debian stretch/non-free DEP-11 64x64 Icons [30.0 kB]
Fetched 1,679 kB in 4s (399 kB/s)
Reading package lists... Done
ericoberg1
 
Posts: 4
Joined: 2020-08-10 20:28

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby ruwolf » 2020-08-10 22:17

How do your links to repositories (e.g. file /etc/apt/sources.list or files in /etc/apt/sources.list.d) look?
BTW, you can find available images of your installed type by e.g.:
Code: Select all
apt-cache search 'linux-image-.*-686-pae'
User avatar
ruwolf
 
Posts: 429
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby ericoberg1 » 2020-08-10 22:46

Hi ruwolf,

Thank you for responding.

The sources.list is this:

atom@Atom:/etc/apt$ more sources.list
#
# deb cdrom:[Debian GNU/Linux 9.9.0 _Stretch_ - Official i386 DVD Binary-1 20190427-11:18]/ stretch contrib main
# deb cdrom:[Debian GNU/Linux 9.9.0 _Stretch_ - Official i386 DVD Binary-1 20190427-11:18]/ stretch contrib main
deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free
# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
atom@Atom:/etc/apt$

There is nothing in /etc/apt/sources.list.d

The apt-cache search gives this:

atom@Atom:~$ apt-cache search 'linux-image-.*-686-pae'
linux-headers-4.9.0-13-686-pae - Header files for Linux 4.9.0-13-686-pae
linux-headers-4.9.0-13-rt-686-pae - Header files for Linux 4.9.0-13-rt-686-pae
linux-image-4.9.0-13-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-13-686-pae-dbg - Debug symbols for linux-image-4.9.0-13-686-pae
linux-image-4.9.0-13-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-13-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-13-rt-686-pae
linux-image-rt-686-pae - Linux for modern PCs (meta-package), PREEMPT_RT
linux-image-rt-686-pae-dbg - Debugging symbols for Linux rt-686-pae configuration (meta-package)
linux-headers-4.9.0-11-686-pae - Header files for Linux 4.9.0-11-686-pae
linux-headers-4.9.0-11-rt-686-pae - Header files for Linux 4.9.0-11-rt-686-pae
linux-headers-4.9.0-12-686-pae - Header files for Linux 4.9.0-12-686-pae
linux-headers-4.9.0-12-rt-686-pae - Header files for Linux 4.9.0-12-rt-686-pae
linux-image-4.9.0-11-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-11-686-pae-dbg - Debug symbols for linux-image-4.9.0-11-686-pae
linux-image-4.9.0-11-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-11-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-11-rt-686-pae
linux-image-4.9.0-12-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-12-686-pae-dbg - Debug symbols for linux-image-4.9.0-12-686-pae
linux-image-4.9.0-12-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-12-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-12-rt-686-pae
linux-image-4.9.0-9-686-pae - Linux 4.9 for modern PCs
atom@Atom:~$
ericoberg1
 
Posts: 4
Joined: 2020-08-10 20:28

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby cuckooflew » 2020-08-10 22:48

Seems to be here, : https://packages.debian.org/stretch/linux-image-686-pae

The package linux-image-4.9.0-9-686-pae needs to be reinstalled,

Maybe the existing/old one needs to be purged/removed in order to re-install it. ? I am not sure on that.
Are you sure those repositories are correct ? In your sources.list file,...please use code boxes for that kind of thing, but to me it does not look like what is shown here:
https://wiki.debian.org/LTS/Using
Important: Debian 9 stretch LTS only supports i386, amd64, arm64, armel and armhf. Users of other architectures are encouraged to upgrade to Debian 10 buster.

The current LTS version is Debian 9 stretch and will be supported from 2020-07-06 to 2022-06-30. To receive security updates, your /etc/apt/sources.list should look like this one:

Code: Select all
deb http://deb.debian.org/debian/ stretch main contrib non-free
deb-src http://deb.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 683
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby stevepusser » 2020-08-11 03:15

You should update to 4.9.0-13 (or the latest version in the future) for the security fixes, y'know.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12072
Joined: 2009-10-06 05:53

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby Head_on_a_Stick » 2020-08-11 15:06

Is the kernel metapackage installed and up to date?
Code: Select all
apt policy linux-image-686-pae

https://packages.debian.org/stretch/linux-image-686-pae
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12629
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby ericoberg1 » 2020-08-11 20:45

Thanks All,

Bunch of stuff to try. Will have at it tonight and tomorrow.
ericoberg1
 
Posts: 4
Joined: 2020-08-10 20:28

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby Deb-fan » 2020-08-12 10:51

Hmmmm, if only apt would give a clue, some indication of what the problem might be, if only there was something to go on, a message of some sort. Apt, speak to us, tell us something, anything we might then feed into a search engine ... apt? What's wrong? Apt? Apttttt?!??!

Couldn't resist any longer and it's too funny of an opp to pass up. :P
Most powerful FREE tech-support tool on the planet * HERE. *
Deb-fan
 
Posts: 939
Joined: 2012-08-14 12:27

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby stevepusser » 2020-08-13 04:22

OK, the reason that's not in the repo any longer is that it's been replaced by a newer kernel with security fixes. Follow the suggestions to install the kernel metapackage from HOAS, upgrade thine olde and busted kernel, and mark this thread [SOLVED].
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12072
Joined: 2009-10-06 05:53

Re: Upgrade fail cant find archive linux-image-4.9.0-9-686-p

Postby ericoberg1 » 2020-08-14 15:08

Hi Steve,

That is good info, searched high and low for the 4.9.0.9 version. I use this computer just a few hours a week on a mesh network, not connected to the "Internet". I will have to decide how long I want to stall before I upgrade to the new kernel.

deb-fan, useless.
ericoberg1
 
Posts: 4
Joined: 2020-08-10 20:28


Return to General Questions

Who is online

Users browsing this forum: esalvesen and 20 guests

fashionable