Need kind help with enforcing custom EDID from firmware!

If none of the more specific forums is the right place to ask

Re: Need kind help with enforcing custom EDID from firmware!

Postby Head_on_a_Stick » 2020-08-16 14:33

cuckooflew wrote:LE_746F6D617A7A69 said you won't find it there, guess you did not believe it. ?

I had already checked before Tomazzi posted, I was just reinforcing their point for our obstreperous OP.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Need help with enforcing custom EDID from firmware!

Postby LE_746F6D617A7A69 » 2020-08-16 18:24

DeabianDieHard wrote:On arch wiki, it said this line: Extracting an existing one is in most cases easier, e.g. if your monitor works fine under Windows you might have luck extracting the EDID from the corresponding driver. This line is the reason why I made such a long post.. In the hope that someone would help me but the power user above is telling me that I am spamming.
Ah yes - somehow I have mislooked this sentence (probably i was just too tired) - but anyway It's one of very few cases when the Arch wiki is not correct - You can't extract the EDID data from windows drivers.

I think the intention of author of that wiki was to suggest that You can read the EDID data under windows if it does not work under Linux -> which is a very unlikely and rare case.

Definitely, I was too tired to read the original post carefully and with understanding:
DeabianDieHard wrote:I dual boot Windows and Linux and bother Operating Systems perfectly recognized this monitor as LG 19 up until last month when suddenly the resolutions reverted back to 1024x768 (in both OS(s) ofc). On Windows I suddenly had/and still have resolutions up to 2560x1600. Not kidding, check this Since the option 1366x768 was still available on Windows, I selected that and Windows never had any issues thereafter. But on Linux, the solution was hacky and ended up with a weird resolution 1368x768 instead of 1366x6768 no matter how hard I tried. Heck, Linux , unlike Windows just didn't have resolutions more than 1024x768 showing up in option so I had to manually add the custom mode and then activate. The result is some weird font issues (not related to RGB, hinting or DPI I swear).

I ran this Monitor Asset Manager tool and it shows all sorts of impossible resolutions (for tis 720p monitor) and six random ABC xxxxxx models instead of LG19XXX. I have pasted all the output here:
I have checked the raw EDID data reported by Monitor Asset Manager, which the OP posted on pastebin: indeed, the native resoulution for the first monitor is reported as 2560x1600, and moreover, all the checksums are correct.
However I don't know whether that application works correctly, that is, where those monitor data are read from - it looks like some cached data and/or complete bullshit spewed by that app.

Judging by the fact that "suddenly" both OSes switched to a fail-safe resolution of 1024x768 I'll bet that it's a problem with monitor or with the cable. Of course the best option is to repair the HW. The only other option IMO is to find original EDID data for this monitor (on the internet - because it does not seem to be possible on Windows too), and then follow the Arch wiki.

Regarding the 1366x768 problem: This resolution is not supported by most of existing GFX cards, even on windows, where a special trick with virtual desktop size is used to trick the users. The closest supported resolution is exactly the 1368x768. I think that the trick with virtual desktop size is also possible in X11, but I have no time test this.
Bill Gates: "(...) In my case, I went to the garbage cans at the Computer Science Center and I fished out listings of their operating system."
The_full_story and Nothing_have_changed
Posts: 472
Joined: 2020-05-03 14:16


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests