(Solved)error python-enum34

If none of the more specific forums is the right place to ask

(Solved)error python-enum34

Postby sarksloane » 2020-08-16 06:30

I keep on receiving the below errors:

Code: Select all
Errors were encountered while processing:
 python-enum34
 minissdpd
 apt-listchanges
Last edited by sarksloane on 2020-08-26 13:07, edited 1 time in total.
sarksloane
 
Posts: 86
Joined: 2017-01-17 04:21

Re: error python-enum34

Postby Head_on_a_Stick » 2020-08-16 13:22

Please post the full, verbatim output rather than a snippet. Also include the command that caused the error and the full output of
Code: Select all
apt policy
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13087
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: error python-enum34

Postby sarksloane » 2020-08-20 21:17

thanks..please find the below..

Code: Select all
apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.2~buster)
E: Unable to correct problems, you have held broken packages.
root@debian:/home/mohammadmishary# dpkg --configure -a
dpkg: error processing package python-enum34 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Setting up minissdpd (1.5.20190210-1) ...
wlo1 Job for minissdpd.service failed because the control process exited with error code.
See "systemctl status minissdpd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript minissdpd, action "restart" failed.
● minissdpd.service - keep memory of all UPnP devices that announced themselves
   Loaded: loaded (/lib/systemd/system/minissdpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2020-08-21 06:05:08 PST; 12ms ago
     Docs: man:minissdpd(1)
  Process: 8903 ExecStart=/usr/lib/minissdpd/minissdpd-systemd-wrapper ${MiniSSDPd_INTERFACE_ADDRESS} $MiniSSDPd_OTHER_OPTIONS (code=exited, status=1/FAILURE)

Aug 21 06:05:08 debian systemd[1]: Starting keep memory of all UPnP devices that announced themselves...
Aug 21 06:05:08 debian minissdpd-systemd-wrapper[8903]: Usage: /usr/sbin/minissdpd [-d] [-6] [-s socket] [-p pidfile] [-t TTL] [-f device] -i <interface> [-i <interface2>] ...
Aug 21 06:05:08 debian minissdpd-systemd-wrapper[8903]:   <interface> is either an IPv4 address with mask such as
Aug 21 06:05:08 debian minissdpd-systemd-wrapper[8903]:   192.168.1.42/255.255.255.0, or an interface name such as eth0.
Aug 21 06:05:08 debian minissdpd-systemd-wrapper[8903]:   By default, socket will be open as /var/run/minissdpd.sock
Aug 21 06:05:08 debian minissdpd-systemd-wrapper[8903]:   and pid written to file /var/run/minissdpd.pid
Aug 21 06:05:08 debian systemd[1]: minissdpd.service: Control process exited, code=exited, status=1/FAILURE
Aug 21 06:05:08 debian systemd[1]: minissdpd.service: Failed with result 'exit-code'.
Aug 21 06:05:08 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
dpkg: error processing package minissdpd (--configure):
 installed minissdpd package post-installation script subprocess returned error exit status 1
Setting up apt-listchanges (3.19) ...
Traceback (most recent call last):
  File "/tmp/tmp.MClbY83NSi.aptlc/debconf-helper.py", line 168, in <module>
    main(sys.argv)
  File "/tmp/tmp.MClbY83NSi.aptlc/debconf-helper.py", line 144, in main
    config.read(config_file)
  File "/usr/lib/python3.7/configparser.py", line 696, in read
    self._read(fp, filename)
  File "/usr/lib/python3.7/configparser.py", line 1079, in _read
    raise MissingSectionHeaderError(fpname, lineno, line)
configparser.MissingSectionHeaderError: File contains no section headers.
file: '/etc/apt/listchanges.conf', line: 1
'deb http://deb.debian.org/debian debian buster main\n'
dpkg: error processing package apt-listchanges (--configure):
 installed apt-listchanges package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 python-enum34
 minissdpd
 apt-listchanges
root@debian:/home/


Code: Select all
apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 https://dl.winehq.org/wine-builds/ubuntu bionic/main i386 Packages
     release o=dl.winehq.org,a=bionic,n=bionic,l=winehq,c=main,b=i386
     origin dl.winehq.org
 500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     release o=dl.winehq.org,a=bionic,n=bionic,l=winehq,c=main,b=amd64
     origin dl.winehq.org
 500 https://dl.winehq.org/wine-builds/debian buster/main i386 Packages
     release o=dl.winehq.org,a=stable,n=buster,l=winehq,c=main,b=i386
     origin dl.winehq.org
 500 https://dl.winehq.org/wine-builds/debian buster/main amd64 Packages
     release o=dl.winehq.org,a=stable,n=buster,l=winehq,c=main,b=amd64
     origin dl.winehq.org
 100 http://ftp.debian.org/debian stretch-backports-sloppy/main i386 Packages
     release o=Debian Backports,a=stretch-backports-sloppy,n=stretch-backports-sloppy,l=Debian Backports,c=main,b=i386
     origin ftp.debian.org
 100 http://ftp.debian.org/debian stretch-backports-sloppy/main amd64 Packages
     release o=Debian Backports,a=stretch-backports-sloppy,n=stretch-backports-sloppy,l=Debian Backports,c=main,b=amd64
     origin ftp.debian.org
 100 http://ftp.debian.org/debian buster-backports/main i386 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=main,b=i386
     origin ftp.debian.org
 100 http://ftp.debian.org/debian buster-backports/main amd64 Packages
     release o=Debian Backports,a=buster-backports,n=buster-backports,l=Debian Backports,c=main,b=amd64
     origin ftp.debian.org
 500 http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic/main i386 Packages
     release v=18.04,o=LP-PPA-fingerprint-fingerprint-gui,a=bionic,n=bionic,l=Fingerprint GUI,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic/main amd64 Packages
     release v=18.04,o=LP-PPA-fingerprint-fingerprint-gui,a=bionic,n=bionic,l=Fingerprint GUI,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://security.debian.org buster/updates/non-free i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org buster/updates/main i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://ftp.cn.debian.org/debian buster-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=i386
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=amd64
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=i386
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin ftp.cn.debian.org
 500 http://deb.debian.org/debian-security buster/updates/non-free i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian-security buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian-security buster/updates/main i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian-security buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin deb.debian.org
 500 http://ftp.cn.debian.org/debian buster/non-free i386 Packages
     release v=10.5,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster/non-free amd64 Packages
     release v=10.5,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster/contrib i386 Packages
     release v=10.5,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster/contrib amd64 Packages
     release v=10.5,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster/main i386 Packages
     release v=10.5,o=Debian,a=stable,n=buster,l=Debian,c=main,b=i386
     origin ftp.cn.debian.org
 500 http://ftp.cn.debian.org/debian buster/main amd64 Packages
     release v=10.5,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin ftp.cn.debian.org
Pinned packages:
root@debian:
sarksloane
 
Posts: 86
Joined: 2017-01-17 04:21

Re: error python-enum34

Postby cuckooflew » 2020-08-20 21:43

https://wiki.debian.org/DontBreakDebian
Repositories that can create a FrankenDebian if used with Debian Stable:

Debian testing release (currently bullseye)

Debian unstable release (also known as sid)

Ubuntu, Mint or other derivative repositories are not compatible with Debian!
Ubuntu PPAs


Code: Select all
 500 https://dl.winehq.org/wine-builds/ubuntu bionic/main i386 Packages
     release o=dl.winehq.org,a=bionic,n=bionic,l=winehq,c=main,b=i386
     origin dl.winehq.org
 500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64
http://ppa.launchpad.net/fingerprint/fingerprint-gui/ubuntu bionic/main i386 Packages
 

Are you running Ubuntu ?
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 681
Joined: 2018-05-10 19:34
Location: Some where out west

Re: error python-enum34

Postby sarksloane » 2020-08-20 22:35

I'm using Debian Buster but I need to install wine that needs i386 Packages.
sarksloane
 
Posts: 86
Joined: 2017-01-17 04:21

Re: error python-enum34

Postby cuckooflew » 2020-08-21 02:17

Well, I guess it did not work did it ? Using Ubuntu ppa's in your sources.list is not a good solution,..as you can now see.
I don't know, but I see they do have builds specifically for Debian,:
https://wiki.winehq.org/Debian
It does not make sense to me why you would use Ubuntu ppas,...Maybe H_O_A-S can help you, Or, follow the instructions on the DEBIAN wiki:
https://wiki.debian.org/Wine
This is how you should have installed it.
I am pretty sure you need to get rid of, remove everything that was installed from the Ubuntu ppas, first though, but I am not really sure how to do that..
https://wiki.debian.org/DontBreakDebian
Ubuntu, Mint or other derivative repositories are not compatible with Debian!
Ubuntu PPAs
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 681
Joined: 2018-05-10 19:34
Location: Some where out west

Re: error python-enum34

Postby Head_on_a_Stick » 2020-08-21 16:24

Let's see how much non-Debian stuff is there:
Code: Select all
aptitude search '~S ~i !~ODebian !~o'

Reference: https://raphaelhertzog.com/2011/02/14/d ... -packages/
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13087
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: error python-enum34

Postby cuckooflew » 2020-08-21 17:21

You know, That is a really good link, I remember using that my self but years ago, I had forgotten all about it...
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 681
Joined: 2018-05-10 19:34
Location: Some where out west

Re: error python-enum34

Postby sarksloane » 2020-08-23 08:41

I followed the steps here https://wiki.debian.org/Wine and removed everything from ubuntu ppas but I'm getting below error.

Code: Select all
# winecfg
No protocol specified
No protocol specified
No protocol specified
002d:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
002d:err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.
002d:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
002d:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
002d:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0029:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0029:err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.
000b:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
000b:err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.
0029:err:setupapi:create_dest_file failed to create L"C:\\windows\\system32\\userenv.dll" (error=80)
0029:err:setupapi:create_dest_file failed to create L"C:\\windows\\system32\\shcore.dll" (error=80)
Could not load wine-gecko. HTML rendering will be disabled.
003c:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
003c:err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.
003c:err:setupapi:create_dest_file failed to create L"C:\\windows\\system32\\shcore.dll" (error=80)
003c:err:setupapi:create_dest_file failed to create L"C:\\windows\\system32\\rundll32.exe" (error=80)
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/root/.wine' has been updated.
0042:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0042:err:winediag:nodrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.
sarksloane
 
Posts: 86
Joined: 2017-01-17 04:21

Re: error python-enum34

Postby Head_on_a_Stick » 2020-08-23 09:07

Try running the command as your normal user rather than as root. Or set $DISPLAY explicitly before the command.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13087
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: (Solved)error python-enum34

Postby sarksloane » 2020-08-26 13:08

thanks guys for your support..
sarksloane
 
Posts: 86
Joined: 2017-01-17 04:21

Re: (Solved)error python-enum34

Postby Head_on_a_Stick » 2020-08-26 14:56

What was your eventual solution? It may be useful for others who encounter this issue.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13087
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to General Questions

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable