Exclude a package from 'aptitude full-upgrade'?

If none of the more specific forums is the right place to ask

Exclude a package from 'aptitude full-upgrade'?

Postby bdz » 2020-08-29 23:53

Is there a way to exclude a package from 'aptitude full-upgrade' or 'aptitude safe-upgrade'?

I normally run 'aptitude full-upgrade' regularly but there is one package I need to keep locked at an old version. The aptitude man page doesn't say anything about this.

thanks
bdz
 
Posts: 54
Joined: 2008-06-16 04:32

Re: Exclude a package from 'aptitude full-upgrade'?

Postby sgosnell » 2020-08-30 00:06

Try putting "debian hold package" into your favorite search engine, then read a few of the results. There are many.
sgosnell
 
Posts: 794
Joined: 2011-03-14 01:49

Re: Exclude a package from 'aptitude full-upgrade'?

Postby 4D696B65 » 2020-08-30 00:45

bdz wrote: one package I need to keep locked at an old version. The aptitude man page doesn't say anything about this.


man aptitude wrote:<package>=
Place <package> on hold: cancel any active installation, upgrade, or removal, and prevent this package from being
automatically upgraded in the future.

<package>:
Keep <package> at its current version: cancel any installation, removal, or upgrade. Unlike “hold” (above) this does not
prevent automatic upgrades in the future.

User avatar
4D696B65
 
Posts: 2486
Joined: 2009-06-28 06:09

Re: Exclude a package from 'aptitude full-upgrade'?

Postby bdz » 2020-08-30 00:57

I tried

Code: Select all
aptitude -s full-upgrade libreoffice-base-core=


but it comes back with

No packages will be installed, upgraded, or removed


whereas there are 12 package that should be updated.

Should I be using hold with a different aptitude command? Or will libreoffice-base-core be skipped the next time I run

Code: Select all
aptitude full-upgrade
bdz
 
Posts: 54
Joined: 2008-06-16 04:32

Re: Exclude a package from 'aptitude full-upgrade'?

Postby reinob » 2020-08-30 08:51

@bdz,

if you want to lock libreoffice-base-core you just
Code: Select all
# apt-mark hold libreoffice-base-core
libreoffice-base-core set on hold.


You can later unhold it.
reinob
 
Posts: 815
Joined: 2014-06-30 11:42

Re: Exclude a package from 'aptitude full-upgrade'?

Postby bdz » 2020-08-30 19:05

Ahh. Great, thanks
bdz
 
Posts: 54
Joined: 2008-06-16 04:32


Return to General Questions

Who is online

Users browsing this forum: PieterB and 13 guests

fashionable