Suspend to RAM not working - Laptop wakes up

If none of the more specific forums is the right place to ask

Suspend to RAM not working - Laptop wakes up

Postby coldcloud » 2020-09-21 23:14

Hello everybody,

I try to solve a sleep problem on my Laptop (Lenovo Legion Y520-15IKBA, i5-7300HQ) with Debian Buster 10.5 and hopefully someone can help me:
My Laptop wakes up every time just after going to sleep, no matter if I use the desktop environment buttons or pm-suspend command. So the fan stops and the screen turns off, but then the laptop wakes up and shows the login screen for example (with MATE desktop). I would like to use Suspend to RAM (S3). Curiously sleep worked occasionally, but only once and afterwards I can't get sleep working again. So sleep should be possible with this Laptop, but I don't know how...I can't find any BIOS settings for sleep and already have the latest BIOS. In BIOS I tested disabling discrete AMD GPU, WiFi card and SecureBoot, but no success.

I looked with dmesg and wonder about the Firmmware Bug...

Code: Select all
[  233.902521] ahci 0000:00:17.0: port does not support device sleep
[  234.190703] PM: suspend entry (deep)
[  234.190705] PM: Syncing filesystems ... done.
[  234.191795] Freezing user space processes ... (elapsed 0.001 seconds) done.
[  234.192995] OOM killer disabled.
[  234.192996] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[  234.194250] Suspending console(s) (use no_console_suspend to debug)
[  234.212952] sd 2:0:0:0: [sda] Synchronizing SCSI cache
[  234.213037] sd 2:0:0:0: [sda] Stopping disk
[  235.446207] ACPI: EC: interrupt blocked
[  235.485548] ACPI: Preparing to enter system sleep state S3
[  235.485944] ACPI: EC: event blocked
[  235.485944] ACPI: EC: EC stopped
[  235.485945] PM: Saving platform NVS memory
[  235.486279] Disabling non-boot CPUs ...
[  235.502440] smpboot: CPU 1 is now offline
[  235.518480] smpboot: CPU 2 is now offline
[  235.534466] smpboot: CPU 3 is now offline
[  192.852134] [Firmware Bug]: TSC ADJUST differs: CPU0 0 --> -234665014. Restoring
[  235.538281] ACPI: Low-level resume complete
[  235.538375] ACPI: EC: EC started
[  235.538376] PM: Restoring platform NVS memory
[  235.539266] Enabling non-boot CPUs ...
[  235.539298] x86: Booting SMP configuration:
[  235.539299] smpboot: Booting Node 0 Processor 1 APIC 0x2
[  235.539780]  cache: parent cpu1 should not be sleeping
[  235.539834] intel_pstate: Disabling energy efficiency optimization
[  235.539959] CPU1 is up
[  235.539976] smpboot: Booting Node 0 Processor 2 APIC 0x4
[  235.540368]  cache: parent cpu2 should not be sleeping
[  235.540509] CPU2 is up
[  235.540524] smpboot: Booting Node 0 Processor 3 APIC 0x6
[  235.540918]  cache: parent cpu3 should not be sleeping
[  235.541064] CPU3 is up
[  235.543752] ACPI: Waking up from system sleep state S3
[  235.547073] ACPI: EC: interrupt unblocked
[  235.590008] ACPI: EC: event unblocked
[  235.593291] sd 2:0:0:0: [sda] Starting disk


Any ideas how to fix this?
Thank you very much and best regards!
coldcloud
 
Posts: 4
Joined: 2020-09-21 19:12

Re: Suspend to RAM not working - Laptop wakes up

Postby stevepusser » 2020-09-22 01:54

Have you tested it with any newer kernels, such as with Liquorix or from Debian backports? Often newer kernels fix laptop quirks like you have.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12083
Joined: 2009-10-06 05:53

Re: Suspend to RAM not working - Laptop wakes up

Postby coldcloud » 2020-09-22 11:59

Hi,

thank you for your help. I installed 5.7.0-0.bpo.2-amd64 and after the first reboot pm-suspend worked 2 times, but then the problem was back.
Maybe it's not related, but I noticed some strange scratching noises directly before the laptop interrupts suspend.
Since I have no optical drive and use an SSD, it's probably a fan at the case bottom.
I can hear 7 slight scratches within a second and the NumLock LED is flickering with the same pattern.
coldcloud
 
Posts: 4
Joined: 2020-09-21 19:12

Re: Suspend to RAM not working - Laptop wakes up

Postby sgosnell » 2020-09-22 13:35

That sounds like a hardware problem, possibly a loose cable somewhere. Can't tell from long distance with just that info, though.
Take my advice, I'm not using it.
sgosnell
 
Posts: 864
Joined: 2011-03-14 01:49

Re: Suspend to RAM not working - Laptop wakes up

Postby coldcloud » 2020-09-22 20:06

Thank you, I opened the laptop and did not found loose cables. The fans worked fine all the time.
This strange sequence of fan impulses only appears when trying to suspend. Very strange.
coldcloud
 
Posts: 4
Joined: 2020-09-21 19:12

Re: Suspend to RAM not working - Laptop wakes up

Postby coldcloud » 2020-09-23 19:34

Out of desperation I did some research and took a look at /proc/acpi/wakeup.
There where several items enabled and I was able to disable most of them, but one of the PXSX entries remains enabled:
Code: Select all
root@debian:~# cat /proc/acpi/wakeup
Device   S-state     Status   Sysfs node
GLAN     S3   *disabled
XHC     S3   *disabled  pci:0000:00:14.0
XDCI     S4   *disabled
HDAS     S3   *disabled  pci:0000:00:1f.3
RP01     S3   *disabled
PXSX     S3   *disabled
RP02     S3   *disabled  pci:0000:00:1c.0
PXSX     S3   *disabled  pci:0000:01:00.0
RP03     S3   *disabled
PXSX     S3   *disabled
RP04     S3   *disabled  pci:0000:00:1c.3
PXSX     S3   *enabled   pci:0000:02:00.0
RP05     S3   *disabled
PXSX     S3   *disabled
RP06     S3   *disabled
PXSX     S3   *disabled
RP07     S3   *disabled
PXSX     S3   *disabled
RP08     S3   *disabled
PXSX     S3   *disabled
RP09     S3   *disabled
PXSX     S3   *disabled
RP10     S3   *disabled
PXSX     S3   *disabled
RP11     S3   *disabled
PXSX     S3   *disabled
RP12     S3   *disabled
PXSX     S3   *disabled
RP13     S3   *disabled
PXSX     S3   *disabled
RP14     S3   *disabled
PXSX     S3   *disabled
RP15     S3   *disabled
PXSX     S3   *disabled
RP16     S3   *disabled
PXSX     S3   *disabled
RP17     S3   *disabled
PXSX     S3   *disabled
RP18     S3   *disabled
PXSX     S3   *disabled
RP19     S3   *disabled
PXSX     S3   *disabled
RP20     S3   *disabled
PXSX     S3   *disabled
RP21     S4   *disabled
PXSX     S3   *disabled
RP22     S4   *disabled
PXSX     S3   *disabled
RP23     S4   *disabled
PXSX     S3   *disabled
RP24     S4   *disabled
PXSX     S3   *disabled

According to lspci this may be my ethernet controller:
Code: Select all
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)


Since I'm no expert I wonder if disabling the wakeup entry or the PCI device would help and how I can do this?

Best regards
coldcloud
coldcloud
 
Posts: 4
Joined: 2020-09-21 19:12


Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable