How to comple wxwidgets3.0

If none of the more specific forums is the right place to ask

How to comple wxwidgets3.0

Postby zombie_ramboz » 2020-10-09 13:42

Hi,

I require wxwidgets3.0 as it is a dependency for Veracrypt.

On extracting the tar.xz I see the below list of files:

    changelog
    compat
    control
    control.in
    control.msw.in
    copyright
    filenames.txt
    libwxbase-dev.postinst
    libwxbase-dev.prerm
    libwxgtk-dev.postinst
    libwxgtk-dev.prerm
    libwxgtk-gtk3-dev.postinst
    libwxgtk-gtk3-dev.prerm
    libwxmsw-dev.postinst
    libwxmsw-dev.prerm
    lintian-override.in
    patches (dir)
    README.Debian
    README.examples
    README.source
    repack.sh
    rules
    source (dir)
    unpack_examples.sh.in
    watch
    wx-config.1
    wx-doc.doc-base
    wx-examples.examples
    wxrc-tools.1

The README files do not give any clues on how to proceed. What I am I supposed to do now?
zombie_ramboz
 
Posts: 13
Joined: 2017-11-05 07:31

Re: How to comple wxwidgets3.0

Postby arochester » 2020-10-09 13:50

arochester
 
Posts: 1750
Joined: 2010-12-07 19:55

Re: How to comple wxwidgets3.0

Postby zombie_ramboz » 2020-10-09 14:12

arochester wrote:Available from Repository?

https://packages.debian.org/source/buster/wxwidgets3.0


Ah yes, I did try from the repositories and get the below:

Code: Select all
sudo apt-get install libwxgtk3.0-gtk3-0v5Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libwxgtk3.0-gtk3-0v5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libwxgtk3.0-gtk3-0v5' has no installation candidate
zombie_ramboz
 
Posts: 13
Joined: 2017-11-05 07:31

Re: How to comple wxwidgets3.0

Postby LE_746F6D617A7A69 » 2020-10-09 15:13

Show Your sources.list please.
Code: Select all
cat /etc/apt/sources.list


Btw, if You would like to compile Veracrypt from sources, You'll need also the libwxgtk3.0-dev package.
Bill Gates: "(...) In my case, I went to the garbage cans at the Computer Science Center and I fished out listings of their operating system."
The_full_story and Nothing_have_changed
LE_746F6D617A7A69
 
Posts: 395
Joined: 2020-05-03 14:16

Re: How to comple wxwidgets3.0

Postby sgosnell » 2020-10-09 18:35

Veracrypt only depends on libwxgtk3.0-gtk3-0v5, and it is in the Debian Buster, Bullseye, and Sid repositories, installable with apt. For Stretch, it's in the backports repo. What version of Debian are you running? Have you read the README.Debian file, or any of the other README files?
Take my advice, I'm not using it.
sgosnell
 
Posts: 864
Joined: 2011-03-14 01:49

Re: How to comple wxwidgets3.0

Postby LE_746F6D617A7A69 » 2020-10-09 19:41

sgosnell wrote:Veracrypt only depends on libwxgtk3.0-gtk3-0v5, and it is in the Debian Buster, Bullseye, and Sid repositories, installable with apt. For Stretch, it's in the backports repo.
Uhm?
Nope, it's not available in Debian. Did You meant zulucrypt?
https://packages.debian.org/search?keywords=veracrypt&searchon=all&suite=buster&section=all
Bill Gates: "(...) In my case, I went to the garbage cans at the Computer Science Center and I fished out listings of their operating system."
The_full_story and Nothing_have_changed
LE_746F6D617A7A69
 
Posts: 395
Joined: 2020-05-03 14:16

Re: How to comple wxwidgets3.0

Postby sgosnell » 2020-10-09 20:05

I mean libwxgtk3.0-gtk3-0v5. Veracrypt has to be downloaded separately, but it should install with dpkg, and if it fails because of dependencies then libwxgtk3.0-gtk3-0v5 is in the repositories. I've never had to install anything separately, but some installations might require it I suppose.
Take my advice, I'm not using it.
sgosnell
 
Posts: 864
Joined: 2011-03-14 01:49

Re: How to comple wxwidgets3.0

Postby stevepusser » 2020-10-10 01:39

I take it that you mean to download the debs directly from Veracrypt?

Hmmm--the latest update 7 to 1.2.4 applied to Linux too, unlike 5 and 6. I better update the MX Linux builds and my OBS repo. :)
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12083
Joined: 2009-10-06 05:53

Re: How to comple wxwidgets3.0

Postby sgosnell » 2020-10-10 01:45

I've always downloaded directly from the veracrypt site. That way I know what I'm getting. I would like to see it in the Debian repositories, but that doesn't seem likely.
Take my advice, I'm not using it.
sgosnell
 
Posts: 864
Joined: 2011-03-14 01:49

Re: How to comple wxwidgets3.0

Postby stevepusser » 2020-10-11 23:10

Here ya go. https://build.opensuse.org/package/show ... /veracrypt

Builds on stock Debian. No need to compile wxwidgets at all, so this was an XY problem.

FWIW, zulucrypt 5.7.1 is also a simple backport from upstream Debian.

Please edit mark this thread [Solved] by editing the title of the first post in the thread.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12083
Joined: 2009-10-06 05:53


Return to General Questions

Who is online

Users browsing this forum: No registered users and 17 guests

fashionable