Problem with X

If none of the more specific forums is the right place to ask

Problem with X

Postby NeverLie » 2005-09-02 10:46

G'Day there , My first time here, great Forum.
My problem is I am using a debian based distro in Kanotix(excellent), & I upgraded from XFree86 to Xorg & everything was great for a while.
But then I saw a nother package I thought was related to Xorg ,but I cant remember exactly what it was called ? then when it was time 4 synaptic to install it after downloading, it asked which one I wanted as my default server "Xorg" the one I was using, or the new "xorg!!!" that I thought was just a addon for the xorg I was already using. and I chose the new package. now I cant get my X to start.
AnyWay I was hoping if someone new if there was away I could change back to the original "Xorg" ? maybe by editing a file, but i'm not sure which file it is. Also is there away I could find out what the name of this Xorg pkg was so that maybe I can uninstall it & reinstall the original Xorg if that would work that is?
apparently there is a command I can type that might give me the packages installed that start with or have " Xorg" in it?
Sorry for a tough first up question.
NeverLie
 
Posts: 3
Joined: 2005-09-02 10:41
Location: MY-HUMBLE-ABODE

Postby phaeton » 2005-09-02 10:53

I think the /var/log/dpkg.log file keeps a history of packages installed with synaptic. You could look at that file to see what was installed and try to remove it.
phaeton
 
Posts: 44
Joined: 2005-06-02 21:00

Postby NeverLie » 2005-09-02 11:47

Thanks phaeton, I have found the package I should not of installed "xserver-xorg-dbg"
AnyWay do you or anyone no which file it is I can edit where I can cause "kdm" instead of "xdm" to load when I type startx or when logging in?
NeverLie
 
Posts: 3
Joined: 2005-09-02 10:41
Location: MY-HUMBLE-ABODE

Postby phaeton » 2005-09-02 12:00

If kdm is already installed, you can type
Code: Select all
dpkg-reconfigure kdm

as root to reselect it.
phaeton
 
Posts: 44
Joined: 2005-06-02 21:00

Postby NeverLie » 2005-09-02 12:09

Thanks again, but changing to kdm didn't work either. I also tried "dpkg-reconfigure xserver-xorg" & tried resetiing some things with no luck either.
Not sure now what I need to do-maybe be a wimp & reinstall & dont make this mistake again? I might search a little more though.
NeverLie
 
Posts: 3
Joined: 2005-09-02 10:41
Location: MY-HUMBLE-ABODE

Postby piper » 2005-09-03 15:50

After you reinstall, install xorg like this



Alt + Ctrl + F1 --> login as root
init 3
apt-get update ,
update-scripts-kanotix.sh,
apt-get install xserver-xorg
apt-get dist-upgrade (just do a plain upgrade not dist-upgrade till things settle down)
/etc/init.d/x11-common start
apt-get clean
fix-fonts
reinstall ATi/ nVidia drivers (if necessary)
init 5 & exit
User avatar
piper
 
Posts: 102
Joined: 2005-07-03 08:29


Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable