Debian AMD64 problem

If none of the more specific forums is the right place to ask

Debian AMD64 problem

Postby Beliar » 2005-09-12 07:34

not sure where to post, so please move if wrong.

Well, i decided i install a linux again on my pc, i decided i try debian this time.Cause i have an AMD64 Processor i downloaded the AMD64 Version (yeah, i know its not an official version right now)
After that i installed it after 'some' problems(including that i forgot that windwos stores it bootloader allways on c:)

Next step was connecting to the internet.I have a "AVM Fritzcard DSL SL" directly on the pc, no router. So i needed the drivers for that.Fortunately AVM has made a linux one, but only precompile for suse, the source is included so i 'only' need to compile those. Normally no prob, but apparently there was no make and gcc installed and not on the dvd. After i restarted windows and downloaded the gcc and all dependencies that were not installed i tried to compile again.
First it seemed it works but then i got the following error:

"/asm/processor.h array type has incomplete element type"

Ok, restarting windows and search the web.Found a solution, not for the kernel i use, but it suggestes using gcc 3.3(i got 4.0).
So i downloaded gcc3.3.

Next try:

"/asm/processor.h array type has incomplete element type"

Ok, searching again.I find out that the kernel i use (2.6.8-11-amd64-k8 ) was compiled by gcc 3.4 so i download this and try.Again:

"/asm/processor.h array type has incomplete element type"

This is where i am now.
Anyone knows a solution?

[edit]
i used the following kernel-headers:
http://packages.debian.org/testing/deve ... 1-amd64-k8
Beliar
 
Posts: 2
Joined: 2005-09-12 07:23

Postby Beliar » 2005-09-12 20:43

nevermind i got it to work.

My fault was to assume that debian would add the packages on the dvd to apt-cache.

I was wrong, when i browsed the dvd on windows i found that the header and gcc packages were on it.After i added the dvd to the package sources i could install the headers, and the driver compiled right away.

However internet doesnt work yet, cant get a connection.
So, more searching on the net...
Beliar
 
Posts: 2
Joined: 2005-09-12 07:23


Return to General Questions

Who is online

Users browsing this forum: Google [Bot] and 4 guests

fashionable