major problem on a PPC...

If none of the more specific forums is the right place to ask

major problem on a PPC...

Postby nunyas » 2005-09-13 07:39

In an attempt at not making myself look like a bigger ass than I feel, I'll just say that I'm fairly well experienced with Linux on x86 hardware. Within the past few months I had a PPC G4 come into my posession, and thought it would make a great LAN server/IP Masquerading machine. It is... well... was... today, the greater LA basin much of Sanfernando Valley, and La Crescenta Valley had a power outage. I have a UPS, unfortunately the batteries in it are dead... So, I guess i don't have a UPS effectively. Anyways, the power failure caused one of the HDDs in the G4 to fail on boot up, luckily it's not one with any "critical" data on it. The dead drive prevented me from fully booting the system. I figured out a way around that problem, and managed to boot the system. However, on of the NICs seemed to have stopped working. In my attempts to figure out what was wrong i tried using dmesg in conjunction with grep. However, I made a major newbie mistake.... the following is what I typed at my ash prompt:

Code: Select all
dmesg > grep | eth


Naturally, that didn't yield anything useful and gave me an error about eth not being a file and could not be found or executed. It should have clicked in my head when I found a newly created "grep" file in my directory. It didn't though, and in my idiocy I thought I'd give this a try:

Code: Select all
dmesg > /bin/grep


well... that obviously did not give me what I wanted... infact I'm now screwed and cannot get the system to boot up "properly" anymore because of it. I tried to cp grep from the installer, unfortunately, the version of grep included in the Debian installer is not the same as what gets installed. The current grep file on my system complains about "-- E" being an invalid flag.

To cut this already long post short, do any of you Debian users on this board have a grep binary for the PowerPC from the Sarge branch? I really want to avoid reinstalling the entire system if at all possible....

thanks
nunyas
 
Posts: 2
Joined: 2005-09-13 07:15

Postby lacek » 2005-09-13 09:44

What do you mean by "can't boot the system 'properly'"? Do you get a login prompt? If so, you can try to reinstall grep:
Code: Select all
apt-get install --reinstall grep


Anyway, that was a painful way to learn The Important Rule: Never do anything in root's name unless absolutely necessary. :-)
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary

Postby nunyas » 2005-09-15 01:37

thanks for the tip... i finally managed to get my PowerPC Debian box to boot into a useable state. with Grep hosed I found that many of the GUI tools were hosed as well... including the default terminal apps. To complicate things the PCI NIC I have added to the system was acting all screwy. So, I couldn't use it to connect to the internet to get updates. But I did get apt-get to pull the necesary files from the CD-ROM, and all apears to be OK... for now. My flakey NIC seems to be working now too.

I have to agree... this is definitely yet one more reason to not do anything as root unless you absolutely have to. I learned this lesson once before (when i was first starting out... in the very early days of Linux and Slackware), and it was much much worse back then (*cough*rm -rf *.* from the / directory*cough*), but I guess you tend to forget things over time. Well, maybe not forget, but definitely tend to pay less attention to some of the "safe practices" over time.
nunyas
 
Posts: 2
Joined: 2005-09-13 07:15


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable