Grub Bootloader

If none of the more specific forums is the right place to ask

Grub Bootloader

Postby EarthBound » 2005-09-15 11:34

My computer has two hard drives.
Hard drive #1 has Windblows 2000 and Debian.
Drive #2 has Windblowsharder XP.
When the computer boots, GRUB sees both O/Ses but even if you choose XP, it loads 2000 instead.
How do I correct this?
EarthBoundMisfit
EarthBound
 

Postby Harold » 2005-09-15 11:50

Open /boot/grub/menu.lst with your favorite text editor. Find the line that says ## End Default Options ##. Show us, please, all lines below that point.

Are both hard drives on the same IDE ribbon?
Harold
 
Posts: 1502
Joined: 2005-01-07 00:15

Re: Grub Bootloader

Postby dawgie » 2005-09-15 12:08

EarthBound wrote:My computer has two hard drives.
Hard drive #1 has Windblows 2000 and Debian.
Drive #2 has Windblowsharder XP.
When the computer boots, GRUB sees both O/Ses but even if you choose XP, it loads 2000 instead.
How do I correct this?
EarthBoundMisfit


Post your /boot/grub/menu.lst entries.
Grub needs to use the "chainload" command to start another bootloader. Windoze has it's own bootload. You also need the "map" command if windoze is not on the 1st drive.
Example entry for chainloading to windows on the 2nd drive:
# Windowsxp
title Windowsxp
map (hd0,0) (hd1,0)
map (hd1,0) (hd0,0)
rootnoverify (hd1,0)
chainloader +1
User avatar
dawgie
 
Posts: 431
Joined: 2004-06-16 21:30
Location: New Hampshire USA

Re: Grub Bootloader

Postby GRUB » 2005-09-16 00:34

EarthBound wrote:My computer has two hard drives.
Hard drive #1 has Windblows 2000 and Debian.
Drive #2 has Windblowsharder XP.
When the computer boots, GRUB sees both O/Ses but even if you choose XP, it loads 2000 instead.
How do I correct this?
EarthBoundMisfit


Here it is ....................
## ## End Default Options ##

title Debian GNU/Linux, kernel 2.4.27-2-686
root (hd0,1)
kernel /boot/vmlinuz-2.4.27-2-686 root=/dev/hda2 ro
initrd /boot/initrd.img-2.4.27-2-686
savedefault
boot

title Debian GNU/Linux, kernel 2.4.27-2-686 (recovery mode)
root (hd0,1)
kernel /boot/vmlinuz-2.4.27-2-686 root=/dev/hda2 ro single
initrd /boot/initrd.img-2.4.27-2-686
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Microsoft Windows 2000 Professional
root (hd0,0)
savedefault
makeactive
chainloader +1


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hdb1
title Microsoft Windows XP Professional
root (hd1,0)
savedefault
makeactive
chainloader +1
GRUB
 

Re: Grub Bootloader

Postby Guest » 2005-09-16 00:38

dawgie wrote:
EarthBound wrote:My computer has two hard drives.
Hard drive #1 has Windblows 2000 and Debian.
Drive #2 has Windblowsharder XP.
When the computer boots, GRUB sees both O/Ses but even if you choose XP, it loads 2000 instead.
How do I correct this?
EarthBoundMisfit


Post your /boot/grub/menu.lst entries.
Grub needs to use the "chainload" command to start another bootloader. Windoze has it's own bootload. You also need the "map" command if windoze is not on the 1st drive.
Example entry for chainloading to windows on the 2nd drive:
# Windowsxp
title Windowsxp
map (hd0,0) (hd1,0)
map (hd1,0) (hd0,0)
rootnoverify (hd1,0)
chainloader +1


Not doubting you here, but I don't see any map(ping) functions listed in menu.lst
EarthBoundMisfit
PS Sorry it took so long to respond. I jigdo ed the 'testing' version to see if its install would cure my grub prob. It didn't. The netinstall ISO for 'testing' Debian DID configure a correct GRUB tho. It just wouldn't installl my ethernet settings correctly. It wanted to installl dial-up settings if memory serves correctly.
Guest
 

GRUB

Postby EarthBound » 2005-09-16 01:08

Just thought of something.
When I downloaded the unstable network debian installer, it installed the 2.6 debian kernel.
The unstable debian DVD installed the 2.4 kernel. How weird is THAT?
I also downloaded the unstable cd's for download (1&2) and disc one won't even boot my machine. In fact it isn't even read.
WEIRRRD
Misfit
EarthBound
 

Re: Grub Bootloader

Postby EarthBound » 2005-09-18 11:14

Anonymous wrote:
dawgie wrote:
EarthBound wrote:My computer has two hard drives.
Hard drive #1 has Windblows 2000 and Debian.
Drive #2 has Windblowsharder XP.
When the computer boots, GRUB sees both O/Ses but even if you choose XP, it loads 2000 instead.
How do I correct this?
EarthBoundMisfit


Post your /boot/grub/menu.lst entries.
Grub needs to use the "chainload" command to start another bootloader. Windoze has it's own bootload. You also need the "map" command if windoze is not on the 1st drive.
Example entry for chainloading to windows on the 2nd drive:
# Windowsxp
title Windowsxp
map (hd0,0) (hd1,0)
map (hd1,0) (hd0,0)
rootnoverify (hd1,0)
chainloader +1


Not doubting you here, but I don't see any map(ping) functions listed in menu.lst
EarthBoundMisfit
PS Sorry it took so long to respond. I jigdo ed the 'testing' version to see if its install would cure my grub prob. It didn't. The netinstall ISO for 'testing' Debian DID configure a correct GRUB tho. It just wouldn't installl my ethernet settings correctly. It wanted to installl dial-up settings if memory serves correctly.



DUDEEEEEE you are the MAN! That did the trick! Thanks for your help!
I was having to go to the BIOS and tell the computer to boot from the seond hard drive in case my wife wanted to use the computer.
Now GRUB sees and boots to both hard drives.
Thanks again
Misfit
EarthBound
 


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable