shutdown command not found after uninstalling gdm

If none of the more specific forums is the right place to ask

shutdown command not found after uninstalling gdm

Postby Donny662 » 2005-10-04 22:41

I just installed Debian on my system, and so far it has been going fairly smoothly for me just poking around in the dark, but I just ran into a problem I can't find the answer to.

When I installed Sarge from the CD, I selected the desktop environment to be installed at that time also. I didn't realize it was going to set it up so it would boot into x and give me the "welcome" screen. So, I wanted to make it so it boots into the text based login and then I can enter Gnome through the command prompt. I uninstalled gdm using aptitude, and now I can logout of Gnome into the command prompt instead of it shutting down the computer, and I can start either Gnome or KDE from the command prompt just fine. But, I went to shutdown the computer using "shutdown -h now," and I get an error along the lines of "bash: shutdown command not found."

Is there another way to properly shutdown the computer from the command prompt, or is there a way I can get the shutdown command to work? I usually try to find answers to problems in documentation or from other discussions but this caught me completely off guard.

Thanks in advance.
Donny662
 

Please disregard my previous post

Postby Donny662 » 2005-10-04 23:34

And the monkey prize goes to . . . . . . . me!

I figured out the answer. It seems I was logged into another shell or something when I was in the command prompt. I tried using the logout command and it said the same thing as when you try to use that command when you have the terminal opened in x. So, I typed exit and now I can shutdown the computer. Now the computer is behaving as I wanted it to by booting into the command prompt instead of x.

I don't really understand why I had a problem, but I am content to just forget about this embarassing incident altogether :oops: , and I hope the moderators will find it in their heart to delete this post and save my shame.

I'm just kidding, the mods don't need to delete it. I hope that my folly will give you experienced users a slight chuckle at the least.
Donny662
 

Postby Wikinator » 2005-10-05 10:37

only root knows the command "shutdown", because it's in /sbin.
Wikinator
 
Posts: 17
Joined: 2005-09-24 21:15
Location: Freiburg, Germany

Postby Donny662 » 2005-10-05 23:17

Oh. :? . How can a normal user shutdown the system then?
Donny662
 

Postby Wikinator » 2005-10-13 20:29

only with sudo shutdown, if it's allowed in /etc/sudoers. there's no other way.
Wikinator
 
Posts: 17
Joined: 2005-09-24 21:15
Location: Freiburg, Germany

Postby jobezone » 2005-10-15 15:05

Wikinator wrote:only with sudo shutdown, if it's allowed in /etc/sudoers. there's no other way.

And to do that, use the visudo command. Look into its manual to learn more.

In my system, my user has sudo acess to all commands, so I ran visudo, then entered the line
eduardo ALL=(ALL) ALL
. You probably only want the user to acess shutdown using sudo, and for that I can't remember on the top of my head how should this line look like, so check the man page of visudo.
The Debian Documentation website contains the FAQ, Installation Manual and the Release Notes for Etch. They're helpful if you want to learn more about debian!
User avatar
jobezone
 
Posts: 220
Joined: 2005-06-12 07:20
Location: Portugal


Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable