Sarge -> Etch.. I think I broke apt ; /

If none of the more specific forums is the right place to ask

Sarge -> Etch.. I think I broke apt ; /

Postby BarnacleJack » 2005-10-08 01:58

I just installed Debian(Sarge) and had then updated to Debian(Etch) afterwards I am now unable to update/install anything. My situation is the following..

apt-get -f install linux-image-2.6.12-1-686
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
gnome-desktop-environment: Depends: sound-juicer but it is not going to be installed
Depends: totem (>= 1.0.4) but it is not going to be installed
Depends: vino (>= 2.10.0) but it is not going to be installed
Depends: zenity (>= 2.10) but 2.8.2-1 is to be installed
gnomemeeting: Depends: libopenh323-1.15.3c2 (>= 1.15.3) but it is not going to be installed
Depends: libpt-1.8.3c2 but it is not going to be installed
hal: Depends: udev (>= 0.063) but 0.056-3 is to be installed
libpt-plugins-v4l2: Depends: libpt-1.8.3c2 (= 1.8.4-2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


So I use 'apt-get -f install' to attempt to fix it but recieve the following..

apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
gstreamer0.8-cdparanoia liblircclient0 libopenh323-1.15.3c2 libpt-1.8.3c2 libpt-plugins-oss
sound-juicer totem totem-xine udev vino zenity
Suggested packages:
lirc libopenh323-dev
The following packages will be REMOVED:
libopenh323-1.15.2 libpt-1.8.3
The following NEW packages will be installed:
gstreamer0.8-cdparanoia liblircclient0 libopenh323-1.15.3c2 libpt-1.8.3c2 sound-juicer totem
totem-xine vino
The following packages will be upgraded:
libpt-plugins-oss udev zenity
3 upgraded, 8 newly installed, 2 to remove and 127 not upgraded.
268 not fully installed or removed.
Need to get 0B/5437kB of archives.
After unpacking 5419kB of additional disk space will be used.
Do you want to continue? [Y/n] y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:en_GB:en",
LC_ALL = (unset),
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
(Reading database ... 70330 files and directories currently installed.)
Preparing to replace udev 0.056-3 (using .../archives/udev_0.070-2_i386.deb) ...
udev requires a kernel >= 2.6.12, upgrade aborted.
dpkg: error processing /var/cache/apt/archives/udev_0.070-2_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:en_GB:en",
LC_ALL = (unset),
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:en_GB:en",
LC_ALL = (unset),
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Errors were encountered while processing:
/var/cache/apt/archives/udev_0.070-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


After looking over this careful.. aside from a possibly configuration error on my part, the perl warnings, I see that it wants the new udev version. An attempt to update udev tells me I need a newer kernel. But to install a new kernel, even from source, I need to be able to install 'ncurses-devel' which due to the previous error I can't. So I seem to be caught in some sort of loop. ;/ I just moved over from gentoo and this is turning into one big headache. I've always heard debian was a fairly trouble-free distro. :" ( What did I do wrong and how can I resolve this? I thought this was just an debian 64-bit issue but it followed me over to this x86 install.
BarnacleJack
 
Posts: 4
Joined: 2005-10-07 20:52

Postby startx » 2005-10-08 07:16

But to install a new kernel, even from source

which kernel did you install. udev is for 2.6.xx kernels. im not quite sure but probably you need some config in the kernel to support udev.

however, it doesent look like a problem of apt. maybe you forget udev for a moment and properly upgrade the rest of the packages and then we'll see :)
debian squeeze for everyday life, many other versions for the rest
User avatar
startx
 
Posts: 180
Joined: 2004-09-16 12:14
Location: london

Postby Terje » 2005-10-08 10:17

did you do a apt-get dist-upgrade after changing your apt-sources?
Registered Linux user number 391283.

Put your hand on a hot stove for a minute, and it seems like an hour. Sit with a pretty girl for an hour, and it seems like a minute. THAT'S relativity.
User avatar
Terje
 
Posts: 124
Joined: 2005-03-25 12:38

Postby BarnacleJack » 2005-10-08 19:33

Hey guys. Thanks for responding.. well after hours after that post and a few hours this morning I was able to dist-upgrade and stablize the system. I'm not sure if there is a "Debian way" to do this or an easier way for the matter but what I ended up doing was the following;

First, I reinstalled debian and then downloaded a 2.6.13 kernel from kernel.org. After I ran 'apt-get install' and installed the package required to run 'make menuconfig'. Then I went ahead and rebooted into my newly compiled kernel and did a 'apt-get update;apt-get upgrade' before I changed my sources.list file. After rebooting again, just to be certain things were fine so far, I went ahead and joined #debian on freenode and after msg'ing a bot I learned some info about which mirror to use for testing/etch.

Well after I did everything the bot suggested and read thru all the links I felt it was finally safe enough to upgrade so off I went and changed sources.list to the appopriate mirrors for etch and ran 'apt-get dist-upgrade' and after about 20 minutes or so it upgraded.. I rebooted, just to be sure, and here I am in my newly installed etch system. Things are going smoothly thus far and very stable. I was sad to see that opera and mplayer wern't in any repositories though but I fetched em by hand. ;)

Btw, I was using the 2.6.8 kernel for both the 64-bit and x86 installs when this problem occured. According to the debian udev package it needs a kernel 2.6.10 or higher.
BarnacleJack
 
Posts: 4
Joined: 2005-10-07 20:52


Return to General Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable