Stuck in a loop trying to upgrade from stable to unstable

If none of the more specific forums is the right place to ask

Stuck in a loop trying to upgrade from stable to unstable

Postby Abzstrak » 2005-10-09 14:46

ok, so I'm fairly new to Debian and apt-get and that whole mess, coming over from gentoo....

I installed debian stable a few days ago and got bored and decided to upgrade it to unstable. Right now I'm stuck, when I run this:

apt-get -f install

I get this :

(Reading database ... 70353 files and directories currently installed.)
Preparing to replace udev 0.056-3 (using .../archives/udev_0.070-2_i386.deb) ...udev requires a kernel >= 2.6.12, upgrade aborted.
dpkg: error processing /var/cache/apt/archives/udev_0.070-2_i386.deb (--unpack): subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/udev_0.070-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


so I figured fine, I'll upgrade the kernel, so when I do this:

apt-get install linux-image-2.6.12-1-686

I get the following:
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
gnome-desktop-environment: Depends: sound-juicer but it is not going to be installed
Depends: totem (>= 1.0.4) but it is not going to be installed
Depends: vino (>= 2.10.0) but it is not going to be installed
Depends: zenity (>= 2.10) but 2.8.2-1 is to be installed
gnomemeeting: Depends: libopenh323-1.15.3c2 (>= 1.15.3) but it is not going to be installed
Depends: libpt-1.8.3c2 but it is not going to be installed
hal: Depends: udev (>= 0.063) but 0.056-3 is to be installed
libpt-plugins-oss: Depends: libpt-1.8.3c2 (= 1.8.4-2) but it is not going to be installed
libpt-plugins-v4l2: Depends: libpt-1.8.3c2 (= 1.8.4-2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



I'm not sure what to do here, I cant apt-get a new kernel until running apt-get -f install, and I cant do that until I have a new kernel..... is there a way to just force the damn kernel to install? oh, and yes I tried a --force-yes when installing the kernel, and no dice.... get the same error.
TIA
Abzstrak
 
Posts: 3
Joined: 2005-10-09 14:40

Postby startx » 2005-10-09 15:38

well, its a big step to upgrade from stable to unstable.
however udev needs a 2.6 kernel. maybe you remove udev first and then try to go on?

did you run apt-get dist-upgrade as well?
debian squeeze for everyday life, many other versions for the rest
User avatar
startx
 
Posts: 180
Joined: 2004-09-16 12:14
Location: london

Postby Jeroen » 2005-10-09 16:48

Better also use aptitude.

Other than that, try to force matters a bit. --force-depends might give you the possibility to install the kernel. However, your current situation is quite wedged already, might be tricky to resolve. That's what might happen when you run unstable.

Good luck!
Jeroen
Debian Developer, Site Admin
Debian Developer, Site Admin
 
Posts: 571
Joined: 2004-04-06 18:19
Location: Utrecht, NL

Postby Abzstrak » 2005-10-09 17:32

I guess I should add I was already running the 2.6.8 kernel... force-depends says its not understood...

I thought maybe I could chroot in from knoppix, but its only running 2.6.11 so the stupid udev still wont upgrade.
Abzstrak
 
Posts: 3
Joined: 2005-10-09 14:40

Postby Jeroen » 2005-10-09 17:35

Purge udev, or force it to upgrade... dpkg --purge udev works. Or eh, edit the check for your kernel version and comment it out. It's a hack, yes.
Jeroen
Debian Developer, Site Admin
Debian Developer, Site Admin
 
Posts: 571
Joined: 2004-04-06 18:19
Location: Utrecht, NL

Postby Abzstrak » 2005-10-09 17:56

thank you, purging udev seems to have done the trick ;-)
Abzstrak
 
Posts: 3
Joined: 2005-10-09 14:40


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable