Browse a CD in CLI?

If none of the more specific forums is the right place to ask

Browse a CD in CLI?

Postby Carlosinfl » 2005-10-11 22:02

I have just inserted a CD-R with some files into my only optical drive on the Debian machine and I am trying to understand how I can browse these files and copy them to their own directory I created for them.

When I go to /dev - there is a huge list of things so I am obviously in the wrong spot.

I then go back to the / dir and check /mnt & /cdrom however I think I maybe missing something. Can someone please tell me what I am doing wrong.

Thanks.
Carlosinfl
 
Posts: 889
Joined: 2005-02-05 06:11
Location: Orlando, FL

Postby Carlosinfl » 2005-10-12 14:06

I have since now tried the following and any help is greatly needed and appreciated!

Code: Select all
debian:~# mount -a /dev/hdc /mnt/cdrom
mount: you must specify the filesystem type
debian:~# mount -t iso9660 /dev/hdc /mnt/cdrom
mount: mount point /mnt/cdrom does not exist
debian:~# mount /media/cdrom0
mount: special device /dev/hdc does not exist
Carlosinfl
 
Posts: 889
Joined: 2005-02-05 06:11
Location: Orlando, FL

Postby dawgie » 2005-10-12 14:06

After you insert the CD, mount it:
$ mount /cdrom
When you are finished, unmount it and then you can remove it.
$ umount /cdrom
If this dosen't work the post your /etc/fstab file here.
User avatar
dawgie
 
Posts: 431
Joined: 2004-06-16 21:30
Location: New Hampshire USA

Postby Carlosinfl » 2005-10-12 14:12

Code: Select all
debian:~# su carlos
carlos@debian:/root$ mount /cdrom
mount: special device /dev/hdc does not exist


Here is my /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 defaults,errors=remount-ro 0 1
/dev/sda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
Carlosinfl
 
Posts: 889
Joined: 2005-02-05 06:11
Location: Orlando, FL

Postby inconnu » 2005-10-12 16:19

from my fstab:
Code: Select all
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   iso9660 ro,user,noauto  0       0


I can mount with: $ mount /dev/hdc
Debian GNU/Linux 3.1
inconnu
 
Posts: 60
Joined: 2005-09-04 05:56

Postby Carlosinfl » 2005-10-12 16:30

OK - I found the issue and was supprised nobody said this. I thought all out systems were set up simular.

Here is what I did:

Code: Select all
debian:/# ls
bin   cdrom  etc   initrd      initrd.img.old  lost+found  mnt  proc  sbin  sys  usr  vmlinuz
boot  dev    home  initrd.img  lib             media       opt  root  srv   tmp  var  vmlinuz.old
debian:/# cd media/
debian:/media# ls
cdrecorder  cdrom  cdrom0
debian:/media# cd cdrecorder/
debian:/media/cdrecorder# ls
Finch              Mit Gas   Prodigy      Taking Back Sunday  Underoath
Hawthorne Heights  Mudvayne  Senses Fail  Team Sleep          War All the Time


As you can see I have a /media dir that for some reason has cdrecorder | cdrom | cdrom0

I just changed to the cdrecorder and now I can see all my MP3 folders.

Can someone tell me why I have 3 options under /media when I only haev once CDROM drive?
Carlosinfl
 
Posts: 889
Joined: 2005-02-05 06:11
Location: Orlando, FL


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable