What is wrong with my Debian

If none of the more specific forums is the right place to ask

What is wrong with my Debian

Postby Guest » 2005-12-10 22:22

It just keeps getting worse and worse and I don't know what's wrong with my Debian. First Pico (Nano) started not backspacing but doing the opposite (deleting from the other direction) and now the Aptitude search field does too. Where is the setting for this? I actually looked through the Nano options and there is a preference, but it was off! This is surprising crippling my ability to use my system!
Guest
 

Re: What is wrong with my Debian

Postby jobezone » 2005-12-11 02:17

Anonymous wrote:It just keeps getting worse and worse and I don't know what's wrong with my Debian. First Pico (Nano) started not backspacing but doing the opposite (deleting from the other direction) and now the Aptitude search field does too. Where is the setting for this? I actually looked through the Nano options and there is a preference, but it was off! This is surprising crippling my ability to use my system!

Try reconfiguring the console-common package, which handles your keyboard's console keymap:
Code: Select all
dpkg-reconfigure console-common

This if you're using these programs in any of the virtual terminals.
The Debian Documentation website contains the FAQ, Installation Manual and the Release Notes for Etch. They're helpful if you want to learn more about debian!
User avatar
jobezone
 
Posts: 220
Joined: 2005-06-12 07:20
Location: Portugal

Worked???

Postby Guest » 2005-12-11 06:24

I got this, and have been getting this a lot lately. In fact I can't find any info on it.

---------START

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_CA",
LC_ALL = (unset),
LANG = "en_CA"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Looking for keymap to install:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_CA",
LC_ALL = (unset),
LANG = "en_CA"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
NONE
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_CA",
LC_ALL = (unset),
LANG = "en_CA"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Cuttle:~#

---------FINISH
Guest
 

Postby lacek » 2005-12-22 08:42

It seems that the system doesn't recognize the locale you try to use.
A 'dpkg-reconfigure locales' will probably help you.
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary


Return to General Questions

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable