apt-get update missing package list error

If none of the more specific forums is the right place to ask

apt-get update missing package list error

Postby john_h » 2006-01-16 21:50

For some time now, I've been having frequent problems when running apt-get update or aptitude update.
Code: Select all
W: Couldn't stat source package list ftp://security.debian.org sarge/updates/main Packages (/var/lib/apt/lists/security.debian.org_debian-security_dists_sarge_updates_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list ftp://security.debian.org sarge/updates/contrib Packages (/var/lib/apt/lists/security.debian.org_debian-security_dists_sarge_updates_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to update the package lists to correct these missing files
W: You may want to run apt-get update to correct these problems

Until recently, multiple running of apt-get update (say four or five times in succession) would clear this, but in the past few days I've been unable to shake this off at all.

Here are the entries for the Debian repositories from my sources.list:
Code: Select all
deb http://ftp.uk.debian.org/debian sarge main contrib non-free
#deb-src http://ftp.uk.debian.org/debian sarge main contrib non-free

deb ftp://security.debian.org/debian-security sarge/updates main contrib non-free
#deb-src http://security.debian.org/debian-security sarge/updates main contrib non-free

deb http://ftp.uk.debian.org/debian etch main contrib non-free
#deb-src http://ftp.uk.debian.org/debian etch main contrib non-free

deb http://security.debian.org/debian-security etch/updates main contrib non-free
#deb-src http://security.debian.org/debian-security etch/updates main contrib non-free

deb http://ftp.uk.debian.org/debian sid main contrib non-free
#deb-src http://ftp.uk.debian.org/debian sid main contrib non-free
john_h
 
Posts: 220
Joined: 2005-11-17 13:01

Postby dawgie » 2006-01-17 18:51

Mine is:
deb ftp://security.debian.org/debian-security sarge/updates main contrib non-free

Seems to work ok.
User avatar
dawgie
 
Posts: 431
Joined: 2004-06-16 21:30
Location: New Hampshire USA

Postby clydefrog » 2006-01-19 16:31

You could try a quick apt-get clean and another apt-get update and see if that helps? It may be that you were hammering the repo when an update was occurring, as this has happened to me before, but I just waited a couple of hours to try again.....
clydefrog
 
Posts: 20
Joined: 2006-01-19 15:51
Location: Norwich UK


Return to General Questions

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable