Another mplayer question

If none of the more specific forums is the right place to ask

Another mplayer question

Postby toadleyb » 2006-01-21 15:54

I have added deb ftp://ftp.nerim.net/debian-marillat/ sid main (I am running sid) to my sources.list and installed mplayer-586, mozilla-mplayer, and w32codecs using synaptic. When I try to view a streaming video I get a box that says mplayer plugin and shows the url of the stream along with a progress bar. I get sound but no video. I have a Nvidia Geforce4 MX440 with the nvidia drivers installed.

Anyone have any ideas?
toadleyb
 
Posts: 13
Joined: 2006-01-05 14:22
Location: Vermont

Postby dawgie » 2006-01-21 21:51

Location: Vermont

Hi Neighbor!

Does mplayer (not the plugin) work OK?
What is the site?
There are loads of types and combinations of various audio and video formats.
You could give another viewer a try:
# apt-get install vlc mozilla-plugin-vlc
User avatar
dawgie
 
Posts: 431
Joined: 2004-06-16 21:30
Location: New Hampshire USA

Postby toadleyb » 2006-01-22 11:19

Hey neighbor, where abouts in NH are you?

Got it working. When I tried to open Mplayer I was getting a font error. I corrected that. Then when I tried to view a clip in the browser I was getting the same thing sound but no picture. I right clicked on it and configured the video now all is well.

I am unable to install VLC because of missing dependencies dbus-1 and libhal0.

Thanks for the help.

Todd
toadleyb
 
Posts: 13
Joined: 2006-01-05 14:22
Location: Vermont

Postby yazdzik » 2006-01-23 03:10

Dear Friends,

vlc will definitely not install with the latest 5x hal and friends - I miss it.

mplayer has a number of issues, most of which are resoluble through the config files.

for instance, in order to avoid the sound synch issue in kanotis, one must eidt the config files in home.

Now, for instance, mu gui config file:

Code: Select all
enable_audio_equ = "no"
vo_driver = "x11,"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "no"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "0"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
a_afm = "libmad"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/dev/dvd"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
sub_pos = "100"
sub_overlap = "no"
font_factor = "0.750000"
font_text_scale = "5.000000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "yes"
cache_size = "1024"
playbar = "yes"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "no"
autosync = "no"
autosync_size = "0"
gui_skin = "default"


shows the text file for the options I chose in the gui configuration thingy.

Of interest here is what your drivers and codecs are showing.

Do you have OSS as well as Alsa available, or, for devices that damned well only want alsa are you using oss simulation?

What video driver are you using for the card, and why not simply chose X11?

What happens if you use mplayer from the command line to play a file,


such as mplayer /home/martin/blahblah.wmf or mp4 or whatever?

Then, are you using mozplugger or mplayer-mozilla?

Ignore the font issue now, as it is not part of the problem.

First, therefore, verify that maplayer works perfectly from the cli, or send us the output if it does not.

Then and only then is the plug in an issue.


Best,

martin
yazdzik
 
Posts: 9
Joined: 2006-01-03 01:12
Location: new york


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable