apt-get overwriting error

If none of the more specific forums is the right place to ask

apt-get overwriting error

Postby djb » 2006-01-27 13:22

I keep getting this error and can't get passed it.

part of kde is broken and this is preventing it from being fixed.

E: /var/cache/apt/archives/kdelibs-data_4%3a3.5.0-3_all.deb: trying to overwrite `/usr/share/mimelnk/image/x-djvu.desktop', which is also in package libdjvulibre15

is there a way round it? I've tried removing libdjvulibre15, but stops with dependency errors.

thanks
dave
djb
 

Re: apt-get overwriting error

Postby simen » 2006-01-27 16:47

If you do:
Code: Select all
dpkg -i --force-overwrite /var/cache/apt/archives/kdelibs-data_4%3a3.5.0-3_all.deb

it should install by overwriting libdjvulibre15's files, if dependencies are met etc. That's what you're asking how to do, right?

Regards,
--Simen
User avatar
simen
 
Posts: 206
Joined: 2005-07-02 15:00
Location: Berlin

Re: apt-get overwriting error

Postby djb » 2006-01-27 17:42

Thanks Simon

It worked.

dave
djb
 

Postby Jeroen » 2006-01-27 17:44

This situation should never arise and is always a bug in either of the two packages. Consider filing one if you were doing a routine unstable->unstable upgrade or so, and there were no unofficial packages involved and/or you did some weird things before that might have caused this.
Jeroen
Debian Developer, Site Admin
Debian Developer, Site Admin
 
Posts: 571
Joined: 2004-04-06 18:19
Location: Utrecht, NL


Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable