Suddenly missing apachectl?

If none of the more specific forums is the right place to ask

Suddenly missing apachectl?

Postby frenetic » 2006-01-29 19:18

After 44 days of uptime, I went to access my web server and it didn't respond. I SSH'd in and found apache wasn't running. I tried to start it and got this error:

Starting web server: Apache2env: /usr/sbin/apache2ctl: No such file or directory

Huh? I went and had a look at the /usr/sbin/apache2ctl and saw this:

lrwxrwxrwx 1 root root 27 2005-11-26 16:52 apache2ctl -> libkommanderplugin.so.0.0.0

I can't run it. The last thing in my apache error log is this:

[Sun Jan 29 04:32:31 2006] [notice] caught SIGTERM, shutting down

I've tried apt-get removing apache2 and reinstalling it, but get the same thing. Anyone know what the heck is going on? I haven't changed anything on the machine, nobody else has access to it.
frenetic
 
Posts: 1
Joined: 2006-01-29 19:06

Postby kink » 2006-01-30 10:20

This smells very fishy. If you didn't change that, I'd guess that your system has been hacked... Did you notice other strange behaviour? Tools like debsums and chkrootkit can provide a good first assessment to spot obvious trouble.
User avatar
kink
Debian Developer, Site Admin
Debian Developer, Site Admin
 
Posts: 287
Joined: 2006-01-02 16:47
Location: Utrecht, The Netherlands


Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable