Keyboard LAyout problem in Debian 4

If none of the more specific forums is the right place to ask

Keyboard LAyout problem in Debian 4

Postby namco » 2009-01-21 15:37

Hello everybody
i am from azerbaijan and i am new in debian....
after first using i liked debian...
it works very fast and without any problems...
but i have a little problem with keyboard layouts....
i want to add azeri latin keyboard layout but there is only azeri cyrillic layout....
and in here nobody uses cyrillic....
if you can help, please tell me how can i solve this problem,
how can i add azeri latin keyboard layout for writing....
THANK YOU
namco
 
Posts: 3
Joined: 2009-01-21 15:30

Postby Lou » 2009-01-21 20:00

Have you tried:

# dpkg-reconfigure console-data

it should guide step by step :)
Devuan Jessie - IceWM - vimperator - no DM
KISS - Keep It Simple, Stupid
Lou
 
Posts: 1775
Joined: 2006-05-08 02:15

Re: Keyboard LAyout problem in Debian 4

Postby Issyer » 2009-01-21 22:06

namco wrote:Hello everybody
i am from azerbaijan and i am new in debian....
after first using i liked debian...
it works very fast and without any problems...
but i have a little problem with keyboard layouts....
i want to add azeri latin keyboard layout but there is only azeri cyrillic layout....
and in here nobody uses cyrillic....
if you can help, please tell me how can i solve this problem,
how can i add azeri latin keyboard layout for writing....
THANK YOU


Have you tried to ask your government to switch back to Cyrillic?

Code: Select all
/usr/share/X11/xkb/rules/base.lst


! layout
us USA
ad Andorra
af Afghanistan
ara Arabic
al Albania
am Armenia
az Azerbaijan
by Belarus
be Belgium
bd Bangladesh
in India


! variant
euro us: With EuroSign on 5
intl us: International (with dead keys)
alt-intl us: Alternative international (former us_intl)
colemak us: Colemak
dvorak us: Dvorak
dvorak-intl us: Dvorak international
dvorak-l us: Left handed Dvorak
dvorak-r us: Right handed Dvorak
dvorak-classic us: Classic Dvorak
dvp us: Programmer Dvorak
rus us: Russian phonetic
mac us: Macintosh
altgr-intl us: International (AltGr dead keys)
olpc2 us: Group toggle on multiply/divide key
ps af: Pashto
uz af: Southern Uzbek
olpc-ps af: OLPC Pashto
olpc-fa af: OLPC Dari
olpc-uz af: OLPC Southern Uzbek
azerty ara: azerty
azerty_digits ara: azerty/digits
digits ara: digits
qwerty ara: qwerty
qwerty_digits ara: qwerty/digits
buckwalter ara: Buckwalter
phonetic am: Phonetic
phonetic-alt am: Alternative Phonetic
eastern am: Eastern
western am: Western
eastern-alt am: Alternative Eastern
cyrillic az: Cyrillic
winkeys by: Winkeys
latin by: Latin
User avatar
Issyer
 
Posts: 3055
Joined: 2007-05-23 02:59
Location: Khakassia

Postby namco » 2009-01-24 10:44

Ok, but how to change keyboard layout to azeri latin.
namco
 
Posts: 3
Joined: 2009-01-21 15:30

Postby Issyer » 2009-01-24 15:29

namco wrote:Ok, but how to change keyboard layout to azeri latin.


Are you sure it exists?
User avatar
Issyer
 
Posts: 3055
Joined: 2007-05-23 02:59
Location: Khakassia

Postby namco » 2009-01-26 10:28

of course yes,
in ubuntu, in fedora in opensuse there is an azeri latin keyboard layout.
and i dont believe that in debian it's impossible.
If you can help me please, its very important for me
namco
 
Posts: 3
Joined: 2009-01-21 15:30

Postby hameau » 2009-01-26 16:13

Hello,

Is that a 'qüerty' layout? If so, do you have 'Azerbaijan default' option in the keyboard layout selector? That's where it is in Lenny. The two options are 'default' and 'cyrillic'.

It doesn't show in the 'dpkg-reconfigure console-data' lists, so I presume it's for X only.
Nick.
hameau
 
Posts: 257
Joined: 2008-11-13 17:42
Location: France

Postby Issyer » 2009-01-26 23:35

namco wrote:of course yes,
in ubuntu, in fedora in opensuse there is an azeri latin keyboard layout.
and i dont believe that in debian it's impossible.
If you can help me please, its very important for me


If you are so sure put into your /etc/X11/xorg.conf something like this:

Code: Select all
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us,az"

   Option      "XkbOptions"   "grp:rwin_toggle,grp_led:scroll"
EndSection


Note: Option "XkbVariant" "cyrillic" is excluded.

Hope that helps.
User avatar
Issyer
 
Posts: 3055
Joined: 2007-05-23 02:59
Location: Khakassia

Re: Keyboard LAyout problem in Debian 4

Postby sina » 2018-12-25 11:21

Hello dear friends,
I am using Debian GNU/Linux 9.6 (stretch) for few months. Today I decided to add Azerbaijani(Latin) language layout to my keyboard and I failed. First I tried the native keyboard setting of Debian and it only gives the Azerbiajani(cyrillic) and I think that it is several years that the official language alphabet in the country is changed to Latin version. Then I tried Ibus and unfortunately Azerbaijani was not among of them. I also tried
Code: Select all
dpkg-reconfigure console-data
and it didn't show any option for Azerbaijani. Is it possible to add Latin version of Azerbaijani? I have used it frequently in Ubuntu or Manjaro.
sina
 
Posts: 2
Joined: 2018-12-25 11:10

Re: Keyboard LAyout problem in Debian 4

Postby sina » 2018-12-25 11:56

Actually I was able to add Azerbaijani keyboard layout just by using the native keboard setting. The problem was that the list of the languages are in the tree form and If you click on + sign in front of Azerbaijani language it will expand and the only given option is cyrillic while if you just click on the +Azerbaijani which is the title of the expanded subtree, you can add the new layout in Latin form.
sina
 
Posts: 2
Joined: 2018-12-25 11:10


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable